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Express
Do-It-Yourself Guide
With Projects for Training Purposes

Welcome!

Thank you for acquiring CADSTAR Express. This free version provides a number of features used in the
full CADSTAR version, only limited by the number of components (max 50) and pins (max 300).

Electronic hobbyists, Students and Evaluators use CADSTAR Express for designing Schematics and
Printed Circuit Boards (PCB). This guide will assist you in detail on how to make use of CADSTAR’s
features to design your next project.

e We will start by showing you a hand drawn electronic circuit and transforming it into a professional
schematic design.

o We will guide you through the process of creating an error-free transfer of data to a PCB board
design, and then move to component placement and wire routing.

¢ You will then move to the CAM output process where you will generate the necessary artwork,
reports and files needed to get your PCB built by your preferred fabrication vendor.

e We will guide you through the process of creating schematic symbols, component and parts for
future CADSTAR libraries.

Upon completion of this guide, you will be ready to move into higher variations of CADSTAR, offering
features and constraints for High Speed signal applications and simulation as well as 3D Electro-
Mechanical collaboration.

To provide you with additional “how to” information, click on the camera icons for demonstration videos.
(internet connection required)

The videos are for demonstration purposes only. They are not created to match the exact
instructions in the task steps. Please follow the specific steps in the tasks.

When CADSTAR Express is executed this PDF Document will appear for your convenience. If you have
not installed CADSTAR Express, simply double click on the executable for set-up and follow the
instructions.

As you work through the tasks in this guide, you will be instructed to save files with suggested
file names. If you do not finish a task and simply wish to move on to the next task, back-up files
are supplied for your convenience. Files with the “_CS.*” suffix can be opened and then saved
using the File=>Save as function to overwrite the file you are working on.

Enjoy!

The information in this document is correct at the time of publication and is subject to changes without prior notice. This
document belongs to Zuken. No part of this document shall be copied without official written approval.

CADSTAR is registered trademark of ZUKEN.

This document is given free of charge and is not for resale. Ver 2018.0
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Introduction to CADSTAR =H

CADSTAR is an EDA design tool allowing you to draw schematic designs and transfer them to the PCB
layout environment. After an error-free transfer, CADSTAR helps to place the components into the board
outline.

Placement and Routing is an integral part of a PCB design process. CADSTAR offers much flexibility in
this area by providing both Push-aside Placement and Routing tools (manual, semi-automatic and fully
automatic) within the Embedded Place & Route Editor or the advanced standalone Place & Route Editor.
The Embedded Place & Route Editor has been developed in general for basic PCB design or users who
don’t use a PCB design tool regularly, and the standalone Place & Route Editor is for the more advanced
users who require more powerful functions. For really advanced users (industry users) high-speed design
features (such as lengthening, delay, impedance, cross-talk, overshoot, reflection etc.) can also be
provided in a full standard package or as an optional add-on. The additional add-ons that are available
to you, include BoardModeler Lite which is a unique 3D verification tool for PCB design that provides a
completely new concept of PCB Design in a 3D environment or the CADSTAR Variant Manager which
enables you to generate variants of a 'master' design (included B.O.Ms and assembly drawings) without
having to maintain separate files for each variant.

The completion of the PCB design is followed by the generation of manufacturing output data for PCB
fabrication.
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Getting Started

By now you have probably installed CADSTAR on your PC and are anxious to get started. Start by
clicking the Design Editor Icon in your Start 2All Programs 2CADSTAR Express 2018.0 menu. When
CADSTAR is started you will see the Start page as shown below.

suB|saq uado @

ubjsaq walng @]

Recent Workspace Files

[8] cusers\Public\Zukem CADSTAR Express 18.0\Self_\Express_18.csw
‘ » Q4

Open Workspace... Save New Workspace...

Recent Design Files

\;\8

CAbSTAR

T Electronic Component nmu@
| | r...... -

SEARCH ENGINE

/ Free PCB design produétmty app
7 for |OS & Andr0|d

CADSTAR Redlining, coming soon!

~ ) As part ofthe CADSTAR 18.0 release in June 2017, Zuken
Open File... New File... will launch a new optional module: CADSTAR Redlining.
The new module allows engineers, PCB designers and

manufacturers to review and mark-up designs, improving

Getting Started

communication between multidisciplinary teams, enable @
you to add text remarks to the original design and let you to

& What's New CADSTAR OnlLine search, jump andrace remarks
Click here to watch the movie, or
ey )
& CADSTAR Help CADSTAR News & Events Click here to read more about the optional madule, or -
. Click here to download the datashest, or
@ CADSTAR Express DIY Click hare tn contact A sales renresentative for nrice infarmation
[ 4
Load this page on application start. ~ ZUKEN

q M startrage H b
[E] BusReport |[#] DesignRuleErrors | 3] Electrical Rules Check | [H] Overlapping Connections  |[g] Routing Completion  |[8] Unused Components %! Name Range By Sheet & Rediining

Home Library Tools View A9
N E @ Iaeeo
New  Open  Open Save New Help
Workspace  Workspace
New Open Save Documentation
o, . . . B
: | M CADSTAR Express Design Editor 18.0
2 5
@
=
2

® OnLine CADSTAR News Reader

salpadold adeyg I'..u

It allows you to;

Access recently opened Workspace Files.
Access recently opened Designs.
Access Help and PDF files.

Read up on the latest in CADSTAR News from the World of Zuken.
Access some On-line Links such as the CADSTAR Web pages.

CADSTAR is a Multi-Document Design Environment. Soon you will have schematic designs and PCB
designs all open in the same Design Editor environment.
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The Basic Design Flow

Library

Schematic

PCB
(Placement)

PCB
(Routing)

Manufactu-
ring Output

Usually you need to start off with a library to ensure that all the parts (schematic symbols
& PCB footprints) required for your design are available to you. However, to complete the
exercises in this guide, all parts have been provided. When you are ready to create new
parts in the CADSTAR library, please study chapter 3.

Note: the library provided with CADSTAR Express contains all the parts required for the
PCB designs described in this 'Do-It-Yourself’ guide as well as some examples from the
on-line CADSTAR Libraries. (Accessing the CADSTAR On-line libraries requires a
higher variation of CADSTAR and an active maintenance contract).

A free download of parts libraries containing 20.000 Parts is available on the website.

Additional libraries are available through the Zuken on-line support website.

The ready-to-download-and-use parts contain all the information required, including
manufacturers' part numbers. They are updated and expanded regularly with over
250,000 parts available. If the part required is not available in these libraries, you can
quickly and easily design your own parts using the supplied wizards and the Graphical
Library Editor.

It is always advisable to start with a schematic design before moving onto the
PCB design, although CADSTAR does support reverse engineering with full back
annotation capabilities.

After the successful transfer from schematic, components will be placed within the
board outline and respective placement areas.

After placing all the components, we can start routing the critical nets manually and/or
through automatic routing.

The final stage of any PCB design. No matter what your manufacturer requires,

CADSTAR can deliver; extended Gerber (RS274X), extended N.C. Drill (Excellon),
Placement data, Bill of Materials, IPC356-D test data, DXF and ODB++
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The User Interface

=H

CADSTAR is very easy to use! The User Interface is very consistent in operations whether you are
editing a Schematic or a PCB Design.

CADSTAR Supports;

Ribbon style Tool bars can be dragged and docked as needed

Tool bar Icons that can be allocated as the user wishes

Customizable Tool bars and Menus are supported for adding user defined reports and
Macros

Tabbed Document Window support — Most often seen in more modern version of Windows
10 and MS Office ®

“Strokes” - command macros that perform the most common functions for panning and
zooming

Omnidirectional panning by depressing the middle mouse button or <M.M.B.>

Themes to alter the appearance of CADSTAR when working in a more modern operating
system, “Windows 10", such as Collapsible Menus for a more condensed menu appearance
Active HTML reports — Active HTML reports can be placed anywhere just like any other
dockable window in CADSTAR. The reports you currently have open will appear as tabs in
the Active Report window
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Strokes in CADSTAR and the Place & Route Editor

If you are not familiar with Stroke commands, you can use them for;

Indicating operations you wish the application to perform by dragging the right mouse button in the
shape of one of the 'gestures' in the table below.

To make the gesture:

e Use the mouse to position the cursor in the design window

o Click the Right Mouse Button or <R.M.B.> and Hold while moving the mouse so that the cursor
follows the path of the gesture. The application will provide feedback by drawing a white line
showing the path of the cursor

¢ Release the right mouse button

Note: The shape of the path followed by the cursor is important. The direction which the cursor takes
along the path is also important, since it is often true that each of the two different directions is
associated with a different operation.

Gesture Icon Operation Gesture Icon Operation

IZ’ Panup — [ Pan left

L Pan down _— |: | Pan right

Zoom in @ Zoom out

Zoom to selected
View all area
@ (Disp!ag-r all o_f the (the minimum box
drawing/design or which contains both
component/symbol) the start and end
points)

Redisplay the current
3 view, repairing any

damage to the

objects displayed

Zoom to selected

area

[see above]

Previous View
Revert to the view
@ as it was before the

last view-chanaging
command such as
pan or zoom

J TSN
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Chapter 1 — Design A

Introduction to the Amplifier circuit

ZN3B53
1N4145 3 o
H | 5 & Ohm
o Speak
* In4148 33 B S
5.5}42%
- ZNZ9058
5 | " 2nams3
Tnput
47UF
15K 22

Transistor Audio Amp (50 mW)

Information on Design A - Transistor Audio Amplifier

Here is a little audio amplifier, similar to what you might find in a small transistor radio. The input stage
is biased so that the supply voltage is divided equally across the two complimenting output transistors,
which are slightly biased in conduction by the diodes between the bases.

A 3.3 Ohm resistor is used in series with the emitters of the output transistors to stabilize the bias current
so it doesn't change much with temperature or with different transistors and diodes. As the bias current
increases, the voltage between the emitter and base decreases, thus reducing the conduction.

Input impedance is about 500 Ohm and voltage gain is about 5 with an 8 Ohm speaker attached. The
voltage swing on the speaker is about 2V without distorting and power output is in the 50mW range. A
higher supply voltage and the addition of heat sinks to the output transistors would provide more power.
The circuit draws about 30mA from a 9-12V supply.
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Step 1 - Schematic for Design A

Start by reviewing the hand drawn schematic shown previously - the design of the audio amplifier. You
will then have to gather the components being used in the circuit

From the hand-drawn schematic, you will find twelve (12) parts in the Library. They are;

Qty. per Part

G FRLNNEDN

You can use a 9V battery for this power supply.

EH

2N3053 NPN Transistor
2N2905A PNP Transistor
1N4148 Diode
3.3 Ohm Resistor (S3E3-MRS25-1%)
22 Ohm Resistor (22E-MRS25-1%) -
SOLDEREYE 1MM (for Input, Speaker and 9V supply)

one of the templates such as Form A3-euro.

ﬁ\i—!ome Library
\ ~
=

Nileygs

=
Open
Workspace

Open

Tools View

I
Save Mew User .
Workspace | Guide L5 Self Teach

1 470 Ohm Resistor (470E-MRS25-1%)

1 1.5 kOhm Resistor (1K5-MRS25-1%)

1 5.6 kOhm Resistor (5k6-MRS25-1%)

1 47uF/10V Elec. Cap (47uF-10V-EC)

1 1000uF/50V Elec. Cap (1000uF-50V-EC)

45‘ TB| SCM Self Teach
T&| PCB Self Teach

? ]

Help

1. Click the New icon on the [Home] tab or select [File] tab=>New [Schematic Design] and choose

New =X5)
Schematic Design | PCE Design | Schematic Symbol I PCE Componert I Documentation Symbo||
T N Ty ) L
s PE3 B3 B
Defaults Fom A1 Form A2 Form
ASEURO Description
g E E g Ad-euro -Size Sheet
=1 =1 =1 == E
Form Form B1 Form B2 Form C1
A4-EURO
s PE3) B3 P
== =1 == ==
Form C2 Form D1 Form D2 Form E1
— -
Template Folder V| View Mew Design Settings
C\Users"Public\Zuken\CADSTAR Express ¢\ Templates
oK | [ Camcel |[ Hel

Once you select a template you are prompted with parameters to enter information using the
Attributes that have been created for you.
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If you like, enter your company name and personal name in the attribute fields below.

These will appear in the Title block of
the Schematic format symbol. Later
you can easily customize your own
attributes and format sheets.

TIP: If you don't like to work with a
black background, you can also select
a different background colour scheme
from the toolbar.

(7) |\ White Background SCM

Click [OK]

Note: If you are creating larger schematics using many
to declare
designator name ranges By Sheet. Clicking the button
shown above will display the dialog shown below. For
this design we will only need one sheet.

sheets, you may choose

New 5CM Design

Design Title
Ad-euro -Size Shest

Murmber of Decimal Places: 1

G ype:

Units
Urits: [Thousandths afaninch =
Dizplay gnd
e Y
Dizplay grid Step: 100.0 100.0
Colour Template
[DEFAULT]

7

Colour File :

Mame Fange By Sheet
Mame Range By Sheet is disabled

Mame Range By Sheet ... ]

Altributes
Doc Sym Referencel Doc Sym Position/ -
SIS Attribute Name Attribute Value
Sheet1 = E
E FORMAT{A3-EURD) (12000.0,1000.0)
Checked JL
Company name Zuken
Drawn AB I_
leciad nomE  mm— E—— o —
[ QK ] [ Cancel ] [ Help
Mame Range By Sheet
reference
From 101 - Populate
Step 100 -
Hinimum Lenath
£z From To
Name
1 | Sheetl

You have just started a new ’E
untitted, schematic  design. || New
Select the [File]>Save as...] || 0Open
Name it DesignAl.scm [ save
EISEWE As
§Re|oad
l__fCIose

’ Load... ] ’ Save.. ] ’BepoltDptions...]

10

o |

[

Cancel] ’ Help ]
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Eﬂ You can now start to add the parts and symbols required using the Libraries auto-hide panel on the
left of the application window. For a demonstration click the camera Icon.

Note: The Auto-hide panels for Libraries, Designs, Shape Properties, etc., can be automatically hidden
if you wish. Simply click the Auto Hide Icon shown below. When you move your cursor off of the
workspace panel it will automatically slide to a hidden position. To show the panel again, drag your
cursor back to the desired Workspace panel tabs on the left-side of the application window. When it
appears click the Auto Hide push pin icon to hold it open.

A TN T N M T

File Home Symbal Net / Shape Design Hierarchy Library Report Tools View (A7)

|8 Schematic Symbols A | & part sl

= e B
] PCB Compaonents ¥, Symbol

Parts Library Library Duplicate Where-used

Bl Documentation Symbols | searcher Editor Report  (library)
Manage Tools Edit Check
Libraries L=
Ly
B 1K5-MRS25-1% N . HIg%
- B 1K5-r0803-2%
- B 1N914
B 1N3593 = - -l -
- E 1N40DT
- B 1N4148
B 1N4T28A B °
| 16264
- B 1nF-c0805-10%
-~ B TuF-c0805-20/100%
B 1VIKE1004
@ 25mm PWR CON ¢ B ol @
- B 2K0-TR4-1%
B 2K7-TR4-1%
- B 2N1613 = = Bl =
- B 2MN21934A
B 2N2222
- E 2N2904A
- B 2N2S03A
B
| 2N33% Add to Design

-~ 2N366 — = =
m@ 2N3%0 inks On-line CADSTAR Datasheet o E

| 2N70D 1039(EBC) URL to manufacturers PDF datasheet

< u
S_NPN(S_NPN_T) - ==

[
L ]

subjsag usdo gl
sajpadoid wey El

ublsagiuaing [g]
saadold adeus G

o, Edit Part —_—
Y ZVKEN |o| 7
==
I = == =
B oo | |
. 1 I 2 ! 3 1 Fi ! = ! 5 | == T = == g= -
T 1 i T L:] T [ T 1 T L 1] ] F L8 b
< 2>
4 M Start Page Untitled:1 - Sheet1 B 3
[E] BusReport |[@] DesignRule Errors |j#] Electrical Rules Check  |[H] Overlapping Connediions | [§] Routing Completion | g@] Unused Components u%1 Mame Range By Sheet & Redlining
38.8 7438.1 Thou Grid: 25.0

Tip: When adding the part/symbols into the design (like 2N3053), you can select the symbol
and click on the right-hand mouse button <R.M.B.> to see a Link: On-line CADSTAR
Datasheet. The link is a hyperlink to a URL on the internet (or intranet), but can also be
linked to something different (i.e. PDF file or Word document). More links can be added
to parts in the CADSTAR Parts Library Editor. Be aware that some links might be out of
date as the part may be obsolete.
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Add Parts and Symbols

For advanced library searching and filtering try one of the additional following methods. Both
allow you to specify which alternate symbol to use if available.

e From [Library] tab click the Library Searcher function. Select the Parts.lib (or any of the
other Parts Libraries you want to search).
t / Shape Design Hierarchy Library Report
ry
A Ve 7> Part i EE
= 'ﬂ% " Symbol =
Library | Library Duplicate Where-used
Searcher| Editor Report {library}
Tools Edit Check
7| Library Searcher - PARTS =n ECH <
S| K| e
—l_j Libraries Fart Name Librany Library Path |CDmpDnent |Symbn|
=] CADSTAR | [2nz052 <L ibravy Filters |<Library Path Filter= | <Component Filters Symbol Filters  +
—1'_-:‘ Parts q o
1 lﬂ dump Part Name Library Library Path |5ymbn| ks
2N2052 CADSTAR Express 3SERC] 5_MPM[S_MNFPM
4
S_NPM[S_MPN_1] to39(EBC] I [Default Alkernate] -
4 1 3
e [Symbol] tab > Part or Symbol
¥ DesignAlLscm (C\Users\Public\i G ERT LR (===
Home  Symbol  Me| LibrayPath AL -
=l 0 [oi=r 001 Parts in Library: Filker:
» - i 1NE264 -
il e 1nF-c0805-10%
symbol=| T Range 1uF-c0805-20/100%
Add Part Mame TWEKE 1004
2.8mm PR CON
2K0-TR4-1%
2K7-1%-CRE030S
2KF-TR4-1%
2ZMN1613
2ZN21934
2N2222
2ZN29044,
ZN29054
Show Alternates | Brawse... | | Search...
Part Name: 23053
Component Mame: TR
S_MPN
Alternate Mame: rs E’N_P‘ ____________ -;
Use Default Alternate l
R o e
Scale [MulDivl: 14
Orientation: 0o [“|Eived  [] Mirrored
Positior: b s
[ &dd || concel |[ Hep |
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4. Place two 2N3053 transistors onto the schematic by clicking the Add to Design option or by
dragging the transistor from the Libraries panel, i.e. highlight 2N3053 for a TO-92 package, click
and hold the left-hand mouse button down, without releasing it and drag it on to the sheet.

Don’t be concerned about the red bow-tie markers on the c
pins. They highlight unconnected pins (the markers will
disappear once you connect the pins). B TR2
2N3053
While dragging, you can use the right-hand mouse button
for mirror and/or rotation for the placement of a symbol, o
use the ‘m’ or 'r’ hotkeys, or use a programmable function B TR1
key like <F3> to rotate. 2N3053
Customize @
Tip: You can setup the
function keyS by Selecting | QAT | Commands | Toolbars | Macros Toolbar| Keyboard |pr|ic:ation Se‘{‘tingsl
the [Flle] tab and the Commands: Shortcuts for selected command:
Customize button at the Bbot -
i AddAttribut || | Demave
bottom, right of the menu. et 3 |
AddBusShape
ﬁgéaﬂgﬁzlaﬁmaﬂon Press new shortcut keyis):
AddCircle Basiar
AddConBlock Teminal =__
AddConConnector
AddConDangler -
Macros:
g : Default Key File
_ _ _ G1.0m E ALsere PublichZ.
Tip: For more information G100 o \Users\Publc . defauts key J
G25mil
on hot key commands o = [impot.. | [Epor. | [Repor. |
type ‘?<enter>’ (this will
appear on the command
line at the lower left
corner of the application). Gose | [ ok

|| -

[ Libraries | Ggl shape Pro
[ EBus Report l@ D

E
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5. Do the same for the other 11 parts (you can either select the through-hole or SMD

components):

Qty. Part Ref des
1 2N2905A PNP Transistor TR3

1 1.5 kOhm Resistor (1K5-MRS25-1%) R1

2 1N4148 Diode D1, D2
1 5.6 kOhm Resistor (5k6-MRS25-1%) R2

1 22 Ohm Resistor (22E-MRS25-1%)2 R3

1 470 Ohm Resistor (470E-MRS25-1%) R4

2 3.3 Ohm Resistor (3E3-MRS25-1%) R5, R6
1 47uF/10V Elec. Cap (47uF-10V-EC) C1

1 1000uF/50V Elec. Cap (1000uF-50V-EC) c2

HH HH DA
8
£

e

Attempt to place the parts in this arrangement.

6. You can move more than one symbol at a time. Hold down the <Ctrl>
button on the keyboard and make your selections and then Click and Drag
them.

7. Try using the Polygon Select and Freehand Select functions to select
everything within an area. Select the Home tab and click Select icon to
access various selection tools. Select Polygon Select and draw a
polygon/fence around the items you want to select. When you are ready
to select them double-click the left mouse button to accept the polygon or
if using the freehand selection mode, just release the left mouse button
and then Click and Drag them.

14

Home Symbol

k ( i) ?—ﬂFind

Align
Select Item =
- Properties g Name

Polygon Select
Freehand Select

Select All Symbols
Deselect All

A
N A

5% Select Met

°§ % Cross Probe Selection

(|
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An additional selection method is available in the [File]

tab->Options->[Interaction].

between Overlap and Cover selection methods.

This gives more control over how items are selected
during Frame Select, Polygon Select and Freehand

Select.

e Use Cover to only select items completely
covered by the selection shape.
o Use Overlap to select items partially covered by

the selection shape.

Options
Here you can choose | Spstem | File Lu:u:atinn&l Libramy Paths | Interaction [
Add/Edit Segment Mode Heada_bilit_l,l
Twio Segment - 30 Degrees Applies
@ Orne Segment - 45 Degrees Mane
One Segment - Free @ Symbols
DeleteCut All
| Ask on Delete/Cut Interaction
— ol figen Rogtes/Connections Auto Merge
Selection Method I Electrical R
@ Overlap Cioneer | [¥]Enable Res

A different cursor is displayed to show which selection method is in use. The selection method
can be toggled by right clicking whilst drawing a selection shape. l.e. Holding down the Left
Mouse Button and clicking the Right Mouse Button.

Note: When adding parts you be may prompted with a Warning!. This can be controlled by using
a special attribute value to control “Part Acceptance”.

Parts I Dgfinitions |

Part Hame |Number Description

|\-‘ersi0n | Diefinition

|SPICE |Part Acceptance

9K-MR52E-1% 232215613903 Metal film resistor MRS 25 39K 1%
39K-r0805-2% Chip resistor 0805 33K, 2%
470E-MR525-1% 232215614701 Metal film resistor MRS 25 470E 1%
3E3-r0805-2% Chip resistor 0805 3E3 2%
HLMP-1525 932201862682 LED GREEM 3MM HLMP-1585
THET4 High-zpeed diode
10uF-100-cB032 10uF 10 T antaal

SOLDEREYE-1HM
Hale-2 Orirn_Man-Plated
Hole-3.0mm_Mon-Plated

2413-M5-02201  Soldereye 1.0 mm
Haole 2.0 MM Mon-Plated

Hale 2.0 M Mon-Plated

2

1
1
2
1
1
2
2
1

F-MREE-1%
39K0805-1%
470-MR525-1%
3E30805-1%
HLMP-1585

1HS14

10uF-100-cB032
SOLDEREYE-1hik
Hale-2 Orrn_Mar-Plated
Hole-3.0rmm_Mon-Plated

Obzolete - Replace with 29K.-0805-2%

Only 10,000 pieces in Stock!

Mat a Physical Part for Ordering

In the Parts Library image shown above, the column labelled “Part Acceptance” can hold a
unique text reference to communicate a Part’s Life cycle or inventory control measure to the user.

This can be defined by the Librarian.

When a part containing a Part Acceptance value is
added to a schematic design, the following warning

dialog will be displayed.

Accepting this part will also store its value in the

design for later reflection in parts List
and various other report outputs.

The property will be reflected in the
Item Properties dialog.

15

Warning! @
Part "39K-MRS525-1%" - Obsolete - Replace with 39K-0805-2%
E Do you wish to continue?
foYes | Mo

Part D etails

JAMRS2E1E
Murnber: 232215613903
Description:  bMetal film resistor MRS 25 35K 1%

Library Path:  {E xpressi\Parts
Part - = e s s ===

Design Version: 1 Pt Pin N ames/|dertifiers Wisible
Library Wersion: 1
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8. After all the components have been placed, perform a

Library search for SOLDEREYE-1MM. You can use the
wildcard and search for solder*. You can then add these
parts to represent the 8 Ohm Speaker, Input and +9V
terminals (see schematic diagram on page 6). These
parts will serve as the wire connections to the battery
pack, signal input and speaker outputs.

These parts are created as single pin Testpoint
components. You could also add these by using the Add
Testpoint command.

Parts are assigned the next available Reference
Designator per the design or the sheet. There are several
ways to name or rename parts, such as with the Item
Properties dialog.

Change the Symbol Properties name for one of

Enter the corresponding name per the parts placement image
on the previous sheet. Click the [Close] button and select the

next Solder Eye part.

You may repeat the same technique or use the non-modal

Item properties auto-hide panel on the right side of
application window.

Libraries

solder®

- @

Ml BE
MMETZ2204 -
MEC_TOKIM_LUC2_REL
MM27C512QE150
PCFE0C552-4WP
PTF15
RC4ER4400POVTOO
S5D-3099-12A1-12
SD-43045-02056-02
5D-43650-0218-02
SD-44245-002-10
SD-44769-0401-04
SD-53822-0800-24
SMEBIL2CA
SMT404M
SMT474D

==l SO DEREYE-1 MM

STAR-POIMT_2-PIN - ™
k

the Itern Properties - Test Point
SOLDEREYEs to “INPUT”. To change the name, select one of

the parts then click the <R.M.B.> and select Item Properties.

Symbol Details

Pogition:

# 53250
¥ B000.0

~ | Item Properties - Test Point

the Orientation; 0.0 =
Scale (Mul:Div]:
[T Fied 1:1
[ Mirrared
Fitted
~ 1 |3

Test Point Outline

DEE % ts & @
‘ Property J Value
MName IINPUT

Position 655.0,58450— — —
Fixed ]

INPUT Mirrored ]

Orientation 0.0 s
Scale 1:1

Symbol Definition 'TESTPOINT (A1)

Part Details SOLDEREYE-1MM

Test Point Outline

16
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10. Pass the cursor over the Item Properties panel button to reveal the panel dialog.
Set the pin icon to leave the auto-hide panel open for as long as necessary.

With the panel open, the properties of any item selected will be represented. Many
fields are editable. Functions such as Reload and Replace parts can be executed
from the dialog. Other icons provide access to the standard Item Properties dialog

and the Attri

™

Undao

Za]

Can't Undo

Can't Redo

bute Editor.

| Item Properti

es - Test Point

. ™
L) ﬁ@a
|

= =

lﬁa} =

The spread sheet readability can be enhanced by clicking in the dialog to turn the
Item properties title block blue then holding down the <Ctrl>key whilst using the
Middle Mouse Button <M.M.B.> scroll wheel to adjust the magnification.

Use this opti

=

S

salpgadold way k !

salpadoly adeys |1'. |

on to name the SOLDEREYE parts according to the previous parts

arrangement image. Simply select a part and enter its name one at a time. Since this is non-

modal there

is no need to close the dialog.

Place INPUT, INPUTGND, SPK, SPKGND, VCC9V as shown below.

’~

{ VCCaY
peid SOUDEREYE - 1M
N

R4
47BE-MR3Z5-1%

TR2
2N3B53

D2

3E3-MRSZ5-1%
1N4148 RE

BBALF-5BY-EC & =

HH < VW

cz
di-”-ﬁq { SPK ]
" [T |
SDL)EB.LYEAMM
_ 9y Lt
1 :;‘l%a MRS25-1 7 SPREND
5KE-MRS25- 1% R2 N4 148 2 l
SOWDEREYE - it
NS
( E § TR3
2NZ985 A
’ — \
{ - C1 47UF-18Y-EC L
wo | ] 2M3053
sV DegE - I
- = } R1 R3
{ INFUTEND 1K -MRS 25 - 1% 22E-MRS25-1%
wa |
L LERPTE - M

17
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E;] Adding Connectivity

Adding connections can be achieved several ways.

a. Select the Home [tab] and click the Add Connection function. Click on a pin to start the
connection, and move your cursor to your destination pin to complete the connection. The
Connection function is also located on the [Net/Shape] tab.

Home Symbal Met / Shape Design Hierarchy Library Report Tools View
*
. i o+ i
_____ .k |_\!) ,:?ﬂ Find ++ Mave - =g ‘L Global Signal T g Bus
E‘_ Align Al Mirror r™ signal Reference @Attribute

Select Item IEI o IEI Part or Connection

- Properties & Mame 4F Rotate Symbol ~ '|"|_ Connector A Text
Select Item Move Flags Add

Note: By default, clicking on a pin will display a
selection list. To disable this mode, select the [File] tab
- Options—>[Interaction] tab and uncheck the Pick
from List setting. By disabling this, connections can be
added in a non-modal method by double clicking on the

pin.

Ficking Tolerance
Fine D Coarze

b. You can place the connecting terminals (pins) on top of each other, then drag them apart
to see the connection. Pins that are connected will be automatically hidden.

c. You can use the left mouse button <L.M.B.> to click
(hold and drag momentarily) from the red bow ties
displayed on unconnected pins and click the left
mouse button over another red bow tie to finish.
Corners can be added along the way by also clicking
the <L.M.B.>.

18
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12.

™

IIN o
SPKGND
R2 b
c1
(];\JPLIT NP B
[+
E
R1 R3
IMPUTEMD
i

CADSTAR allows you to make pin names or numbers visible/invisible (this is typically determined
by the librarian) such as for 2 pin non-polarized devices. If these parts are set to be invisible the

user can override them globally as follows.

Select [File]Jtab>Options>[Display] from the ribbon and
enable/disable Override Part Pin Names/identifiers
Visibility.

CADSTAR provides an Interactive check for
overlapping connections.

flagging

Select the [File]>Options—>[Interaction].

When the Prevent Overlapping Connections selection is
enabled, the check will alert you with the following error when
you attempt to drag a connected terminal of any

eraction | Display | Constraints I Crozs Prok

Drawing - SCM
I~ = iOvenide Part Fin T
L EL.*J.éﬂﬁ§i.!5|§._n.t.i.f£r.§.i,i§gli.tg_ _ 1
Hide Connected Pins

Interaction - SC

Error

sort and place it on top of a connection line of a
different net name.

'-@-' Cannot complete operation - connections overap

19
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If you do not wish to run the interactive check until a more convenient time, simply disable the
selection. When you are ready to perform a batch check of the design, move the cursor over the
Overlapping Connection active report button to make the report panel open.

hd Emﬂﬂwﬁm-mﬁ1xlnﬁr
File Home  Symbol  MNet/Shape  Design  Hierarchy  Library  Report  Tools  View A @
= v 1 k2 o B %] L ET E = ©:
Report Electrical Overlapping Bus Unused Name Range | Design Parts  local Versioning Where-used Variant  Redlining
Generator~  Rules Check=  Connections~ | Report~ | Components~ — BySheet~ | Comparison  Llist™ Changer - (local) Check | Report
User ERC Connection Bus Component Symbol Design Library Variant | Redlining
E Libraries o3 ~ -=D
) ML =
5 | =1 Libraries ~ L L 3
o =
g =] Express E
o =
=
= {E) Alps_Parts 4 . 3
-] AMD_Parts 2
{E] Analog_Parts
{E) Fairchild_Parts E
= .| o
- (] Hitachi_Parts et
< {E] Intel_Parts 3
3 @
E iE) IRF_Parts £
2
=] (g Maxim_Parts 5
2 {E] Microchip_Parts 2
= -{g] Motorola_Parts - = -
(] Natsemi_Parts
{E] Onsemi_Parts
-] Parts
Overlapping Connections +0
. -
HaddeanEEB
Overlapping Con ~
CADSTAR Design Editor Version
Design: C\UsersN uken| CADSTAR Express 15.0\Self Teach|DesignA2_CS.scm
Design Title: A3-euro -SizeWeet
Date Monday, May &, 2017
Time 1:38 PM
No overlapping connections found
End of report v
—— e ——
8] Rediining [E] BusReport |[&] DesignRuleErrors | [i9] Electrical Rules Check || |[1{ Overlapping cannemansl [§ Routing Completion | Unused Components | %§' Name Range By Sheet
Ready ssss‘lﬂ'lmr —f—— Thou  Grid: 5.0

Click the Overlapping Connection report button as shown above. The resulting report contents
are hypertext. Selecting a line item will make the error appear in the schematic window.

Home Symbol

. Add five AGND Global Signal symbols as shown in the diagram.
To do so, click the Global Signal button located on the Symbol
tab.

=l "L Global Signal [u]

r= Signal Reference

Part ar Allg
. symbol~ ] Connector Pz
Select (AGND). You can connect the AGND terminal add P
and the terminal of resistor R1 by placing the
terminals onto each other as shown below.
Add Global Signal (5
Library Path [ALL v]
[AGHD]
[DGMD)
[GND)
(VCC) +
< 1E ~ [VEE)
47“': L
[}
L]
R1 <
INPUTGND 1K5 <] | signalMame:  AGND
© < Add [ Cancel | [ Heb |
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15.

16.
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D1
1N4148

INFUTGND

&

SPKGND

L®

R6
3E3

E

TR3
2N29@5A

C

Finish connecting all the symbols together as shown on
the previous page. To connect, try each of the methods
as previously described.

When you are adding a connection (Add Connection) or
editing a connection (Add/Edit Segment) the route taken
by the connection will automatically avoid obstacles in its
path. This can be enabled/disabled in the
[File]>Options=>[Interaction].

Interaction - SCH

| Prevvent Owverlapping Connections
| Report After Move/Rotate
Auto Connect Mid Segment

o | Auto Wweld Danglers

| Part Pin Hames At 45 Degrees

s @ Overlap Al

When connecting, you can also use the right-hand mouse button <R.M.B.> to Change Default
Net Route Code, allowing you to select a different Net-Route Code for the PCB design. (l.e.

wider than signal tracks for Power & GND).

Change the net name connected to VCC9V to VCC by selecting the net % and clicking the Item

Properties icon.

Select the pins of the AGND symbols and click the Item

Properties i icon. Check the Display Signal Name
option to display the AGND signal names.

Note: this is for display purposes only. If you decide to
not show the signal names they would still remain
AGND.

Note: Moving connected symbols maintains connectivity
as you would expect. A connection autorouter corrects
the 90 degree orthogonal patterns in real time. However
this can be disabled if you wish.

21

Met
| [VIDisplap Signal Hame |
y v
Signal Paozition: 4550.0 e00.0

rs

Signal Orientation: 0.0

Interaction - SCM

| Prevent Dwverlapping Connections
| Report After Move/F otate
Auto Connect Mid Segment

| Ao w'eld Danglers

| Part Pin Mames At 45 Degrees

| Enable 90-degree autorouting

Autoroute on b ove I
[t @ Overlap Al I
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If Automatic Version Increment in [File] 20ptions>[System] is enabled, with every future change
of a symbol, component and part, the version increments automatically as it is saved to the library.
You can easily check if a component in your Schematic or PCB design matches the current Library
version. To check, click Reload located on the Symbols tab.

This function is also used to reset all selected parts, Label, Symbol and Part name attributes to
their original locations as defined in the library by selecting a Reset to Origin option.

Home Symbol Met / Shape Design Hierarchy Library Report Tools Vieg
L Global Signal 001 | ¥ Positional | [N |<NOVARIANTS> - || @
) bl 9 - . =
r= Signal Reference » ]} g MName Create Variant &
Part or * Allocate | Mame Wariant o Reload | A
Symbol = ] Connector Part Range Manager ‘4% Delete Variant
Add Part Mame Rename Variant Reload | R
%2 Reload Parts/Symbols From Library @
Altributes
Action Part Instance Hame Re:‘::i:oe Alternate Name| Design Version Number | Library Version Number
[ 1K5-MR525-1% 1 2 "
iNa14s 7 3 Reset Positions
: INZ905A 7 3 Hemove DOther
0 N3053 2 3 Altributes
[ 3E3-MRS25-1% 1 2 Rietain Local
] 5KE6-MRS25-1% 1 2 O Reference Name
[ 22E-MRS25-1% 1 2 )
[ ATUF-10V-EC 3 5 Reload Fin Mames
Ll ATOE-MRS25-1% ! 2 Reload Pin Labels
1 1000uF-50V-EC 2 4 Pt Fort
O SOLDEREYE-1MM 2 3 #l yome Vi;‘h’i‘iw‘”
Unallocated -— o —
Fietain Alermate l
Fieset to Origin I
I Symbol Name
. I [¥] Label/Mame I
Retain Alternate N
R ]
Reset to Origin Eipand
|:| 5_||-_||TI|:||:|| HamE-' LContract Al
Select Out of D ate
[ LabelMame
Select all
|:| F'Qrt Name Deselect All
Repart... Optians... Ok, ] ’ Cancel ] [ Help ]

The image The image shown above is an example that shows the dialog when Parts are
different than those in the Parts Library.

17. When completed, save this schematic design as DesignA2.scm. If you didn't complete the
schematic design as described above, just open DesignA2_CS.SCM and save it to overwrite

your file.
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18. In today's market it is important to deliver a B.O.M. (Bill of Materials or in CADSTAR called Parts

List) at an early stage.

Library Report Tools

To create a parts list, click the upper half of the Parts List button.

5 g
To modify the options select the lower half of the Parts List button. |, ="~ 0 5
By Sheet~ Comparisan List~ |Cha
Symbaol Design

Source Variant

DOutput Farmat: | HTML > Current Y ariart

Al ariants

Separate Part Mumber/M ame Sl Vs

List Components

A sttt Select Variant...
[ Output Nan-Fitted Componetits
Shows Full Part D escription
Output Part Acceptance string
Report Header: |D.I.Y. Parts List
The output shown below includes the Parts description Eames Help

and the Testpoint components.

[N Parts List

Parts List

CADSTAR Design Editor Version 18.0

Design: C:\Users'\Public'Zuken CADSTAR Express \Self Teach' DesignA2_CS.scm

Design Title: A3-euro -SizeSheat

Date: Monday, May 8, 2017

Time: 1:533 FM

D.LY. Parts List

Part Name Part Number Description Qty Comps._ Part Acceptance

1000uF-50V-EC 1000uF 50V Electrolytic Capadtor 1 c2

TK5-MR525-1% 2322-156-11502 Metal film resistor MRS25 1K5 1% 1 R1

1N4148 High-speed diode 2 Di-2

22E-MR523-1% 2322-156-12209 Meal film resistor MRS25 22E 1% 1 R3

2N2905A 9330-359-60112 SIL PLAN. EPl. TRANSISTOR 1 TR3

2N3053 MED.POWER SILNPN PLAN. TRANSISTOR 2 TRI-2

3E3-MR525-1% 2322-156-13308 Metal film resistor MRS25 3E3 1% 2 R5-6

470E-MR525-1% 2322-156-14701 Metal film resistor MRS25 470E 1% 1 R4

47UF-10V-EC 47uF 10V Bectrolytic Capacitor 1 C1

SKE-MR525-1% 2322-156-13602 Metal film resistor MRS25 5K6 1% 1 R2

SOLDEREYE-TMM 2413-015-02201 Soldereye 1.0 mm 5 INPUT
INPUTGND
SPK
SPKGND
VCCov

End of report

Save As... Print... Copy Find Help Close
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Tip:

™

If you prefer to create a Parts List in a different format (fully customizable) click on the Report
Generator button also located on the Reports tab.

Home Symbol Met / Shape
Report Electrical Overlapping
Generator~|| Rules Check~ | Connections ~
User ERC Connection

Manage Reports

:

E
B
Rep

B

Report Contents Feport Elements:
Generator File Name: Text
C\. Npart_list.ngf Date
LrEr L -lf\-li:v: Line
Mew... Save fs.. Variable
Court
Details... Erirt... Design Title
Design Name
Report Target Design Units
Crigin

View Report
[ Report to Printer
] Report To File

File Extension
Line Wrap Indent

Variants
Max Line Length: a0 For Each
Next

Change File Name... if

Else
Bun r el Donﬁ Companert
—_—.|
Options... Lists... Type
Name

Close Help Reference Name

Report Contents:

Insert
Delete
Replace
Duplicate
Modify...
Up

Down

Line

Text "Design:
Design Mame
Text ™"
Design Title
Teat ™"
Date
Text "Time:
Time
Text "
Line Wrap Indent: &3
For Each Part Sorted by Part Name
Part.Part Name
Part.Part Description
Component Count. Total Output
For Each Component (Component, Testpoint) Sorted by Name
¥ Component.Fitted = Fitted
Componert.Mame
End K
MNext
New Line
Mext
Using Defined Origin
Text "

In the above image the dialog is fully enlarged as a result of clicking the [EDIT] button.
Once enlarged the button will change to [Done] thus serving as a toggle function.

Open the file part_list.rgf, which you can find in the Reports directory and just click [Run]. You
can customize the parts List output and list any attribute (wattage, voltage, tolerance,
manufacturer etc.) in any particular order you choose.

For the more advanced users among you who have experience in Visual Basic or C++, you can
create, for example, a user-defined B.O.M in Microsoft Office Excel, by using the OLE automation

in CADSTAR.

19. To print your schematic design, simply click on [File]2>Print and go through the Print and Page
Setup. Alternatively you can print your schematic design to a PDF file, you do not need to install
a PDF writer, CADSTAR has its own native PDF writer.

Enable Alternative text output in the print options, making text searchable when printing to a file

format such as PDF.
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Finally, transfer the schematic to PCB through

[Design]->Transfer to PCB.

The dialog will automatically use the same output file
name as the schematic being transferred. Click the

[Browse] button to enter a different name.

Set the output file to DesignAl.pcb as shown -

Choose '2 layer 1.6mm.pcb' as PCB Technology.

Click [OK]

As part of the process a report is generated identifying
any warnings or errors that may be in the Schematic

design.

Next specify the PCB design units, Display
Grid dimensions, default colour template and
enter any initial attribute values if required by
your company PCB technology templates.

Once the schematic data is collated error
free, you will be prompted with the adjacent
dialog. Click [Close]

W View File

Design:

Date:
Time:

Gollating Schematic Design

CADSTAR Design Editor Version 18.0.B.138

Design Title:
A3-euro -Size Sheet

Monday, May 8, 2817
2:07 PH

C:\Users\Public\Zuken\CADSTAR Express 18.8\Self Teach\DesignA

MNew PCB Design

Design Title

Transfer To PCB

Output File

C:AUsers\PublichZuken\CAD. \Designdl pch Browse.

Fommat, | PCE Binary o About..

Categaries.. Options.. Format Help

Source Sheet Source Yariant
() Current Shest
(®) Whole Design

() Selected Sheets

Current Wariant
AllVariants

Select Sheets...

Transfer To PCB

Template Folder:

C:\Jsers\Public\ZukentCADSTAR Express 1. \Templates

PCE technalogy:

2 Layer 1.6mm.pch ~
“Wiew Mew Design Settings

Feport Unnumbered Terminals

Report Dangling Connections

Allow Single Mode Mamed Mets

] Perform Update of Reuse Blocks on Completion

tdapping File

Browse...

Use Map Create Map... Edit Map...

Cancel Help

2 Layer Defaults

Units

Unita:

Dizplay grid

Dizplay grid

Colour Template

Thousandths of aninch

Mumber of Decimal Places:

3 s

Step: Grid type: | Pairts e

Calour File - Black Background PCB w
Altributes
Layer Name Doc Sym Referencel Doc Sym Position/
% Attribute Name Attribute Value
i i on
Cancel Help
=

Collation Results:

8 Errors, 8 Warnings

PCB design has:

18 components (18 with Part Names)
22 connections in 12 nets

8 group(s)

8 reuse block(s)

End of report

Save As Print. LCopy

25

< Click [Close].

The PCB Design will appear in a
new window, active with a PCB
related ribbon style GUI.
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Home Component Met / Shape Design Library Report Tools Manufacture View & @\'
HViewAII @Zoom In \.'2 Previous White Background - ‘F- -—'j' |.E; Open Designs| _-_-:i) Iltem Properties === & Previous Lj Close
o2 View Selection \:&Zoom Cut @ Refresh ﬂ|h Mirror View ﬂ Current Design _J# Shape Properties = S Next j‘ Close All
Colours Met Frame — Group
E&Frame\iiew EManage nMix Colours - Bitmap gLibraries |XI Start Page - BT switch -
Zoom Views Display Highlight| Image Panes Tab Document
+ -
oo e ne QaRE s
= Ope_n Designs a B ~ |E
~ | B+ Open Designs =
] DesignAl.scm (Ch\User 3
@ . o
El B DesignAl.pch (C\User C 2 3
[ =
@ @
@ =
=1 @
3 o
o
s P
= m
s E
g o
o =1
o =
@
=
@
@
v
£ >
< > 4 i Start Page DesignAl.sem - Sheet1 - B8  DesignAt.pcb n [
@ Redlining IE Bus Report @ Design Rule Errors f;.’j Electrical Rules Check ﬂ Overlapping Connections @ Routing Completion ﬂ Unused Compone
Ready -378.6 -386.6 Thou  Grid: 25.0

ot e Ol B —  —
L " swap
ayers o—1T0 ~ o —_
embedding
o—Jio = e
Name | Ty “}IC:"E-”;S Embedding | Des Physical Board Thickness = 63.0th Aield Layer
ou
Top Elec (0.7
Top Profiing Plat| Nen-Electrical 0.0 | Mone op Blec (0.7) Delste Layer
Top Profiing No | Nen-Electrical 0.0 | Mone Move Up
Top Placement Non-Electrical 0.0 | Mone
Top Assembly | Non-Electrical 0.0 | Mong Move Down
Top Glue Spot Non-Electrical 0.0 | Mone ol Ord
Top Paste Non-Electrical 0.0 | Mone olumin Drder...
Top sik Mon-Electrical 0.0 | Hone Show Layers of Type
Top Soider Resi  Non-Electrical 0.0 | None Electical
No tracks Non-Electrical 0.0 [Mone
[
No vias Non-Electrical 0.0 [Hone R .
Top Elec Electrical 0.7 | Above . Mo Electrical
T tel Construct 161 Laminated (61.6)
aminate’ onstruction | one Bl .
Bottom Elec Electrical 0.7 | Below i
Bottom Solder R Non-Electrical 0.0 [ None Documentation .
Bottom silk Non-Electrical 0.0 | Mone )
Bottom Paste Non-Electrical 0.0 [Hone Physical Layers
Bottomn Glue Spo Mon-Electrical 0.0 | Hone Minimum 1
Bottom Assembl  Non-Electrical 0.0 [Mone -
b awirumm
Bottom Placeme | Non-Electrical 0.0 [Mone
Wechanical Dra |~ Doc i None Apply M aximum
Letter Dril Drawi Do None
Do Do None Bottom Elec (0.7) Layer Stac&f Wiew
thm_power b Do i None Show Picture
C Dime D i None . =
- Blind Via [Unavailable EhotraiBoly .
X = Copper Colour .
Buried Via |Unavailable Copy
Chill Calour
Fit to Window
S 2 Construction Calaur .
Report. 4 aterials. Cancel Help.

Note: If you choose the PCB Technology 'l layer 1.6mm.pcb' during transfer to PCB, this default
technology file is prepared for single sided boards. The advantage of the different technology
files is that you still can make use of ONE library as you will experience in Design D.
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The first steps showed how a schematic design can be drawn for Design A. In fact, any schematic
can be drawn following the sequence shown. However, a more complicated design will require
more challenging steps. There are many tools within CADSTAR Design Editor that

will help designers like you to create a schematic. You can also add spacing classes, insert a
component into a net without any disconnection, and perform auto-connection of busses. Other
tools like Align Symbol, Design Re-use, Design Variant, Hierarchical Design, etc. are also
important and are user friendly for professional design engineers to use.

You can now move on to PCB Design. You will notice that the CADSTAR Library, Schematic and

PCB design editor run on the same Graphical User Interface, guaranteeing a fast and problem
free transfer.
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Step 2 - PCB Placement for Design A

If you didn't create the new PCB design as described, just open DesignAl_CS.PCB and save it as
DesignAl1.PCB

E:] 1. Set the design units to “Thou” (Thousandth of an Inch) by selecting [Design]2>Units or
alternatively by double-clicking the units | Thou Grid: 5.0 | gt the bottom of the CADSTAR window.

When a new PCB design is created all components are placed in
the positive quadrant of 0X, QY, this is considered the initial Design
origin. s @ Drill Letters/Table = | 81|

7 Electrical Rules =

Met / Shape Design L

2. Select the [Design] tab and click on [Origin = Design Origin]. 's €D Origin -

i @ﬁ Interactive Origin G
You will see the design origin symbol at 1000 for both X E P Design Origin }‘
and Y position. This is defined in the '2 layer T

1.6mm.pcb' PCB Template that was used.

Settings Design Crigin >

Current Origin Position:

e |n.n | ¥ |n.u

(®) Origin Position Absalute
() Origin Position Belative ta Current Origin

# Poszition ; ' Pozition ;

|1unn | |1nnn

Corea | [

Next, you will have to create a PCB | Import Design [l
outline; _
|mpart File
A board outline can either be created CAUsersiPublich...\Boardoutiine. dit
within CADSTAR or imported via DXF
format Fomat: [DiF =] | bour
' CADIF
CADSTAR 7 [for DOS) PCE Bi.r'u.ar_l.J Format Help
¥=H 3. Select [File] tab->File Import. Change W
the Format to DXF. Mappinc OrCAD 'PCE' Metlist
PCE Archive
C:hUzer: : ; -B[cuwse...
Select the DXF file Boardoutline.dxf. pREdtor R Fles [LBoves.. )
Use | RINF Metlist Edit bap._
For the Mapping-file, you have to select
dxfin.map, which you can find in the Create Mew Design (@) Merge into Current D esign
..Juser/ folder and just click [OK].
[ QK ] l Cancel l [ Help ]
If you have chosen to import the DXF

board outline, then skip to step 7.
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Note: the board outline that is imported using the DXF data is different from what is described in
step 4. The intent is to demonstrate the support for DXF Line entity styles such as BLOCK,
INSERT, ELLIPSE, SPLINE and POLYLINEs.

CADSTAR also supports Importing and Exporting of IDF 2.0 and 3.0 from most mechanical
CAD systems.

Alternatively you can manually draw the board outline. L .

n Library Report Tools
Let’s try to do this by inputting coordinates using a dialog. =n "L | [copper -
Locate the default shape type quick-pick menu on the [Home] tab |, -
and change the default to Board as shown to the right. > ponent~ A
Next, click the “Add Rectangle” button. fde Copper

® DesignAlpcl Cutout |
Click the <R.M.B.> and select Input Coordinates. Figure

Template

Enter a Width value of 2100.

Enter a Height value of 1050.

Input Coordinate @

@ Absolute Relative X: 0.0 * Y: 0.0 -

Leave the other fields as shown -

Click [Apply]

Width: 2100  Height: 1050 -

Apply ] | Close | | Help

Note: if you choose to create the shape without the use of the Input coordinates assistant
watch the absolute and incremental coordinates at the bottom of the CADSTAR window when
drawing the board outline.

Tip: From any point in the design you can reset the incremental coordinates by pressing the 'Z'
key, followed by the <Enter> key.

To modify any outline (board, figures, component outlines etc.), simply click on the shape edge
and select one of the grab handles. You can also use the Shape Properties panel on the right
side of the application window. By selecting the outline you can see and modify the absolute or
relative coordinates.
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Home Component Met / Shape Design Library Report Tools Manufacture View [A7 ]
e lﬁ- K :;—1 Merge = ‘_1 _.-1-._ Insert Segment m Fillet Corner Cutout . Q' I>_f\\:b
- n—& Reconnect e ’ -5 Modify Arc m Mitre Corner
Connection Met Nvet .\.-S-&t SR — Disconnect I_Edit P - E‘ D o ' Duplicate Trim/Merge
Width "= Pad Segment 27
Add Select | Highlight Route Connection Edit Segment Add Shape Shape
doohldne QB -
= ~ | Shape Properties O x|
o] Relative | Closed
% R N Type X voE
@ | Start Point 0.0 0.0
=) : O O Line To ZT000 0t
! ! Line To 2100.0 1050.(
| ! Line To 0.0 1050.0
i i i Line To 0.0 0.0
5‘- : | Cutout Start 100.0 50.(0
= Clockwise Arc 100.0 1501
& n n With Centre 1000 T00.0
i I Clockwise Arc 100.0 50.(
i 1 With Centre 100.0 100.0
| Cutout Start 100.0 500.0
i Clockwise Arc 100.0 10001
! : With Centre 100.0 950.0
1 O IOI ! Clockwise Arc 100.0 500.0
@ - =.I With Centre 100.0 850.(
— — — — — — — — — — — _ — — — — — — — — — — — [}
Cutout Start 2000.0 900.0
Clockwise Arc 2000.0 10001
With Centre 2000.0 850.0
Clockwise Arc 2000.0 8001
« || With Centre 2000.0 950.0 v
£ > £ >
4 i Start Page DesignAl.scm - Sheetl oz DesignAil.pch n [ :'.)Item Properties - Board j'Shape Properties
@ Redlining IE Bus Report Iﬂ Design Rule Errors I‘;.’j Electrical Rules Check Iﬂ Overlapping Connections Iﬁ Routing Completion ﬂ Unused Compone
Ready 2074.3 1277.1 Thou Grid: 25.0
6. You can also create screw holes or mounting holes if you like. To do this within the board outline

locate the default shape type quick-pick menu and change the default to Cutout, and then click

any of the drawing tool icons ¥ . In this case you will add four round holes with a 50 thou
radius.

Click the Add Circle icon.

. . . Input Coordinate @
Click on the board outline then click the
<R.M.B.> to select the Input coordinates ©) Absolute  Relative  X: 100 v T 100 -
assistant. Radius: | 50 v

Apply l [ Clase ] [ Help

Enter X 100 Y 100 as the location of the
center of the cut-out and enter a Radius of
50 thou.

Click [Apply]. The Input coordinates assistant will remain open.

Remember to select the board outline before selecting each add shape as per the command line
instructions.

If the board outline is in full view you should see the first cut-out in the lower left corner of the
rectangle.

Add cut-out number two at X 100 Y 950.
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Retrieve the previous radius value of 50 from the pull down list and click [Apply]. The Input

coordinates assistant will remain open.

Repeat the sequence for cut-out number three at X 2000 Y 950 and cut-out number four at X

2000 Y 100.

If you didn't manage to draw the board outline or to import the board outline through DXF, just
open DesignA2_CS.pch and save it as DesignA2.pcb. Note the board shape is as shown

above.
. i Met / Shape Design
Once the board outline has been imported or drawn manually you can |
set an interactive origin, to reference all X and Y co-ordinates of all @ Drill Letters/Table ~ [
design items, and cursor positions, relative to the new origin. 7 Electrical Rules =
5 Ga Origin -

Select Interactive Origin from the [Design] tab and place the origin at
the lower left corner of the board.

ti @:' Interactive Origin
ig @ Design Crigin

. . . . Design
Enable Snap to Endpoint it will be even easier to place the .

Interactive Origin. To do so select All Snap on/off located on the [s/Table ~
[Design] tab. lules

Library

81| Grids
== Units

Grid

Report

vy
s

AlrSmap
Oon/Off =

Snap

3 ZURKEN



http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar

2H

™

Component Placement

Start by moving or arranging the components around the outside of the board outline.

8. Use the Arrange Components function, located on the [Component] tab to move the components

from zero, zero.

Home Component
=
=,y
Arrange

t~ | |Components~

Placement

Select the Place around
board outline option on
the first dialog and click
[Next]..

Set the method to
Outside Board Outline.

Set the Component
Separation to 100.

Component Placement

=3

Placement and Stacking
Enter placement and stacking details.

1 1
{1 {1

Align
(@ Min Bounds
Max Bounds
Centres
Origing

Row and Column Steps

nn
I u.u

Placement Origin

(@ Use Component:

[ 5tack Matching Components C1

Use Coordinates:

-2150.0

nn
uu

2300 n

-4

Click [Finish] <Back || Fnish | [ Cancel | [ Hep
Your results may vary.
2
o]
+ = L
ee) n . o2 INFUT
¢ NS B _Te @@L _F+ @
. INPUTGMND
O O
==
W
A3
=)
A*
= =
O AS
sp%m/snfn i A8 B —#]
(@ @ = —*
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Place the critical components inside the board outline. In this sample design, the SOLDEREYE
parts should be placed first. You may consider these components as critical where as their
location would be described by mechanical engineers. This is also possible in CADSTAR using
the BoardModeler Lite application as well as the IDF Module If you do not have BoardModeler
Lite or the IDF Module. You can use the Item Properties panel to enter placement criteria such
as X, Y Coordinates, Rotation and Board side.

Note: BoardModeler Lite and the IDF Module are available for evaluation by contacting your local
CADSTAR Sales Agent.

Open the non-modal Item Properties panel located on the right side edge of the application
window. Click the pin icon for it to remain open.

Select component VCC9V by clicking on the outline or just type in “VCC9V<Enter>". (It will be
highlighted automatically), then change the X-position to 250,0 and Y-position to 875,0 and click
the Fixed tick box.. The component will move to the new location. Click in the PCB window.

Repeat this action for:

Component SPKGND, change the X-position to 450.0 and Y-position to 875.0
Component SPK, change the X-position to 650.0 and Y-position to 875.0
Component INPUT, change the X-position to 1650.0 and Y-position to 100.0
Component INPUTGND, change the X-position to 1850.0 and Y-position to 100.0

Place the remaining Components by Component MNet / Shape Design Library Report Tools
selecting the Embedded Place and E o2 E’I- ;ﬂ % & S Adviser | o
H Enl o5 Ea =
Route icon Iocated on the [TOOIS] tab' Embedded  Auto PREditor PREditor SI Board U
Router XR ¥R HS Verify Muodeler To
Embedded PREditor SI EM EMC Adviser i
SEleCt the [HomE]estaCk Off— Hame Route Design Report Tools WView
Board icon. I i"\l 4%* Maove + o :].o Mode :Z: Align - 000 Space
= S swap v | =y w0 0o 7] et 42 Gridding ~ 55 Scale
It
T 45 Rotate - ftem ti Component = 4 Push = ¥ Stack
Praperties ]

Item Moave Flags Focus Placement

Enter <Ctrl+A> to select all

components. This will result in all the components that are currently unfixed to be randomly
placed around the perimeter of the outline. This serves as a second option for arranging
components.

Home Route Design Report Taols View
Select the Move icon and the Component mode =~ | [ move - o ] Node
R [ | - g
focus icon. W Sewape | = | ohe T et
Itemn Item
Properties | ‘& Rotate = Component
Item Move Flags Focus
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13. Select component “TR1” and move the cursor inside the board outline.
Click the <R.M.B.> and you will see a list of assist commands as shown

to the right. >

Cancel

Clockwise
AntiClockwise
Swap

Align

O
A8 (
Push
f A4+ Al L)
[ —
Az P =] i/,_el_\ | ﬁ g' E} Q Toggle Errors Allowed
&— A3 |—e — T = Toggle Dynamic Pushing
c 7=
= — | VECEPKEND SPK 'L/ Toggle Move Track
Oe=s=it) _ i
&K
[ 2
c2
I
+ = &

Selecting Clockwise or Anti-Clockwise will rotate the component accordingly. You can do so

by pressing ‘C’ or ‘A’ on the keyboard to gain the same result.

Selecting Swap will mirror the component shape to the opposite placement side.

The Embedded Placement tool will aid in error free placement. However, there are times when
an error is needed temporarily. Such as, to place a component back outside of the board
outline temporarily. This can be achieved by selecting "Toggle Errors Allowed".

If the default action is to push other components, the opposite behaviour can be chosen using

the Toggle Dynamic Pushing.

To set the default action, select the Push->Options dialog located on the [Home] tab

v

Select Item
< Properties
Select Item

—

+= Align -

4 Push - [

ﬂ Options

Route Cresign Report Tools View
++ Move - o -], Mode
% Swap T - "-.-I..- nIt' o l Met
em
¥ Rotate - Component
M push Aside el |

["| Dynamic pushing

[¥] springbadck

Push effort

Pook | [ Cancel l [ Help
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14. Place TR1, TR2 and TR3 like the image below. Practice using techniques to achieve some

preliminary results.

- = R3 RB
Cm=== T
e o[  [eleTr e
| / RS —/.
/ [— @&
"9
e
15. After the placement of all critical components and some preliminary
placement is complete, exit the Embedded Place and Route Editorand ' = Cempenent | Net/sha
place the remaining components by selecting Arrange = &1 mMultiple
Components>Automatic Placement function on the [Component] == B positional
Arrange
tab. Compongnts'

[

Automatic Placement

Placement Area: Placement Grid:

EE Replicate Placement
ELE‘E Automatic Placement

[[Buard Outline] VI [[Eunent Wiorking Grid] VI
Surface Mounted Through Hole
[ Asata-bdirrar [ &suka-Mirrar
Auta-R otation Auta-R otation
[[]0deg 0 deg.
[] 90 deg. 90 deq. Diuring Placement
[]180 deg. 180 deq. Flesamesh
[T] 270 deq. 270 deq. :
[ Place Componerts ] [ Close ] [ Help ]

Enable all Auto Rotation angles before placing the components (depending on your design rules).
Try the different settings and experiment with the different results.
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m
N

REB
VCCIOVSPKGND SPK O

@ ®21

Sample placement with only o and 180 degree auto rotations enabled.

If you didn't manage to place the components, just open DesignA3_CS.pcb and save it as
DesignA3.pch.

16. Try moving the components manually using a finer working Grid | Theu  Grid: 5.0 | (click on the grid
button at the bottom of the window).

Note: you can select any footprint in PCB by simply —== | &3 Previous | [ Close
selecting the particular symbol in the schematic. In [~ 7
CADSTAR, This called Cross-Probing. To try it, select Group T ] Close Al
Group>New Vertical Tab Group located on the [View] - | E7 Switch -

tab first. Then select any random item. New Horizontal Tab Group

. . . . Mew Vertical Tab Grou
To continue with the next exercise, you should activate and 1] -

enlarge the PCB Design window. &= DMove to Previons Tab Groun
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Setting up Powerplane Templates for Copper Pour

Power Planes are an integral element in the PCB. CADSTAR can accomplish this as a Negative
Powerplane where templates can be created on designated Power Plane layers to set the boundary area
for split power planes and DRC checking. This then requires a power plane output which is a traditional
negative photo image output.

Alternatively templates can be created on Electrical layers for use as a positive photo image copper pour
effect. This guide will focus on this method as it is the most popular among users.

17. To create a partial power-plane, create a template by duplicating the board outline. Select board
outline and then Duplicate shape function on the [Net/Shape] tab.

Met / Shape Design Library Report Tools Manufacture View
3 _ 73 ! p.4 i
H —* Merge : I_l ;-1 Insert Segment EFlIIet Corner Board . E'
i n—& Reconnect “ Modify Arc E Mitre Corner
Set Disconnect Edit ) W@ " Duplicate|T
Width o Unroute Pad Segment 7& ArcTo Line
Route Connection Edit Segment Add Shape 5ha
Duplicate Shape @
Duplicate Shape
Type
Lkt 1 Area
Change the type to Template and the layer to Eoard Qutline
Bottom Elec. ) Copper Copper
Disable Resize Shape if selected. - Fre slerk
Buz
Click [OK] to create the template.
Offzet
) ) & 00 Y00
Note: Copper pour will be generated automatically
in the Embedded Place and Route or stand-alone Layer
Place & Route Editor on solder side based on the [E.juc.m Elec -
template area. Copper shapes will be created to fill
in the empty space within the template outline ["] Resize Shape
connected, for example, to AGND. Cire
2] By 'Walue By Percentage
a7
293
M aintain azpect ratio
QK l I Cancel I I Help
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18. After the template has been created you can set the properties to control how copper is
generated. Select the template and click on the non-modal Item Property panel and pin it open.

19.

Note: the demonstration video suggests Bottom
AGND as a template name with signal AGND.
Please set the properties as described below.

Tip: If you are unable to select the template, enable
the pick from list function in the [File]2>Options

[Interaction] tab.

With this enabled, select the board shape outline
once again. This time a Select Item dialog will

Select Item @
Board
Template TEMFLATED Bottom Elec

[ ok || Cancel | | Hebp |

appear to make it easier to select the template

outline. Item Properties - Template v
DR S %% = &8 ©
Set the properties as follows: Pronorty i | |
Name Template: Bottom VCC9V , ,
Relief Copper Code: 10 picber somslaliint
Layer: Bottom Elec TR
Signal Name: VCC9OV Line Width Code  Line 1 ==
Clearance Width: 10 Fil Type (Clear) E|
Allow in No Routing [select] Copper Code |8 B
Thermal Relief: Enable On Pads Relief Copper Code| 10 |
Angle 45° Layer Bottom Elec El
Signal Name VCCsV
Note: Automatic Pour is ENABLED! Conmncayam | 190
[These are the important parameters you need to set.] Addiional lsolstion | 0.0
Sliver Width 10.0
Allow In NoRouting VI
Return to step 18 and repeat the process for the Top IR
Elec layer using AGND for the template. Miomatic Pour vl
Target For Autorou V]
[=] Retain Poured Cop 'Retain Poured Cop
Set the properties as follows: - @
Name Template: Top AGND Creater Then | 1009
Relief Copper Code: 10 Disjoint ]
Layer: Top Elec Greater Than 100.0
Signal Name: AGND [=1 Thermal Relief Gro ' Thermal Relief Gro
Clearance Width: 10 On Pads v
Allow in No Routing [select] ARl oo S :
Thermal Relief: Enable On Pads On Vi
Angle 45° Angle 0.0 4
Relief Type Cutouts
[=] Suppress Inner La Suppress Inner La
The steps that were mentioned in this chapter are again paroted o boa O
a typical sequence. There are other tools such as Radial s ViTo o
Placement, Gate and Pin Swap, Replicate Placement

etc., to help designers achieve correct placement of
components.
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Step 3 - PCB Routing for Design A

With placement completed we can now start to route the PCB. If you didn't manage to create the
template, just open DesignA4_CS.pcb and save it to overwrite your current design before going to the

routing environment.

1. Select the [Tools] tab-> Embedded Place and Route, to go to routing environment.

Begin by check the Routing Options. Setting the Routing Options is very important before any

routing.
Select Routing Options
button located on the

[Route] tab

Route Design Report Tools View
o=, EAuto Route

. 51 Bus Route G Mitre jl Routing Options

*
b a'lnSemi-Auto Route !g!ﬁ Memory Route aUnmitre gRouting Layers
Manual
nent  pgute ., Unroute

'\_\-_5' River Route 34 Routing Costs

Routing Settings
Routing Setup @
General | Trunking Optiohs
Process Interaction
@ Route Smooth Azl before rebuilding Router resultz into lapout
Optiong Angle Track
@ Straight
| Erors Allowed 90 Degree: @ 45 Degrees Free Style e
Curved
Acthiv-45 Ophimal
Paszes |10 - | Activ-45 R outing Wwidth (@ Mecked
— 200
Effort |10 b Tidy Style: | Full - Typed Tk
Via Equispace
o | Miaz Allowed Change Length 'with Equizpace
“iaz Under Single Laver Pads E quizpace YWhile Refine Routing
Puzher Fouting Parameters
v
Enable Fusher Autoratic: Pour
| Springback,
| Allow Segment Breaks Angled Autorouting _
Standard
[ 0k l | Cancel | | Help

The Routing Options dialog contains several options to control routing behaviours:

Route Width, Routing Parameters (for autoroute), Routing Angle, On-Line Design Rule Check,
Push Aside, Activ-45 Degree Routing etc.

Make sure that at least On-line DRC, Angled Autorouting, Angle 45 Degrees, Activ-45 Degree
Routing are Enabled. You can use these options to create the result you want.
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Home Route Design Report Tools View
'\D 4§* Maove - o :]-n Mode :;'? Align ~ 00 Space o'o" Eﬁuto Route
=) swap v | =y =0 e 7] pet i Gridding - {55 Scale b | " semi-Auto Route
Ttem ) Ttem Manual|
Properties | ¢ Rotate ~ Component |+l Push = [J¥Stack | | poute | - Unroute
Item Move Flags Faocus Placement Routing

2. Start with manual routing by clicking two icons on the toolbar, Item Focus and Manual Route
located on the [Home] tab as shown above.

Try out the Activ-45 Degree Routing and AutomatiC [ rauting - Layers ==
Pour starting on the Solder-side (Bottom Elec), by Curort
selecting a net just once and moving the cursor to the lBDan;Elec 2
other end of the net.

Layer Marne: Active: Yisible:
To insert vias, requires the changing of the active | e U

routing layer from Top Elec TopEkc  to Bottom Elec

Bottom Eec | (by clicking the Top Elec button at the
bottom of the window and changing the current layer
to Bottom Elec).

While routing, you can insert a via by using the right-
hand mouse button and select Change Layer.

Route width can be changed on the fly from Optimal -
to Necked or Change Width USing the right-hand Select Al IéctiveYesJ IEisibIeYesJ
mouse button and select Change Width (you can
choose a width between Min and Max, depending on
your Route Assignments). (k] [caneet ] [ ek

|ActiveNa | [ isible No |

Home Route Design Report Tools View
'i) 4§' Mave - o :]-n Made :E Align - 10 Space °'¢" Ehuto Raoute
=) swap + | =3 =0 0h0 "] Net %7 Gridding ~ (55 Scale b " semi-Auto Route
Item i Item Manual
Properties | o Rotate ~ Component | +iPush ~  [j%Stack | poute - Unroute
Item Move Flags Focus Placement Routing

3. Use the automatic routing features. The two icons used are Net Focus and AutoRoute shown
above. Nets can be automatic routed individually or by dragging a selection frame area around
the whole board outline.

Copper pour will be generated automatically on the Top Elec and Bottom Elec layers since you
enabled automatic pour earlier.

Note: the copper poured into the template will have followed the properties you have set. The
copper will also have automatically avoided the cut-out of the board outline.

Note: Transistors, TR1-TR3 contain a round Keep-out area within the component shape, shown
as cross-hatched in the previous images. You may choose to change the colour settings so that
component areas are not visible. The settings for the templates that Allow in No Routing areas
while be considered resulting in copper being poured within the area. Try it!
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4. After completion, you can go back to the PCB Design Editor window by
selecting [File] tab and clicking the Exit Embedded Place and Route
icon. Don't forget to rebuild the router results into the layout. You can
now see a design similar to the PCB shown below.

Home Route

b P Re__cr.furd E

Execute ~ Exit
- | Uit Embedded
Macro Embedded

5. For a different view of the PCB use the Mix Colours (transparency)
mode located on the [View] tab This will display multiple layers so
that all items are visible. Shown above

al
ﬂ"l\, Mirror View I

Colour . S S —

[DEFALLT) '

EMix Colours
Display b

Note: This is best viewed using a black background.

6. If you required, a mirrored view of the PCB design select [View] tab->Mirror View. This view
option allows work to be performed as if you are working on the bottom side of the PCB.

7. The board can also be displayed filled. Select [view] tab

-> Colours,Pick the Board Outline category and select Faan
Change Colours ot
Copper
. . . Wias
A checkbox in the Colours — Board Outline dialog Bord Duline
. Diill Hales
allows you to toggle the fill style of the board. Dl Letters
[ Cill T able
Frrs:

41

Tes
Tes
No
ex
ez
Tes

res
ex
ez
Tes

Tes  ND ey
es No
es No
Yes No

Yes No |M\

es No
‘res Layers. ‘

|ChangsCD\uuls ‘

es Mo
e Nn

Colours - Board Qutline

Colaur:

Fill Board Outiine

R

Select Al | Visible Ves Visible Mo
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8. Save the file =

If you didn't manage to route the design, just open DesignA5_CS.pcb to have a look.

This is probably the last stage of the PCB design. It requires some careful considerations as to how the
board can be routed, what are the critical nets and what nets have to be routed manually etc. For
advanced users, more routing features and high-speed routing are to be considered.
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Step 4 - Manufacturing data for Design A

At this stage, you can also create the manufacturing data (Gerber, N.C.Drill, Parts List, Placement data,
Drill Drawing, etc.) for the manufacturing of the PCB. Start by creating a Drill drawing with an associated
Drill table as shown below. Your design may be different.

53.34mm
4B.26mm
T_“\) F & &L 4 ©
4’ J °A n" Drill Table
d‘ d‘ OA GA Size |Plate Through |Letier |Count |Tolerance
E o Hp & 050 YES D \|+/- 882
5 2 e s ) 270 YES B 9 [+/- 0.02
8 P s 8.60 YES A 20 [+/- B.92
1.88 YES c 5|+/- 8.82
£ P £ P £
O £ & & & FO
T - mm
T e
i
Drill holes marked with letters that correspond to a hole count in a table or legend.
1. Change the preferred units to mm with 2 decimal places.
e Design Library Report To

2. Load the colour file called Drill Drawing. This is found in the pull-
down menu adjacent to the colour palette Icon found in the [View]

tab.

This can also be loaded by typing [col drill
at the command line.

D

'j White Background | =
o)

Elack Background PCE

Select the Drill Letters/Table function
located on the [Design] tab.

5

Drill Letters and Drill Tabll

Dnﬁrawﬁ“jn able | Duill Letters

Ll Letter &ssociation

I 080 P 000

B 070 P 000

C 1.00 P o000 @ k

D 0.50 P 0.00 @ Mo Suppression

sl

Post Process - Change Drill Letter

[ Drvill Optimmisation

Automatic Drill Letter Association:

Automatic Drill Letter Azzociatign
Mozt Frequently Used Drill h

[ Mirrared Dill Letters

Dirill Letter: A

Doill Size: 0.e0 Flate Through

Drill Length: | 0.00 Dutput Not-Fitted Items
¢« [ | Tolerances hyer Pairg

hde: [ [Thraugh Hale]

[ Open.. ] [ Save... ] Save az Defaults

[ e ] [ - ] [ e ] [ Inchude E quivalents d
Selec Lorill T able ity
@ Use Defaults Specify File | Leng
Mo File Selected Flate Through
Count

Tolerances

0K

] [ Cancel ] [

Help

43

Colours
EBottom Elec
drawing <enter>] Eottom paste mask
@ Bottom silk screen
Met / Shape Design Library EBottom solder mask
— . Defaults
@f Drrill Letters/Table - gﬂ Grids
. Drill Drawing
@ Drill Letters/Table Units
gnd
Add DfiblTable
tings Grid

. Select Automatic Drill Letter

Association option as shown.

. Double click on the Drill Letters

and enter a tolerance comment
like +/- 0.02.

Deselect the Length column
header

. Select the Comments column

to appear on table and change
it to “Tolerances”
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4. Select the [Drill Table] tab.

Drill Letters and Drill Table (==

Diill D ra-fing Drill Table [lriII Letters

Poszition Properties
a. Change the Layout, layer to Letter . "
Drl” DraWing Position = .'".gln.'. [ Fixed
- [ Mirmared
hd _
@ Orientation 0.0 -
Selecting the Show Drill Settings
option will show pertinent settings Lapont o Cortrl
that are useful for the Fabrication of Laver |[Lettr Dill Dawing - 1
the PCB. Leave it deselected. _—— = = = =
TestCode [ Tent Siee 50/S0/10 ~| e -
b. Click to [Add Drill Table] button. Line Code (Border] ~ |Line 5 ) Léddﬂ"" Table ) |

on your cursor.

This will make the drill table appear Line Code (Grid) ~[Line -]
|

0K | [ Cancel | [ Hep |

5. Move the table to the right of the PCB board outline and <click> to release it as shown below.

53.34mm
48.26mm
T O g ¢ & & &, Ol ===~~~ ~=========-
°A QA OA oA Drill Table
oA dA oA dA I Size |Plate Through |Letier |[Count |Tolerance
£ E & FaR & | [ese YES D 1|+/- 802
g 0 o Fal H 270 YES B 9|+ - p@2
5’ a & PN | P.80 YES A 20 [+/- 9.92
| .99 YES [ 5|+/- B.B2
L g P B E B £ L
Q B 8 & F FOo| TTT T T T T T T T T m
. LZ_.EH»mm

2.54mm —
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6. Try adding dimensions as s'hown on the preyious page by c_Iicking the | e view
[Home] tab and then selecting the style of dimension you wish to add =
from in the Add Dimension list. 1 Lg
1 add~
Feete=tded
Line
ﬂvm Orthogonal 5
. . . . . | <{* Direct
The default dimension styles and details are declared in [Design] tab, 7 Angled
Defaults dialog. Once the dialog is displayed, move the cursor over I Angular
the various parameters for a graphical representation of the meaning. Arc
@ Radius
Defaults @ e Diameter
| General | Shape I Tex | Routes I Copper Pourl Dimension | Dimension Line | Dimension Textl
Arrow Heads TTTT
style
Amow Heads
Layer:  |Letter Dril Drawing v
Style: e ———
Urits Length: 100
Units: Millimetres -
Upper Angle:  20.0
Precision: 2
Lower Angle:  20.0
Angular Units: Dearees -
"
Angular Precision: 1 e
OK || Cancel || Heb
rary Report Tools it
ids Ry ==
o || & @
All Snap || Attribute Attriby
On/Off - Editor MName
Line =3
q/n Endpaint |
TIP: Try using the Snap mode functions located on the [Design] tab A Midpoint
when adding dimensions. - | Perpendicular
/f’ Parallel
>ﬂ< Intersection
Arc
@ Centre
6\ Tangent
(:} Cluadrant
Ttem
BC pad
@ Origin
a2 Via
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Select the [Manufacture] tab and click the

Power Plane  1I] IPC-D-356 Report

Drill Drawing [55] Check Plot

Batch Process button on the ribbon. Batch | Artwork , ODB++ | Design
Process am M. C. Drill Reference
Batch Output ODB Reference
In the Batch Process window, select [Open]
and choose Manufacturing Output 2 Layer.ppf, which you can find in the ../Self Teach/ directory.
45 Batch Process - [C:\Users\Public'\Zuker\ CADSTAR Express )O{X\Self Teach\Manufacturing Output 2 Layer.ppf] @
Use Description Process Type | Colour/Report File \ariant Device Type Device Selections Qutput Hew
1 Z Gerber Copper pattern Componentside | Artwork Top Elec.col <NO VARIANTS= Photo Plotter re274-x usr Artwork.sel Gerber-Cu-Com
2 Z Gerber Copper pattern Solderside Artwork Bottom Elec.col =NO WARIANTS= Photo Plotter re274-x.usr Artwork.sel Gerber-Cu-Sold
3 || | Gerber Solderresist Componentside Artwork Top solder mask <NO VARIANTS= Photo Plotter re274-x.usr Artwork.sel Gerber-Solderre
4 [¥] | Gerber Solderresist Solderside Artwork Bottom solder m <NO VARIANTS= Photo Plotter rs274-x.usr Artwork.sel Gerber-Solderre
5 || | Gerber Sikscreen Compenentside Artwork Top =ilk screen. <NO VARIANTS= Photo Plotter re274-x.usr Artwork.sel Gerber-Silkscre
6 Z PDF Assembly Componentside Artwork Top Assembly.c <NO WARIANTS= PDF File <None= pdf.sel POF-Assembly_ Save da...
7 z Partlisting Report <Parts List= <NO VARIANTS= Text File <None= <None:> Partslist.rep
8 Z Placementdata Report Placement2.rgf <NO WARIANTS= Text File <None= =None= Placement.rep
9 z Drilldata (Plated Through Holes) N.C. Drill Defaults.col <NO VARIANTS= NCDrill File excellon2.usr Drrill_Plated.sel Drill-Plated.drl Add Row
10 Z Drildata (Non-Plated Through Holes) N.C. Drill Defaults.col <NO WARIANTS= MNCDrill File excellon2.usr Drrill_MonPlated. Dril-Non-Plated.
11 [¥| | Layer Stack-up report Report <Layers= <NO VARIANTS= Text File <None> <None= Layer stackup.t Delete Bows
Hide Dialog
Edit File...
Output Directory: |4 sers\PublichZukent CADS TAR Express X< x\0utputs [ Browse ] [ E stensions ]
[ Frefis Jobname to oulput fles CheckPCB | [ Saw | [ Cose | [ Hem |

Ready

In this 2 Layer design, the layers that are to be generated are;

Top Elec

Bottom Elec,

Top Solder Mask,
Bottom Solder Mask
Top Silkscreen

(all in Extended Gerber RS274-X format).

Additional data generated by CADSTAR manufacturing are;

Parts Lists,
Layer Stack-up report
Placement Data

Drill Drawing layers) rather than let CADSTAR generate a non-WYSIWYG output file.

e Extended Drill Data.

Drill Drawings (in the case of this design is recommended to produce PDF artwork of the

< Click the demonstration video link to see how additional rows can be added such as for a

drill drawing PDF file.

Click [START]. All manufacturing data will be saved in the Output directory.
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Note: During the generation of the manufacturing data, a check is performed to ensure items such
as Areas, Templates and Component Area are not visible. If they are visible in your design you may
receive warnings on rows that are using a colour file. To fix this, exit the Batch Process dialog and
then load the colour file for the row that is being flagged as a warning. Check the colour file and
change the visibility settings to Off for the item category being flagged. Return to the Batch Process
function and click the button to [Check PCB]. This is to check the colour files for items that are not
normally output as manufacturing details.

TIP: Select the Prefix Jobname to Output Files control to append the name of the design to each
output file. This makes it easier to keep manufacturing output for different designs in the same folder.

There are other tools such as Associated Dimensioning (Orthogonal, Angular, Radial etc.), Snap,
Component Rename etc., to help designers like you to create all the necessary manufacturing data.

TIP: CADSTAR also provides Design Rule Check functionality. When you run this function, DRC

errors will be flagged in the PCB layout. If you have unresolved errors at the time of post
processing, the Manufacturing output will notify you.
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Step 5 — Saving your Design for future Reuse

Small schematic and PCB designs like this Amplifier are typical examples of circuits that are saved for
future reuse. Once saved as a reusable circuit they can be recalled for use with other designs. CADSTAR
offers functionality for managing reusable circuits.

1. Display both your Schematic and PCB Design in CADSTAR.

v | e IR W RSN A

File Home Symbol Met / Shape Design Hierarchy Library Report Tools View AN 7]
EViewAII Q Zoom In :ﬂ Previous 'j [DEFAULT) o IF- ;’% JE;I Open Designs _J.J ltem Properties ] 4= Previous J Close
View Selection &), Zoom Out | [¢] Refresh = B3| Current Design | ¥ Shape Properties = =y Next ' Close All
X Colours Net Frame i i Group .
(54, Frame View 3 Manage - Bitmap | | Libraries i Start Page - BT Switch v
Zoom Views Display Highlight| Image Panes Tab Document
ﬁl Colours ~ | Item Properties [ x |
b=k ' | View and modify colour and i
o q visibility settings D Yl B
= v
S ‘ Property = ‘
o
1]
@
2
=i g 53.34mm =
’-.— 4B.ZEmm 4‘
=
[
= @
o ojlo e
o all
o
" SPEGHD
™
e
# ]
HRUTGHD
v v
L4 > £ >
q B Start Page DesignA2.scm - Sheet! [Ed| q B8 Designaspch [EA b [Ditem Pro.. [Wshape P
&) Redlining [E] BusReport i#] Design Rule Errors %] Electrical Rules Check [H] Overlapping Connections [£] Routing Completion (@] Unused Component
Ready 12185.3 4469.5 Thou  Grid: 5.0

2. Open the Colour settings for the design and change the settings for board outline, figures and
dimensions to non-pickable.

Select all the electrical contents of your PCB using a simple framing method. If Cross-Probing is
active the same components and nets should be selected in the schematic window. Deselect the

SOLDEREYE parts.

Select from the [Design] tab Manage Reuse Blocks—>Create
Reuse Block. The default location for reusable blocks is in the
Reuse Files folder as per the Path locations defined in the [File] tab

—>Options dialog.

'

CADSTAR Express

Colours

Library

Macros

Cutput

PREditor Configurations
Reports

Reuse Files

Selections

48

=2 Update Fields
1A Apply Readabili

Lar
#

Manage
Reuse Blocks =

& Create Reuse Block

@ Execute Hyperlin

t 54 Insert Reuse Block
Open Reuse File

Remove Reuse Association

Update Reuse Block
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5. Choose a valid meaningful name for the file. l.e. “Amplifier” and then click [OK].

6. Enter the same name for the Reuse Block name and | Enter New Name 5
then click [OK]

Mew Reuze Block Mame:

7. With the schematic data still selected from cross probing,
carefully click the schematic window tab. (not within the [
window since this will deselect the contents). This will

k. ] [Eancel] [ Help ]

change the tool ribbon used for schematics. Reselect the
circuit block and select [Design] tab Create Reuse
Block.

If you have prematurely clicked and deselected the circuit repeat the process for the schematic
data. Give the schematic reuse block the same name as the PCB reuse block i.e. Amplifier.scm.
Do not include the SOLDEREYE parts.

8. Select the Manage Reuse Blocks button. The new block name will be Y
listed. y o
Manage
Reuse Blocks ~
Reuse
Reuse Block Manager @
Block Mame Item
File path B
Amplifier Settings Actions
W Eriped ("] Repove Reuse Block
.................... P o L .
[| Fixed QU.E':I%
[ Mirrored
Orientation: 0.0 it
Repame... O, ] [ Cancel ] [ Help

Note: Since the Reuse Block files are named, this functionality will allow you to manage them
within the \Reuse Files\ folder. If you decided to make changes to the blocks, update both the
Amplifier SCM and PCB files. Then, for any design that used the Amplifier circuit, you can simply
update them by double clicking on them and selecting the Actions — Update option shown above.

In the next project, Design B, the Amplifier reuse blocks will be used. Simply select from the
[Design] tab, Manage Reuse Blocks 2>Insert Reuse Block and select Amplifier.
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E:] Assigning Unique Reference Designators for Reuse Circuits

Before reusing these circuits we recommend you perform a reference designator renaming procedure.
This will assign unique reference designators to the schematic and PCB components used in the reuse
circuits blocks and will also help to eliminate the chances they will be renamed automatically by
CADSTAR when they are inserted as reuse circuit blocks.

For instance; When inserting a reuse block into a schematic or PCB that may already have used the
reference designators that are used in the reuse definitions, CADSTAR will resolve the duplicate
reference designators automatically by renaming them to the next available ref des. This can cause the
reuse circuit blocks to become out of synch in between the schematic and PCB reuse blocks.

An elegant solution is to use the rename component function to rename the used reference designators
to something with a higher level prefix. l.e. R1 2 R1001, C1 ->C1001.

9. Open the Amplifier Schematic and PCB so you can see both at the same time and then click in
the schematic window to make it active.

File Home Symbaol
= L Global signal
it

= Signal Reference
Part or
symbol » F| Connector

Add

ML st x| -Lon e e R e

Met / Shape Design. Hierarchy Library Report
001(‘% Positional | ri]j <NO VARIANTS >
e v ﬂ; UET o Create Variant
Allocate . Mame Variant .
Part Range Manager Delete Variant
Part Mame Rename Variant

uflsaq uaung @]

WIoaY

¥, Positional Rename
Sequentially rename
components/symbols across design

salelq] mh

e
# ]
NRUTEND

q b start Page

(2] Redlining
Ready

DesignAZ.scm - Sheett [EJ -

[E] BusReport

E] Dresign Rule Errors

%] Electrical Rules Check

Tools
M
e
Reload

Reload

B8 DesignAS.pch n

E Overlapping Connections

11844.0 9854.8

View
Etﬂ {E; Export FPGA
ﬁlmp-:-lt FPGA

Replace | o Aldec Active-HDL

Replace

53.34mm

Aldec

7]

~ | Item Properties [ x |
DG T ta o
v

‘ Property al

3 __J.jltem Pro... jf*a:i3
Ek] Routing Completion ﬂ Unused Component

Thou  Grid: 5.0

10. Select the Positional Rename button on the [Symbol] tab as shown above.

50

ZURKEN


http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/movies/cadstar15/CADSTAR_Renaming_Components_for_reuse/CADSTAR_Renaming_Components_for_reuse.html
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar

™

11. Apply the settings as shown in the image for components with a stem name of R.

This will rename the resistors using a 1000 prefix range
in a Left to Right — Top to bottom sequence.

Symboal Met / Shape Design Hiera
Repeat for stem names of C, D and TR. al Signal 'E ¥ Positional
| Reference bt § LI: Mame
Allocate Mame
nector Part Bange
Positional Rename
- —— = = = = g First Fiename Direction Second Fename Direction
J] Uze Sheet R anges @) Left to Right Left ta Right
Wame mng?Eyﬁmeet_is ok enabled ") Right to Left Right to Left
a
Sheet Fanges ) Top to Bottom @ Top to Bottorm
IEE:m 1001 I ) Bottom to Top 1 Bottom ta Top
ISEEP 1000 M I Rename Range Symbol Bandwidth
Minimum Length Istem R 1
— -—
Sheet From To Tower ™ 250.0
Name
7 | Sheeti 1001 2000 Upper 3333
Riestrictions
Shest
@ Nore ) Current Sheet

@) whole Dezign

VR GY

Selection Only

) Selected Sheets
Mame Range By Sheet

= Erars Select Sheets...

TR10D1

N353 rLE:pI_l,I_ .:’ Cancel ] [ Help ]

R1002

S D100
1N4146 3E3

C1001
Ll
il
1000uF
R100D4
3E3
12. Save the Amplifier schematic again,
E overwriting the version currently in the \Reuse
TR1002 Files\ folder.
ZHZIBR5A

©

The renaming of the components in the
schematic can now be passed to the PCB
circuit block by way of the ECO Update
function.
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13. Click in the PCB window for the Amplifier to make it active.

14. Click on the [Design] tab and then the ECO
Update button.

Click [Yes] if the following dialog appears.

ECO Update

Do you wish to continue with ECO Update?

FYes | [ Mo |

Use the 'Align Nets' option in Connection Check to realign the net names.

Changes have been made in the PCB editor which may have caused loss of alignment
of net names against the original net list. This could generate unexpected ECO updates.

Design Library Report Tools Manufacture
- || Gri Etg;.
/Table j Grids ?x"i E E
ules g Units =
All Snap | Attribute Attribute ECO
On/Off - Editor MNames Update
Grid Snap Attributes ECO
ECO Update
ECO Source

C:AJsershPublich. . \amplifier scm

15. Browse to the \Reuse Files\

folder and select the Amplifier.scm as the ECO

Source data.

16. Apply all other settings as shown and click the [OK]

button.

17. Click [Yes] on the Design Comparison information
dialog. The results will be displayed in an ECO

Update report

Design Title:
2 Layer Defaults

Date:
Time:

Monday, May 8, 2017
4:906 PH

Rename Component
13 components renamed
"“C1" renamed to "C1862"
“C2" renamed to “C1001"
' renamed to "D1862"
* renamed to “D1881"
renamed to "R1865"
renamed to “R1003"
' renamed to "R1006"
* renamed to “R1881"
' renamed to “R1882"
renamed to “R1004"
" renamed to “TR1003™
" renamed to "TR1801™
" renamed to "TR1862"

o4 1

[ ciose | [saveas.| [ Pirt. |

" | ECO Update = &)
ECO Update
CADSTAR Design Editor Version
Design: C:\Users\Public\Zuken\CADSTAR Express

m

52

Comparzon Dphions

Excluzions...

Betain routes on component deletion

[ Advanced Configuration... ]

Perfarm Library R eload on campletion
[] Retain Local Reference Mame

[T] Retain Local Pad Information
|Jpdate Pin Labels
|Update Pin Testlands

[ Transfer Feuse Blocks
Ferform Update of Reuse Blocks on completion

Schematic Source Options
Update Yanant Hierarchy
Replace Net Route Codes

Met Foute Code Aszignments

Replace Min/t ax Bestrictions
Feplace Optimal/Mecked Widths
Fetain Feazsignments

Tranzfer To PCE Ophions

Fepaort Unnumbered Terminals
Repart D angling Connections
[T &llow Single Mode Mamed Mets

[ Cancel ] [ Help ]

Note: ECO Update will also change
system assigned net numbers as part of
the process. If you have important nets
it is recommended they be given proper
names.
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18. After reviewing the report carefully, click the [Close]
button. You will be presented with opportunity to accept

the changes. Click [Yes]

The PCB design will now be updated to match the

schematic.

ECO Update

—,
e 3

k.

Accept automatic design changes?

No |

19. Save the Amplifier PCB design again, overwriting the version currently in the \Reuse Files\ folder.

G S0 FHI S ERE | DesignA2.scm (C:\Users\Public\Zuken\CADSTAR Express XX.X\Self Teach\) - Sheetl - Schematic - Zuken i =] 3]
Home Symbal Met / Shape Design Hierarchy Library Report Tools View P \@‘
EVlewAII \ﬂbZoam In \'ﬂ Previous ‘White Background ~ h’f‘ @ Open Designs fj)ltem Properties e | 4= Previous ﬁ" Close
) =
52 View Selection \-)bZoam Qut @ Refresh bW Current Design W Shape Properties - S MNext :r Close All
Calours Net Frame — Group
[, Frame View & Manage = Bitmap | 4] Libraries |41 Start Page - B switch -
Zoom Views Display Highlight Image Panes Tab Document
5” 4 ' startpage " B3| Designazscm - sheetr x | 3 ‘4 /" #8 pesignas.pcd x | )
gl 2 [ 4 5 = g
gl B WCCS >
3 =
&
3
= @
L )
o B
2 |-
2 g
g =
[} el
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&
=
fr &
&
| L
(e}
=
d
=
o
@
=
[
= R2
_ KB
[53]
D wRuT - Ve a
[
uF
R1
MPUTGND HE
3 | 4
K| _
||E] Bus Report |@ Design Rule Errors ||@ Electrical Rules Check |® Overlapping Connections ||§ Routing Completion |@ Unused Components |D£1 Name Range By Sheet
Ready |[121313 94624 Il |[Thou |[Grid: 250 || | 4

This completes the first design with CADSTAR Express!
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Add the Power of 3D to your Design

You can also check out BoardModeler Lite, supporting import/export of STEPS AP203, AP214,
ACIS,STL and IDF formats, providing you an optimized solution for the placement and verification of a
PCB Design in its own 3D environment, including:

a.

Replacing board shapes and modifying component placements which are smoothly back

annotated.

Creating detailed 3D models using the 3D parts creation wizard
Importing Mechanical Enclosures (or other PCB designs).
Measuring Distances and Checking Clearances.

Running Batch collision checks.

BoardModeler Lite is more than just a 3D viewer!!!

You can find more information at:

www.zuken.com/cadstar-board-modeler-lite

Mechanical CAD CADSTAR

wSCIRS oy =l

prp— dlewcvasesre 85
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Chapter 2 — Design B

In Design B, we will expand on what you have learned in Design A by exploring more features within
CADSTAR. We will use the Amplifier circuit in the form of a Reuse Block for both the schematic and the
PCB design. We will use Hierarchical features in the schematic and use a more elaborate PCB board
outline with predefined component placement as an example of a Mechanical CAD driven system.

The project we will be designing is an audio device that many electronic hobbyists have built to cure
insomnia. The circuits will emulate the sound of rain falling. This is similar to that of a white noise
generator.

The original circuit was obtained from www.electroschematics.com as a free download.

&)
R4 12 ... 30V/60mA
270k
100k lin
| Zyam
R1 | Iln
270 — 1
2.7k Pl \
47k lin
B £
0.1 .\
AH 10
Ic1 e
, — 2N1613
c1r C2 | 741 R7 . =1ca
1] 5 ; :I_
10n e R& 470
A R2 R3 10p/25V
2200 4..320 [
i 1000 220k

We have expanded on this by adding an additional amplifier that will be activated with the push of a
button and an optional ear phone jack.

The PCB design will be created for you with predetermined coordinates and rotations of the parts. You
will import this as a DXF file and begin placing the remaining parts.

Routing and Placement can be accomplished using the Embedded Place and Route Editor.

You will then be able to use your new skills from the previous design to complete Design B called
Rainmaker.
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The Image below contains the finished Rainmaker PCB design. The 3D models are available as part of
the CADSTAR — Board Modeler Lite tutorial guide. If you would like to take this project to the 3D Level

contact your CADSTAR Sales agent to obtain a full CADSTAR and Board Modeler Lite evaluation
license.
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Step 1 - Schematic for Design B

The sequence steps are the same as Design A.

Create a new schematic sheet using Form A3-euro. Set the working grid to thou and screen

grid to 100, 100.

Pick out components from the Library Workspace window. You may also use the Library

Searcher as well.

The Parts list is as follows

Part Name Description Qty Comps.
0.1UF-COG2-5% 0.1uf 100V COG Mlayer Ceramic 1 Cc2
10-TR4-1% 10 Ohm TR4 Metal Oxide Film 1% 1 R14
100-TR4-1% 100 Ohm TR4 Metal Oxide Film 1% 1 R5
10UF-10V-EC 10uF 10V Electrolytic Capacitor 1 Cc4
2.5MM PWR CON Power supply connector 2.5mm 1 J1
220E-TR4-1% 220 Ohm TR4 Metal Oxide Film 1% 1 R7
220K-TR4-1% 220K Ohm TR4 Metal Oxide Film 1% 1 R6
270K-TR4-1% 270K TR4 Metal Oxide Film 1% 2 R2-3
2K7-TR4-1% 2.7K TR4 Metal Oxide Film 1% 1 R1
2N1613 SABER TRANSISTOR 1 Q2
2N3904 SABER TRANSISTOR 1 Q1
47uF-10-EC 47uF 10V Electrolytic Capacitor 1 C7
470E-MRS25-1% Metal film resistor MRS25 470E 1% 1 R4
BA156K0103J-- Leaded film capacitor 1 C3
BA156K0104J 1nf Leaded film capacitor 1 C1
LM741CN SINGLE OPERATIONAL AMPLIFIER 1 Ul
LGY2109-1701F STEREO- CONNECTOR - EARPHONE 1 J2
NEC_TOKIN_UC2_RELAY NEC TOKIN's UC2 Mini Signature relay 1 RL1
RS15H11AA04M-100K Slim Slide(Slim 4) RS**H Series 100K 1 P1
RS15H11AA04M-50K Slim Slide(Slim 4) RS**H Series 50K 1 P2
SOLDEREYE-1MM Soldereye 1.0 mm 2 SP1-2
TL1250F180BQRCLR SPST - Tactile Switch N.O with Blue Led 2 SW1-2

3. Place the components on the schematic sheet. The schematic is on the next page for reference.
Feel free to print the page for this easier viewing.

Remember that symbols may be mirrored as well as rotated. However for most cases use the
appropriate alternate symbol to match the schematic.

Parts STP1 is a 2-pin Star point symbol. It resides in the library and has a PCB star point footprint

representing a large single pad component. In fact this is special component that allows two nets
such as ground returns to be connected together at a predetermined location using routed traces.
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As you create the schematic, feel free to make adjustments to the;

scale of the symbols using the Item Properties dialog

size of the text and fonts using the Assignment settings

position of the attribute test introduced with the part.

colours using the Colours dialog.

local visibility of pin names/identifiers for parts such as resistors and non-polarized devices

4. Save the design as Rainmaker1.SCM

5. Connect the components — Note that the connections are different colours. This is due to the
use of different route codes.

For Power Nets (red) use Net Route Code VCC
For Ground nets (green) use Net Route Code GND
For all other nets (purple) use Net Route Code Signal

6. Add Global Signal symbols accordingly. They can take on unique net names. See the
schematic for the appropriate names.

7. Optional step. If you would like to learn about using Spacing classes, you will find it very
useful to declare unique spacings between groups of Nets. Circuit designers appreciate being
able to define this information in the schematic.

Assignments @

Lines | Routes | Text | Teminals | Hatchings | Met Classes  Spacing Classes |

net w_ith spacing class X
Spacing Classes ]
. net with spiacing class ¥
Used Spacing Class [ Add Assignment
O] [110v |  DeleteRow |
] |220v
[] |Grounds
] |Powers

8. Save the design as Rainmaker2.scm
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We will now add a second sheet to this design. This will be a lower level hierarchical sheet that
we can push down to and pop up from as we move from sheet to sheet. To connect to the sheet
we will add a hierarchical block with terminals to emulate signals connected to the lower sheet.
The signals names are shown below in red. The block has been named “Optional Amplifier”

2 P
}_——»« -
4
O
7
e . 12v_8 SP1
O SPK+IN SPK+0OUT -
Optwnal AmplLifier
AGND
L2 SP2
¥ ©
5TPI
Home Symbol Met / Shape Design Hierarchy Library Rep
E= J Pop Up |_d.h| A Edit Block 3:7 Upwards Cf»;; Create Mew
[==1 Push Down ;@: Add Block | 4 Downwards :{C\ Link to Another
select Add Block . . o
Sheet Shape |4 CutBlock
Mavigate Elock Symbol Add Terminal Sheet Link

9. From the [Hierarchy] tab select Add Block shape. Click to start the rectangle start and end
position in the approximate location shown in the image above.

10. Double Click on the block shape outline. You will be prompted as follows.

Select [Create New Sheet] | Push Hierarchical Block [m5m]

Thiz block iz not prezently linked to another sheet.

| Create Mew Sheet... | [I__ink b Another Sheet... ] [ Cancel ] [ Help ]

Name the new sheet 7 i
“Optional Amplifier”. Create Mew Lower-level Sheet @

Mew Sheet Mame:
Click [OK] Optional &mplifier

[ ] ] [ Cancel ] [ Help ]
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CONTRACT NO. COMPANY NAME
APPROVALS DATE DWG
DRAWN
SIZE | FSCM NO. DWG NO. REV.

CHECKED A3
ISSUED SCALE SHEET 2o0f2

| 7 8

7 [

You are now in a new schematic window using the same format sheet symbol labelled

61

Sheet 2 of 2.
11. Open the Open Designs auto-hide panel to see that the &5 Open Designs > & @}
greu\;vefgfeter':eagﬁie;sl m;irirrl]tted to suggest that it is a child S El"ii’ Open Designs I
parent. = £+ RainMaker2_CS.scm (CAU
3 -4} Sheetl
Note: Here you may rename Sheet1, if you wish by clicking |2 g Optional Ampiifie
on the name and clicking the <R.M.B.>. Select Rename [=
sheet.
] ) [ Create Mew Sheet @“
Note: New Sheets may be added in this same manner by
selecting Add Sheet. Ve d Sies!
Top Level Sheet will be at the same level as sheet 1. @ Lomsrdevel Shest
Adding a Lower-level Sheet will create it as an unconnected
sheet and be displayed as a light blue icon. This means that a | naw Shest Mame:
Hierarchical block will be needed to bring the new child sheet Sheet3
under the desired parent sheet.
[ (] ] [ Cancel ] [ Help ]
12. Click inside of the Optional Amplifier sheet space and the & Previous view Shift<F
click the <R.M.B>. Click the Pop up option to take you upwards E7 View Al Al-Fa
to the parent sheet.
i PopUp Ctri+U
This function as well as Push Down or doubling clicking on the w |
hierarchical block shape makes it easy to move from sheet to e
sheet. -
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Next we will add terminals to serve as connection points to emulate net connectivity between the
sheets.

Note: that this is optional as common signal names are automatically merged during the sheet
collating phase, such as during the transfer to PCB process, ECO update and Back Annotation,
etc.

Design Hierarchy
13. Click the Downwards option on the Add Terminal section of the Tr Upwards %
[Hierarchy] tab. 4 pownwards | T
| [ Add Terminal

Note: Steps are dictated

for functions at the lower :

left corner of the k] BusReport |[&] Design Rule Errors
application window. Select block for new terminal
Click on the block shape. From the dialog, | AddBlock Terminal - Downwards ()
open the Signal Name list and select AGND.
Sighal Mame:  AGMND -

Change the Terminal Code to Cross. This .

. . , Terminal Code: | Cross v|
terminal code uses a ‘Plus’ shape.

. Pozition: s AN
Click [OK]. _ _
Multiple Terminals

Place the terminal on the bottom side of the Repeat Teminal

block outline as shown.

Press the <esc> key on the keyboard or click
the <R.M.B.> and select Cancel. This will i

. oK Cancel Hel
return to the dialog. | [gered | [tk |
You may specify new net names as well.
Enter the signal name 12V_B then click [Ok] and position 12v_B
this terminal on the top of the block symbol as shown. SPK+IN SPK+0UT
Optional Amplifier
Repeat for SPK+IN and SPK+OUT placing them as AGND
shown.
Item Properties - Block Shape @

Click the <R.M.B.> and select Finish. L Wit Code

Line 10 - [
You may position the terminal name labels as you like. Fived 7] Cosed

Fill Type:

[1ctean) -] @)

14. To apply a name to the block symbol select the outline | ..
and enter Optional Amplifier as shown and click Optional Amplifier
[OK].

Segment(z] Length: 1400
Lower Sheet Mame:
Optional &MP

ok ] | Cancel | |gttributes...| | Help
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15. Push Down to the Optional Amplifier sheet to see the lower level terminals. As each terminal
was placed, its corresponding hierarchical terminal was placed at the same X, Y location on
the lower sheet.

TIP: As the demonstration video shows, Hierarchical terminals codes can be changed, if so
desired, using the Item Properties panel. For instance the Hierarchical terminals on the lower
level sheet can be assigned a terminal code that represents a filled arrow whereas the Upper
hierarchical terminals may continue to use the Cross terminal code.

16. Pop Up to Sheetl and finish adding the connections to the new hierarchical terminals as shown
on the schematic. Remember to set the Route Codes to maintain the same colour correlation.

o =
4
¢
7
O : 12v_B SP1
(o] SPK+IN SPK+0UT £)

Optional Amplifier
AGND

L2 SP2
* ©
STPI

17. Save the design as Rainmaker3.scm.

We are now ready to add the reusable circuit block that we saved in chapter 1.

Creating lower level circuit blocks for the purpose of adding reuse blocks is a nice way to maintain a
tidy design flow, though they are not required.

= = Update Fields
[ 1A Apply Readabilit
Manage
Reuse Blocks = W Execute Hyperlin
[te Create Eeuse Block

18. Push Down into the lower level sheet.

)

. ¢ Insert Reuse Block
19. From the [Design] tab select Manage Reuse Blocks - Insert

reuse Block. E o N
-

Select the Amplifier schematic block.

As the block is integrated into the main design items such as component reference designators
and net names are checked and compared to those already used.

Duplicate component names are renamed to the ——— =
next available reference designator per their prefix "=

stem name. Met with thiz name already exists:

. . Mame:  AGMD
Duplicate Net names are prompted with the

adjacent dialog allowing the user to decide to Join
the nets or Rename them to keep them separated.
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Since you have connected the AGND hierarchical terminal to the starpoint part, the net does in
fact exist and we can Join this instance. Click [Join]

The following dialogs are very important to consider. If you are familiar with every net name in
both circuits and agree that it is ok to repeat the Join operation for every duplicate net then do
so. Else you may cycle through each net individually to avoid joining two nets together
accidentally.

20. The Amplifier circuit is now attached to your cursor. Place it on the sheet.

The circuit is now grouped and in a state of being locked as a reuse block.

Current Design * +H
By
o =] 12 (DEFAULT) -
21. Open the Current Design panel menu. Expand the Reuse S | %) <NO VARIANTS> -
Blocks branch to see the reuse blocks that are currently in - [ Current Design
. . [1:] =1 _'
the schematic design. é [l Buses
I:ﬂ Groups
+._"lj Mets
22. Place the Lower level Hierarchy terminals near their & = ReuseBlocks
respective nets and connect them accordingly. — - Amplifier
g ':*"'.Q'j Symbaols
12 _B ints
R1001
470E
C
g TR1001
1 2N3053
E
-
S D1001 R1002
1N4148 3E3
u 1001
. ﬂl N SPK+0UT
1000uF
R1004
3E3
E
TR1002
ZMZ985 4
[
SPE+IN
. HEHD
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23. Create the Parts List — When prompted select

24. Print the design.

25. Save the design as Rainmaker4.SCM

If you have not completed the design to this point,
please load Rainmaker4_CS.scm and save it as
Rainmaker4.scm.

26. Transfer the schematic design to PCB
(choose '2 layer 1.6mm.pch' as PCB
technology).

Since we are using design reuse blocks you
must also check the option (shown below)
Perform Update of Reuse Blocks on
Completion.

You will be presented with several verification
dialogs pertaining to new items to add to the
design.

Accept them until the Reuse Block Update
Summary report appears as
shown. ->.

W View File

both sheets in the dialog.

Transfer To PCB
Output File
C:AUsershPublic\ZukentC.. \R aint akerd. pch Browse...
Format; | PCE Binary ~ About...
Categories... Options. .. Format Help
Source Sheet Source Y ariart
() Current Sheet Current ' ariant
(@) ‘Whole Design Al ariants
() Selected Sheets
Select Sheets..
Transfer Ta PCB
Template Folder:
C:AUsers\Public\Zuken\CADSTAR Express 1. \Templates
el CELECHIOIO, o e o o
= |
...... 1.Bmm.pch X
i ————————_——— .
Wiew Mew Design Settings
Fieport Unnumbered Terminals
Fieport D angling Connections
Allow Single Mode Mamed Mets
- -y
Perform Update of Reuse Blocks on Completion
— e e e e e e e e ol
Mapping File
Browsze...
Usze Map Create Map. . Edit tap...
Cancel Help

Note: the warning reflects the
use of the Part Acceptance
attribute used in the parts
library definition for;

Design:

Design Title:
A3-euro -Size Sheet

Date:

Time: 4:087 PH

“LGY2109-1701F” and

C:vUsersyPublic\Zuken\GADSTAR Express 18.0%Self Teach\RainMakeri4.scm

Honday, May 15, 2817

Gollating Schematic Design

CADSTAR Design Editor Version 18.6.B.138

“STAR-POINT_2-PIN”".

Collation Results:

PCB design has:

For these parts the text string
values have been highlighted
for this attribute. You will

1 group(s)
1 reuse block(s)

39 components (39 with Part Names)
71 connections in 27 nets

@ Errors, 2 Warnings

learn more on this in the next

chapter. 4 = Sheet (A1l Sheets) \
I Warning: Part °LGY2189-1761F' :- Zuken Part
. Warning: Part 'STAR-POINT_2-PIN' :- Hot a physical part
Click [Close] L) W it A
End of report
Close Print. LCopy
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The new PCB design is displayed along with the reuse block, grouped, as shown below.

W View File O X
________________________________________________________________________________ ~
Reuse Block Update Summary
CADSTAR Design Editor Uersion 18.8
Design: C:\Users\Publich\Zuken\CADSTAR Express 18.8\Self Teach\RainMakerk._pchb

Design Title:
2 Layer Defaults

Date: Monday, May 1%, 2817
Time: 4:12 PH

Reuse Block - Amplifier
Updating from reuse file C:\UsersyPublic‘\Zuken\CADSTAR Express 18.8\Reuse Files\Amplifier_PCB

Success

8 reuse block(s) selected. 1 reuse block{s) updated successfully.

Save Az Frrint... Copy

Home Component Met / Shape Design Library Report Toaols Manufacture View & g
- k3 -
r ( i\_l jﬂ +3* Move T E;‘E =] O Copper ] == Measure E 9
= :_ 4l Mirror & Separation =
Select Item ' 5 Part or Redlining Embedded Paste Undao
- Properties 4 Rotate ﬁ IEI Component ~ A Marker vyoo ' HmAdd M - -
Select Item Move Flags Add Add Shape Dimension Tools Clipboard

Ho oD s QUK -

Item Properties + 1B

i L ?13 ﬂuu [y
v
Property al ‘

uBlsaguaung [

salelq] m]

4 RainMakerd.scm - Optional Amplifier RainMakerd.sem - Sheet1 . BB RainMakerd.pch [Ed b
Q] Redlining E] Bus Report E] Design Rule Errors @ Electrical Rules Check H Dverlapping Connections E‘] Routing Completion
Ready 19629 1125.0 Thou  Grid: 2!

Note: the reuse block has been moved slightly by the author from its original location for image clarity.
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Step 2 - PCB Placement for Design B

You can now start to place and arrange the components on the PCB after the transfer. If you have not
completed the design to this point, please load Rainmaker4_CS.PCB, save it as Rainmaker4.pcb and
skip to Step 5.

1. Check and/or change the Units & Grid (25 thou is preferred).

2. Click on the Amplifier circuit block and move it to the right of the components to make way for
the incoming board outline.

Remember, when a new PCB design is created all components are Het/Shope | Desan (TR
placed in the positive quadrant of 0X, 0Y, this is considered the s @ Drill Letters/Tsble = | ]
initial Design origin. ®(7 Electrical Rules =|
Is @ Crigin =
i @ Interactive Origin -~ |©
3. Select the [Design] tab and click on [Origin=>Design Origin]. E @ Dpesign origin
.

You will see the design origin symbol move to X 1000, Y 1000.

Settings Design Origin

Current Origin Position:

¥ |n.u | Y |n.u

(®) Origin Position Absolute
() Origin Position Relative ta Curent Origin

# Pogition : ¥ Paogition :
4. Import the DXF Board outline using the Rainmaker_Boa.dxf [1000 | [10m
file located in the \Self Teach\ folder. Also use the same
dxfin.map file. This DXF file also contains other information Cancel Help

such as Critical Component placement and dimensions as if
provided from the mechanical engineer.

N Import Design

board outline imported

area{s) imported

copper item{s) imported

figure(s) imported

template{s) imported

text item{s) imported

13 dimension{s) imported

18 critically placed components found in dxf File
4 critically placed components added to design

6 critically placed components already in design
File C:\UsersyPublic\Zuken\CADSTAR Express 18.8\Self Teach\Rainmaker_Boa.dxf successfully imported

[N~ -~

Save .. Frint... Copy

Note: From the image above, 4 critically placed components have been added to the design. This
refers to 4 mounting holes that are imported as single pad components. The DXF Import process will
acknowledge the ref des and component reference shape request. If it is not in the design, CADSTAR
will import it from the Parts library. This process is described fully in the CADSTAR Help.
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Tip: Once the PCB window displays all of the information from the DXF
file, you may find that the connections are not optimized (to their shortest
length). This can be quickly resolved using the Reconnect feature Iﬂr : 73 Merge

Met / Shape Des

located on the [Net/Shape] tab. This function will simply optimize the [« f Reconnect
appearance of the connections thus eliminating length. This does not Set
Width w Unroute

have any impact on the Signal integrity constraints.

Route

Reconnect Summary =
Connection Length Before : 895078
Connection Length éfter ; 49577 8
Mumber of Ring Connections Deleted : i

Help
B2 .B3mm
2.59mm
‘}%‘7 sL.Zlamm

2 9@ . AAmm

3B.1Bmm

= 55.86mm
15 4Bmm

£
=

o]qf’ayt
i

e 4‘
o
=

Note: PCB design shown after reconnect function has been run.
Note: the reuse block has been moved slightly by the author from its original location for image clarity.

If you have not completed the design to this point, please load Rainmaker5_CS.PCB, save it as
Rainmaker5.pch.

Next we can move the reuse circuit block into position. Since the block is grouped. It is possible to
click on it and move it as a single object. It may also be rotated on any angle.

°% ZURKEN
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Even though the amplifier reuse block does not quite fit. This is OK and probably a normal occurrence
for the experienced PCB designer. Later we will remove the reuse block association make some
placement adjustments and copper pour template adjustments. The point of the exercise is basic

Design Reuse techniques.

5. Place the block as shown below.

Tip: if you pick an object by a location that you would like to change while in the “Move” mode,
click the <R.M.B.> and select the “Change Selection Origin”. This will temporarily suspend the
movement while you select a different location. Once you click the object the movement will

resume.

Tip: Enable the Snap point function located on the [Design] tab before changing a selection

origin.

and clicking <R.M.B.> and clicking on the Fix function.

Place the Starpoint STP1, relay RL1 and the SP1 and SP2 components in the suggested
approximate locations shown on the next page. Fix them once they are placed by selecting them

58 BBmm

—e
mm 3B .1Bmm

15

62 B3mm

2.59mm
|-

8. 28mm

8.589mm

57 .23mm

a2 @dmm

9@ AAmm
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7. Select the Embedded Place and Route icon located on the [Tools] tab.

8. Arrange the components around the board outline using the Stack function located on the

[Home] tab.
9. Select the Move icon and the | e @ Foue_ Destan
Component mode focus icon ,\!) I_*é*ﬂm_'l
and manually place the other o =) swap ~ | = %
components. Properties  ¥a Rotate ~
Item Move Flags

Report

Wiew

:E- Align = 00 Space

Component|  +# Push + [ stack

Placement

10. Exit the Embedded Place and Route and save the PCB Design.

Adjusting the Reuse Circuit block.

At this point we will make the necessary adjustments to the circuit block so that it fits with this board

outline.

11. Select the Amplifier reuse block. From the
non-modal Item properties panel, turn off the
Grouped setting.

12. Start by modifying the shapes of the existing
copper pour templates that are a part of the
reuse block. They can be selected and
stretched to the left of the board outline as
shown in the image. >

13. Delete the round cut-outs that in the
templates. There are 8 total, 4 on each
template.

RL)
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14. Open the Current Design panel on the left side of the application window. Expand the Reuse
Block branch, click on the Amplifier name and click the <R.M.B.>. Select Remove Reuse
Association. You are now free to make any edits to the circuit block you wish.

ol el * A [B] kera_cs.sem - sheetd
j 23 White Background PCE  ~

Tyl <NO VARIANTS> -

=-{~=7 Current Design

|ﬁ| Areas
Note: This is an optional process, it is not necessary to eil Board
remove the association. If a PCB design warrants this <@ Components
technique, it is recommended to also remove the reuse
association in the schematic reuse block as well.

uBlsag uanng @]

_ Reuse Blocks

g ~— =

. . . . . : i) Htem Properties...
However if you pay attention to the intricacies of the g I::;

salelqn m]

block and later remote select the PCB block items from | _ | & yie, * ctrl=x
the Schematic window using Cross probing, you can f 2 Comy cri=c
create a new reuse block of the same name to insure |z K| Beete pelete
that it remains in synch with the schematic. g =0 Fix

=) =5 Unfix

“ 3 View Selection

Replace

24 Open Amplifier_CS.PCB
[ Uit el 15008 | Ol s 1

q Remove Reuse Assodiation
-_— s = —'| - a1

15. Select the copper polygons and associated templates and delete them from both Top and Bottom
layers.

16. Select the Embedded Place and Route icon located on the [Tools] tab.
17. Use the move commands in the Component focus mode to adjust the placement of the two

capacitors and perhaps R1005 to a more proper location.

If you encounter any errors that you wish to ignore, click the <R.M.B.> and select Toggle errors
allowed.

As you move routed components, the routes should remain routed as they move with them. .

18. Exit the Embedded Place and Route and save the PCB Design.
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If you didn't manage to place the components, just open Rainmaker6_CS.PCB and save it as
Rainmaker6.pcbh. This file has the copper and templates already removed.

19. Create four new templates to support the power and ground nets from the main Rainmaker circuit.
The GND and AGND templates will be on layer Top Elec, the 12V and 12V_B templates will be
on layer Bottom Elec. Using the Item properties use your judgment when making the settings to
the templates.

Shown below is a suggestion of the shapes for the templates. Those in green represent AGND
and GND. The red represent the signals 12V and 12V_B. Notice that the templates can be
outside of the board outline. The Copper pour function will only pour up to the board outline minus
the Copper to Profile spacing that is allowed.

Star| Paint

et ”@T i - —
alBls @ &@ ™

T e Bk
O LR . c|lc|lE T Tz &
V/ T ’/TlﬁTifﬁ

Ll Lt 21t 9T
o L
SW2 ill::
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Step 3 - PCB Routing for Design B

You are now at the final stages of the PCB design. For this task you may use the Fix command to lock

the existing routing from the Amplifier reuse block in place.

1. Selectthe Embedded Place and Route icon located on the [Tools] tab.

2. Manually route any critical nets such as 12V from SW2 (Shown below as partially routed to the
closest 12V template contact point), 12V_relay_enable and 12VA.

3. An additional route (AGND) can be routed on the Top Elec layer from J2 pin 1 or from J2 pin 5 to
the Star Point. You can also route from R14 pin 2 to J2 pin 1 or pin 5 as shown in the image

below.

If you recall from the schematic part entry, the symbol
indicated that pins 1 and 5 are internally connected.
Therefore you did not connect pin 5 to pin 1 using a
physical connection in the schematic. These are
connected on layer Interconnect, which must be made
visible to see.

Pins | end &
are internally

connected

N PR2 4
R 3

NS
N N

e}
=
=]

Perhaps you have encountered some parts where a similar situation can occur. This unique
situation can be addressed by creating a closed polygon shape within the component reference

shape. This can be drawn on an electrical layer and
used as part of the actual copper routing pattern or it
can be drawn on a non-electrical layer where the net
connectivity is simply implied.

Once you have routed this pattern, use the item
Properties function to verify that the other pad is in
fact connected to AGND.

4. Using a framing technique, draw a rectangle around the extremities of the PCB outline to select
all items. Click the Fix command located on the [Home] tab.

74
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5. Automatically route all other nets then spend some time manually routing using the Activ-45
routing mode. This is accessible from the <R.M.B.> menu.

Note: Do not route any other pins connected to the 4 power and ground nets. This will be
completed in the next step.

6. Once you are satisfied with the routing results use the Pour copper function to complete the PCB
design. This will make the connections to the 4 power and ground nets.

Note: the two connections coming from the Star point must be routed partially to the finished
Copper pour shapes.
If you wish to fine tune your routing to ensure each power and ground is properly connected to the
poured copper, simply Undo the copper pours or use the Clear function.

7. Exit Embedded Place and Route and save the PCB design.

If you didn't manage to complete the design, just open Rainmaker7_CS.pcb to have a look.

Tip: If you still see connection guides on the power and ground nets, verify the completion of the
routing to the copper polygons by generating a HTML Routing Completion Report. This is located
at the bottom of the application window. A sample is shown on the next page though yours may be
different. Simply click on the Items to see what is being reported.

~ ZURKEN
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Routing Completion +* 1 [

BEagoeuanhaiER
Routing Completion

CALCRTAR Design Editor Version 18.0

Design: C:\Users'\Publict Zuken\CADSTAR Express 18.0'5elf Teach'\RainMaker 7.pch
Design Title: 2 Layer Defaults

Date: Monday, May 15,2017

Tirme: 430 PM

Routing Completion: 99.1 %

Total number of nets containing unrouted connections: 1

Total number of unrouted connections: 2

Connections Unrouted Between:

Net Start End

AGND (2960.7. 2055.1) (3226.2. 2165.1)
AGND (2960.7, 2055.1) (3226.2. 2165.1)
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Shown below is a sample of the placed, routed PCB with copper poured. RainMaker7_CS.pcb

The mounting hole M3 is shown in 3D using Board Modeler Lite to
illustrate how additional spacings can be applied using items such as
Keep-out areas within the components reference shapes.

DE BN 8@

Property Value ‘ ‘
Name Top GND
. . : . Fixed

A benefit of creating Keep-out areas in the component shapes is they Line Width Code  Line 1 =)
can be enabled within the template properties. > FilType (Clear) |
Copper Code 10 62 |
. . . . . Relief Copper Code 20 62 |
If you experiment with this design, try changing the template property Layer TopElec 3

for the Top GND to Allow in NonRouting area. Then use the SinalName | GND

Embedded Place and Route tools, to re-pour the copper. et e

e, — ] —

Allow InMoRouting [ [JT ]
ROy 1Ol te AR S o — | —
Autematic Pour

Target For Autorou

Retain Poured Cop
Thermal Relief
Suppress Inner La

! ZURKEN
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Step 4 - Manufacturing Data for Design B

1. You can select [File] tab=> Manufacturing Export-> Batch Process &2 [Open] select
Manufacturing Output 2 Layer.ppf ) in the menu bar to create the manufacturing data.

At this point you might want to check out the capabilities of BoardModeler Lite. It supports import/export
of STEPS AP203, AP214, ACIS STL and IDF formats; providing you an optimized solution for the
placement and verification of a PCB Design in its 3D environment. You can replace the board outline,
modify component placements, which are smoothly back annotated, import other PCB designs and
housings, then build it all together and run a complete collision check.

I's not just a viewer!
You can find more information at:

www.zuken.com/cadstar-board-modeler-lite

8 ZUKEN'
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Reviewing your Designs with Redlining Markers

Another part of the design review process uses a module called “Redlining”. This licensed module is
available for purchase with all CADSTAR variants.

Lan Bl x| -l e o e s

File Home Symbol Net/ Shape Design Hierarchy Library Report Tools View P 7]
- M
. Find +J+ Move ; — Global Signal = Cut Undo PopEBlock
( J) # o o ET} = g B Y O New Block - 4 9 P
HE . . . ~ ~
iom Align 4 Mirror = Signal Reference @ 3 Copy Can't Redo
Select Item o Part or Connection Redlining Paste
- Properties @ Name | 4 Rotate '-%' % Symbol * +| Connector Marker vaoao ' Delete
Select Item Move Flags Add Add Shape Clipboard Undo
= ~ Add Redhn.lng Marker :D
Add a Redlining marker
o o
e z
- o
= =
L] I n I n I n I n n n I n I n I o
o =
=3 @
a w
o
i I
5 p
- 8
g @©
z |+ o
2 g
N @
=
i B &
o
1 § T 1 § T 1 § T 1 § T o T I 1 I=I=I
v
< >
q RainMaker4_CS.scm - Sheet! |3 o4 B8 RainMaker7.pco Bl b
Il Redlining [E] BusReport |[&] DesignRuleErrors |f#] Electrical Rules Check | [l Owverlapping Connections | [&] Routing Completion | g] Unused Components 0%' N
Ready -8057 2522.5 Thou Grid: 5
i Do-lt-Yourself - Example3.scm (CACADSTAR180_Demos\Projects\Do-lt-Yourself\) - Sheetl - Schematic - Zuken CADSTAR Design Editor
Home Symbol Met / Shape Design Hierarchy Library Report Tools View
B3] View an @ Zoomin | (& Previous [DEFaULY x| @ 15 Open Designs| [T ltem Properties| | [~ ¢ Previous | [ Close
31 View Selection 2 Zoom Out | [&] Refresh ) 4] Current Design | ¥ Shape Properties g, e = closean
(. Frame View Emanage " N e ] ubraries 4 start page S 23 switen «
Zoom Views Display Highlight| Image Panes Tab Document
. = 1] Ao e Al B i
TO f|nd Out more ] OpenDesions v r@E 4 Examplel.scm - Sheett | BB Examplela.pch | BB Examplelb.pch | M8 Eampletcpes | BB Exampleld.pch Exampl sheett | M8 Examplezapch | BB Examplezb.ps
| =+ Open Designs ] o

information click on
the [Redlining
Marker] function
located on the

SalIEl

[HO m e] tab for‘ a ampled.scm (CACADST] Property st ‘ ‘
Exampleda.peb (CACADST 1 OE i Fxed [a]
H H 8 Example3b.pch (CACADS] ' AllSheet @]
video demonstration. i CAGA0S L |
. . 38 Example3d.pcb (CACADS| Text Changs value fo 228 =
Th|s requ"'es an B8 Exomple3e.pch (CACADST | — i Checked =]
. ) M8 Example3f.pcb (CACADST | LestMosfied  |deroen, donderdag 16 december 2016 1458
8 Example3g.pch (CACADS] User Name Jeroen
Internet connection. 5 ool et (€A CADS | e [

«

3

Current Design

Exarnplel.scm (CACADST|
¥ Eamplela.pch (CACADS]

B8 Examplelb.pch (CACADS]
B8 Eamplelc.pch (CACADS]
B8 Ecampleld.pch (CACADS|
Examnple2.scm (CACADST)
¥ Ecample2a.pch (CACADS]
B8 Example2b.pch (CA\CADS]
B8 Eample2c.pch (CACADS]
ample2d pcb (CACADS]

B8 Exompleda.pcb (CACADST
B8 Exampledepch (CACADST
B8 Exampleds peb (CACADS]

i v
v 1@

5 (DEFAULT)

UL

Item Properties - Redlining Marker

ORER 5 M o

0 (7)) Item Properties - Redlining Marker
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Chapter 3 - Library

The CADSTAR Library Editor ensures that design integrity is maintained between the symbol, the
footprint and the part information, and also supports multiple libraries.

The library provided with CADSTAR Express contains only a few parts essential for the PCB designs
described in this 'Do-It-Yourself Book' and some examples of the on-line CADSTAR Libraries. More
libraries are available through the Zuken Global support site. The ready-to-download-and-use parts
contain all the information you require including manufacturers' part numbers. They are updated and
expanded regularly with over 250,000 parts currently available. If the part required is not already
available in these libraries, you can quickly and easily design your own parts using the supplied wizards
and the Graphical Library Editor. Access to the on-line CADSTAR Libraries is available as part of the
maintenance contract.

Server 3

Server 2

Server 1

4 | CADSTAR Component Database

3D Symbols qn

Parts Library

JuUtL —
Simlib ||
"V Schematic PCB Decumentation
Symbols Components Symbols B
F | I

: Concept :: Schema :: Analyze :: Layout :: Verify :: Manufacture:
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Step 1 - PCB Component / BGA Wizard

For this next step, we will be using the Graphical Library Editor. This can be launched from the
Windows Programs menu or from within the Design Editor.

|| CADSTAR Express 17.0
=L CADSTAR-DIY
ﬂ Design Editor

b, Migrate Tool
PREditor XR

Met / Shape
A
Library Library

Searcher | Editor
Tools

Design

j R’/ Part

5 Component

Library

Edit

|5§E] What's Mew

The Library Editor functions as its own CADSTAR Application. It uses a multi-document interface to edit
PCB components, Schematic symbols, Documentaiton symbols and Parts.

Home Library Tools View A7)

— . ~
N B o0 T @
New | Open  Open OpenDatabase | Save New Help

Workspace  Library Workspace
New Open Save Documentation
L . - - ~ J
M CADSTAR Express Library Editor 18.0
E

[ CWUsers\PublicZuken\ CADSTAR Express 18.0\Seff. \Express 18.caw . 7 0

1T " 1
ormance single-board design
il 1> Z 7

i

Open Workspace...

RecentDesign Files

Save New Workspace...

sapadolg way Ll

m"”g | t

OpenFile... Database.. New File...

Electronic Component

SEARCH ENGINE

 flin(&le =

J—

Getting Started

CADSTAR Redlining, coming soon!

As part ofthe CADSTAR 18 0 release in June 2017, Zuken will
launch a new optional module: CADSTAR Redlining.

CADSTAR OnlLine
CADSTAR News & Events

¥ What's New
¥ CADSTAR Help

The new module allows engineers, PCB designers and
ﬁ CADSTAR BExpress DIY manufacturers to review and mark—ur designs, improving
communication between multidisciplinaryteams, enable you to add [
text remarks to the original design and let you to search, jump and
trace remarks.
Click here to watch the movie, or
Click here to read more about the optional module, or
Click here to download the datasheet, or
Click here to contacta sales repre sentative for price information vl
[ Bd
Load this page on application start. M ZUKEN v
< >
¢ . I strtPage H 3

[#] Design Rule Errars
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We will start with a 64 pad ball BGA using the BGA Creation Wizard.

Eﬂ 1. From the [Home] tab click the New
button. Then select the [PCB New ==

Component] tab and Choose the BGA | Parts Library | Schematic S}‘Tﬂb0|| PCE Component |Documerdation S)'rnbo||
Wizard in the box. ==
Click the [OK] button Defaults adal ‘.".-'izan:ll I . . .
e o o Description
EDE EEE A wizard to guide you
E A Lk = through creating a
DIP Wizard  LCC Wizard  Radial Wizard BGA componert.

SIL Wizard  Staggered Grid
Wizard %

Template Folder:
CUsershPublic’ Zuken\CADSTAR Express XX X \Templates

2. Enter a {Component} Reference Name of BGA-64. (do not enter BGA64 as demonstrated in
the above video link) Fill in an Alternate Name l.e. Reflow.

Change the Units from
Thousandths of an Inch to
Millimeters. Component Names

Enter names for the component.

BGA Creation Wizard

This is handy when you
have component
specifications that are
documented in mm or Thou.

Template File: Defaults i

Beference Name: BGA-B4

Fill in the component Height
if you want to run a Design
Rule Check on the height
clearances, which can be
checked against placement Height: 3
areas as defined in the
Design Editor, or you can run :

a collision check in
BoardModeler Lite.

Altemate Name: Reflow

Version:

mm

[=s}
(¥1]

Nei> | | Camcel | [ Hep

As this is a new component,

the version will be 1.

If Automatic Version Increment in [File] tab—= Options [System] is enabled, with every future
change of the component the version increments automatically. This can easily be checked if the
component in the design is the latest version as in the library.

Select [Next >]
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3. Enter the assignments to be used for pads and outlines.
Pads: Choose for the Pads the pre-defined pad Code bga64r.

Side: When you are creating an SMD component seen from Top View you must select the Min
side to place the SMD pads on component side.

Origin: The component Origin should be placed for SMD components at centre.

Silkscreen Outlines: The Code specifies the thickness of the line you are drawing. For Layer
you should select Top silk.

Placement Outlines: The Code specifies the thickness of the line you are drawing. For Layer
you should select Top Placement.

Check the option for Enclose Silkscreen and Assembly outlines as shown below.

Assembly Outlines: The Code specifies the thickness of the line you are drawing. For Layer
you should select Top Assembly.

Note: These layers are referenced in the PCB Layer settings as layer sub types and are used
by other features.

BGA Creation Wizard X

Assignments
Enter assignments to be used for pads and outlines.
Pads

Est Directions:

Fin One Code: [ Use defautt
bgakdr ~| EH Free Angle * & & & & & & & & & & B 2 * B
Code: * & & & & & & & & & 5 B 2 » B
e v E z & 5 85 & &5 5 & & & 5 8 B 8 8@
Use defaul S 5 S B 5 5 5 6 B 8 S & 8 8@
Side: (® Mn O Max (O Through Hole * & % & = B & % 8 5 ¥ 2 B B B
Silkscreen Outlines Origin *® & % & & & % @& # & & & & & @
Code: | Silkscreen Outline v | [FE (Ot pin one & & % ® & & % % & & & * = " @
Layer:| Top sik ~ @t certre 2 5 5 5 5 5 5 % 5 5 5 5 58 @
Placement Outlines L L A L R L L
Code: | Placement Outline v |HE & 8 & 5 & & & 8 2 8 % & 4 8 @
Layer: Top Placement - 5 8 5 5 8 5 5 B F S
[Enclose Sikscreen and Assembly Outines: LA A R S T A A L A
Assembly Outlines * & & & & & & & & & % 2 * B
Code: | Assembly Outline ~| |FE 8 B 8 5 B S B SR
Layer: Top Assembly ~ * & & & & & & & & & % 2 * B

< Back Cancel Help

Select [Next >]
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4. Enter the component dimensions:

Set B to: 15 mm
Set D to: 10 mm
Set Eto: 1 mm
Set Fto: 1 mm

Set Nx to: 8
Set Ny to: 8
Dimensions

Enter compeonent dimensions.

Dimensions
Nx
T

: TEEXERENEN
b Ny ;  E RN NN NN
tEEE PP D Nod d (LN N N N N N N
b TEEEREREN
| TREEXERNEN
TEEEEREREN
EFEENENE NN
TR RN NN

Reset to Full Grid

< Back Cancel Help

Select [Next >]

The next dialog is for designing the cavity dimensions where BGA pads are subtracted to match the
physical component package. For this task we will skip this option. Come back later and experiment with
this option. Select: [Next >]

BGA Creation Wizard

Cavity Dimensions
Enter dimensions for cavity window

Dimensions
Dimension Value
Nxc
- Hxc 0
Nyc 1]
Nxm 0
206022 SB6 | [om o
oEE a8 @ie | [ 0
e N o AN N RN NN
& NE4 iy Ne3 & Nz 0
. ey ) = 2 9 0000 OO
ye! e} Nys .
o ’ = d EE N NN NN
& 2092000 0®
: 2092000 0®
\ S0 0000 OO
L N B B N N N
202000 00

Reset to Full Grid

<Back Cancel Help
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5. Decide how the “Pin 1" marker location will appear on the component (this will ensure the
correct mounting of the device). Set the options as shown in the image.

BGA Creation Wizard

Pin One Marker &
Enter pin one marker details.

Fin One Marker Style

Il : T F:X -i - x
|oT : ;(_ I [T
O Hone O Dot e @re | Fip
H‘ + e x X
3(': :k |+Iv H}"
B Tab Plus =

r [
Fin One Marker Size / Postion I Fin One Position

Y- I I (®) Pin one in comer I ) Pin one on edge
I

1,
L - s s s —_— - -

< Back Cancel Help

Select: [Next >]

6. Last, we will assign the pin names to the BGA pads.

BGA Creation Wizard X

Pin Naming
Enter pin naming details

Naming order: | Alphabetic(H}-Numerical(V} ~
Start Values
Horart Vet

Pin Mame Exception: [1.O.Q.5.X.Z

Minimum Length: |1 bl

Use JEDEC Standard

< Back Cancel Help

At this stage, you can [Finish] the wizard and the BGA-64(Reflow) will be created and displayed in
the component editor where you can still modify the PCB component manually if needed.
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I RGN Y g = TR I

Home Shape Design Library Toals View 9

.
e A | om bﬁ.‘_] = ] Cut ~ i
i) +3* Move A Text Outline . I Measure L =g £} Undo Assignments

W) 3|7
o irror rigin -
— Al Wi Origi B | I_ Add

Item E [t: 3., Pad w D O ' Rename Design Design

Properties | i Rotate Pads Rule Check Rule Errors Delete
Select Item Move Flags Add Add Shape Mame Dimension DRC Clipboard Undo

sajadoid adeys G

e e

sajpadolg way _'_:.

Bt

@ @

666666
Q660 e e e e

e 066066666

GeoeHeoae
eeOoeDeee
@@@@jr@@@@
e6eO0BE6ee6

2]
©

Lampanent Name

4 E Start Page ﬂ Untitled:1 - BGA-64 ﬂ I
ﬂ Design Rule Errors
Ready 27.827 31.793 mm  Grid: 0.635
Home Shape Design Library
7. When done, save the component. ] Schematic Symbols A [
{ZE| PCE Components Bs
. . Lib [
Click on the [Library] tab-> PCB Bl Documentation Symbols  searcher | Re
Components — [Save Comp]. anage Tools | G
If the component already 25| Library Manager ==

exists in the library you

. . . Current Library
can decide to over-write it

if you wish. Path: C:5UsershPublichZukentCADS TAR Exprass #4s\Libran vl
Type: FCE Components
Filz Mame: pchlib | Browze. . | | Create...
| AddFoider |
[ Edt ||Epcbib | # bga256 (reflow] « | [ Use Mapping fle
o -2 Jumpers I BGA-B (BPADBAAR) | Add File... |
| Properiies | -2 Temporary Library |EGA-B4 [Freflow] | —_—
| Delete | 3 BGA-G4 [Reflow_C5) e
R & BGA-T4d
| Aichive | = BGA-T60 [UJE) | J
- & BGa-196 TR ey |
| Regott.. | & BGA-225 BG225) -
| Ore | & BGA-241 | Agsignments... |
—— & BGA-256 ETET—
| ersions... | #E BGA-256 [BG25E) | User Atributes... |
I I BGA-292 - | Lapers.. |
| gelact il | , -
N . | Units... |
Show subfolder contents 1 Selected From 787 Listed L =777
@ Show selected folder anly - -
| LCloze | | Help |
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Step 2 - Schematic Symbol / Block Wizard

We shall start with going through the Schematic Block Creation Wizard. The symbol to create is a
StrataFlash® Embedded Memory device. This device is built up with 2 schematic symbols therefore we
will use the multiple gate functionality.

"=l 1. Select  [File]tab>New=>[Schematic

. N
Symbol] and choose the Block Wizard — =
|n the bOX Parts Library | Schematic Symbol | PCB Component | Documentation Symbol|
. . D @
We will start by creating the power Defaults BEE
symbol and logic symbol concurrently. Description
A wizard to guide you
through F:reating a
Click [OK] S Pock
Template Folder:
C:UsershPublic'Zuken\CADSTAR Express XX X\Templates
0K || GCancel |[ Heb

2. You can choose a different template file. | 2hemstcBleckCrestion Weard
In addition you can also fill in the version e s forthe symbo.
number (1 as this is a new symbol). [Units]
can also be changed to suit your
specification. For this step set them to
Thou.

Template File: Defaults h

Version:

Select [Next >]

< Back Nest > ]l Cancel II Help J
3. The second step is to enter the symbol PO ——
dimenSionS as ShOWn. chematic Elock Creation Wizar
Dimensions
Enter symbol dimensions.
Dimensions
Dimension Value
A min (Thou) 400.0
Tip: The size of the text font used in "IA e 300.0
. [ | " C (Thou) 100.0
the data can be made more legible by | Ve | c D (Thou) 1000
holding down the <ctrl> button and v i E (Thou) 200.0
. B ¥ F (Thou} 200.0
scrolling the mouse wheel. 1 ¢
— [ A
- L
Select [Next >] D o
LI B |
I»Fd
<Back || Ned> | [ Canced | [ Heb
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Name. In addition you can also fill in the Alternate Name.

Select Gates — [Add] one gate.

For GATE A, enter the Reference Name as RC48F4400P0OVT00-P
and Alternate Name POWER-BLOCK

For GATE B you can fill in the Reference Name RC48F4400P0VTO0

Set the Number of Pins to 59 and
select [Update].

Select the Pin Sequence numbers 1
to 4 by using the CTRL/SHIFT key
and drag and drop the Pin
Sequence column to Bottom of
GATE A, as shown to the right.

Select Pin Sequence numbers 5 to
10 by using the CTRL/SHIFT key
and drag and drop the Pin
Sequence column to Top of GATE A
as shown to the right.

4. The next step is to add a gate, number of pins, define the pin locations and to fill in the Reference

Schematic Block Creation Wizard

Gate and Pins
Define gates, enter pin locations and text.

Pin
i = QU T G

Reference Name/

— U — —

ARternate Name/

e o K — —

GATE A

El RC43F4400POVTO
—_—

POWER-BLOCK

Spacers

”
-

Left

[= Bottom

e e @ & ¥

LAE L 2E 3L 3L

GIE L A0 0 AL 3L AL aE At

m

E INumberof Fins |

15 I
I |
I[ ete )

Pin Information

Read From File

[ Import Legacy
Symbual Text

Clear All Text

Gates

<Back | Mext>

Tip: Once you have selected a group of pins, you may also try clicking the <R.M.B.> to access

an assist dialog.

88

ZURKEN



http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar

™

Select the P|n Sequence Schematic Block Creation Wizard
H Gate and Pins
Phu mg_ﬁrRsL}élj?Fﬁ_Skby us'gg Define gates, enter pin locations and text.
e ey an
drag and drop the Pin s
Sequence column to left for . Pin Refere;c;e Hame! Artern_l.?ti‘riamer - B
quence e L=
GATE B as ShOWn. GATEB (& RC48F4400PONTOO =alt name:s
12 L .
13 P Mumber of Fing
14 &«
15 * 59
16 &
18 L
;3 : Fin Information
B ; a
22 &
23 ™ D Import Legacy
74 P Symbol Text
25 &
(Spacer)
26 &
Select Pin Sequence 2z * Gates
numbers 44 to 59 by using = *
the CTRL/SHIFT key and 30 ®
drag and drop the Pin ; : i
Sequence column to right of = - ~ [ up | [Down
GATE B. - '
<Back || Ned> | [ Cance | [ Hebp
The Spacers are equal tO the pln Pin Referen.oe Name! Alternate Hame/ ~ pacers
spacing assigned previously. Seduence Side . Text
) ) ; & Delete
Add a spacer in between pins 25 = .
and 26 by clicking on the pin 25 24 * Number of Pins
row and then clicking the [ADD] A R—
button. 26 (e |
Select [Next >]
Warning @I

As a courtesy check once you get to this

point, you may get a warning if the Symbol
Reference/Alternate name exists in the RCAGF4400POVT00-P (POWER-BLOCK)..
Symbol Library.

'.0.' The following Reference/Altemate names already exist in the Symbol Library;

Do you wish to continue?

This gives you the opportunity to take T ] [ % |
action. In this case select [Yes] :
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5. The next step is to enter the Pin

Name/Number and Pin Label
Origins.

The position of the Pin Name /
Numbers and Pin Labels are
related to the final pin position.

Note: By default the Wizard will
place Pin Name/Number and Pin
Label Origins intuitively, with Pin
Names outside the block, and
Pin Labels inside.

Ensure the settings are the
same as the example. ->

Select [Next >]

The last step is to enter
assignments to be used for
terminals and outlines.

Terminals: Set the Terminal
Codes to Terminal.

Outlines: The Outline Code
specifies the thickness of the
line drawing. You should select
Symbol Outline.

Origin: The symbol Origin
should be placed at terminal
one.

At this stage, you can [Finish]

Select [No] if you are asked to
set the multiple gate file, this is
only needed when reading an

Aldec FPGA pin list file (CSV).

90

Schematic Block Creation Wizard

Pin Name/Label Origins
Setup pin name and label origins

Fin Name Origins

Add Pin Name Crigins

Code: | Al 78/78/4 -
Side Orientation Alignment Offset (Thou) Direction
Left 0.0 | Centre Right 100.0 270.0
Bottom 50.0 | Centre Right 100.0 180.0
Right 0.0 | Centre Left 100.0 50.0
Top 50.0 | Centre Left 100.0 0.0
Fin Label Origing
Add Pin Label Origing
Code: | Arel 78/78/4 ~|
Side Orientation Alignment Offset (Thou) Direction
Left 0.0 | Centre Left 50.0 50.0
Bottom 90.0 | Centre Left 50.0 0.0
Right 0.0 | Centre Right 50.0 270.0
Top 80.0 | Centre Right 5 180.0
<Back || Net> | [ Cancel | [ Heb
Schematic Block Creation Wizard
Assignments
Enter assignments to be used for terminals and outlines.
Teminals
Terminal ’Ten'ninal ']
One Code:
Code:; ’Ten'ninal ']
- UUse default
Cutlines
Code: v]
Crigin
@) at terminal one ~) &t centre
Mutti-gate file

<Back ||

Finigh

][Cancel ][

Help

ZURKEN
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The symbols will be created and appear in separate windows. You may choose to modify them
to suit your requirements.

M 9 b 7|l gy g @ S @ ET 7| Untitled:2 - RC48F4400POVTO0-P (POWER-BLOCK) - Symbol - Zuken CADSTAR Library Editor Exp... ] X
Home Shape Design Library Tools View 2 \@\'
@ .@; Move g A Text Outling . Dll‘ “-""j % Cut ¥} Undo Select
A Mirror = - Origin 2 B 53 Copy W Can't Redo
Seled ProI:::rr’:ties jCRotate ﬁiﬁ 5, pin E D o ' Renplij':r;ber Paste X Delete
Select Item Maove Flags Add Add Shape MName Clipboard Undo
~ ~ :h'
w
g
E
PN4 PL34 |7 PHG4 =
=
PHZ | PL2 PL35 [ PMsS =
= FN3 2| PL3 PL38 |7 PNz6 =
Z2 2 z 2 Z = : |
PH4 ] pLa PL3Z =
C o oo o g g
TE TE T? TB f Tm FN5 2| PLE PL38 |3 PN2s o
PNB & PLE PL38 | 35M20 B
EE - o
T oo @ & o PNT 1| PL7 PLAD [
o
PH& & PLA PLA4 | 1P
4
= :I ﬂ 3 BNG 2 -PLY PLd2 | P42
o 0 4 o PNID 2 PLID PL43 |4 N43
;@ympl J<3 J<4 PN14 U L1 PL44 |t M4
> o o = PN12 42 pL12 PLA5 [ PM4S
Symbol Nam% r
FN13 43 pL13 PL4B |+ FN4G
PN14 44 -PL14 PLAT [ PN4T
PN15 #3-PL15 PL4B | 48
PL4% | P4
PN16 «{5-pL1B
2 i A7) P aw 2
< L4 >
4_ [ Untitled:2 - RC48F4400POVTO0-P (POWER-BLOCK) [ 3 4_ [ Untitled:3 - RCasFaoorovToo Bl 3
[# Design Rule Errors
Ready 3020.1 2366.4 Thou  Grid: 100.0
- -
i . o Home Shape Dresign Library Tg
7. Select the Add Origin tool bar icon to place additional R
origins such as the default Part name location. @D | =M™ [l S
Al Mirror ¥ Origin
. - - - Item +, = .
Simply browse the Origin type list Properties 4~ Rotate 5. Fin

and select the origin name you wish

to place.

Try adding the (Part Name), (Link)
and Description to both symbols.

91

Add Origin

Origin T ype: ‘[F’art Mame] v'

Position:

Details

Text Code:

Orientation:

Fir:

==

[Link]

Component Reference

Walue

Dlezcription

pch_zone
zim_model

Ayl 78,784 - l E
0o [ Use Alignment
Alignment Justification
1 (@) Left
Centre
[E] Eived @ Right
[ kK ] [ Caticel ] [ Help l
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8. You can still modify the schematic symbols manually if needed.
When done, save them by clicking on the [Library] > Schematic

Symbols [Save Symbol] button.

If the symbol already exists in
the library you can decide to
overwrite it if you wish.

Home Shape Design Library
ii]Schematic Symbols ﬂﬁ ﬁi
[F| PCB Components B -
] Library Dup:
QDocumentatmn Symbols | Saarcher Re|
Manage Tools Ch
B Library Manager @

Current Library

Path:

[ C:AU zers\Public'Zuken\CADSTAR Express s x4\Library',

4

]

Type: Schematics Symbols

File Mame:  symbaol. lib

Add Folder Fiename Folder

Browse...

[relete Folder < ¢~ Locate

=77 symballib
"] Temparary Library

Edit
Froperties
Delete
Archive

Fepart...
Origing...

Wergions...

Select All

¥ RC28F1B0C3P
W RC28F256K-C
W RC28F256K-P
B RC28FE40K-C
W RC28FE40K-P
b g RC48F4400P0VT 00

b g RC4aF 44 0-P [POWER-BLOCK]

B RC48F4400POVTO0-P_CS (POWER-BLOCK)

B RC48F4400POVTO0_CS @
W RD74LVC240B-C
W RD74LVC240B-P
W RD7ALVCEHEB-C

<

] b

() Show subfolder contents
@ Show selected folder only

2 Selected From 2839 Listed

Add File...

Save Symbal...

Tidy Library

Aszsighments. ..

User Attributes...

Units...

Lloze ]

Help

You can now go through the
Schematic Block Creation
Wizard again and create
another device if you wish.

Another option is to select the
Defaults option which will open
an empty symbol window where
you can create symbols from
scratch.
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Mew

Parts Library | Schematic Symbel | PCE Component I Documentation S)'rnbo||

1 B

L I Block Wizard

Description

Schematic Symbol
Defaults

Template Folder:

C:Users'\Public’Zuken\CADSTAR Bxpress XX X\Templates

[ ok || Ccancel

J

Help
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Step 3 - Parts Library Editor

Now that you have created the PCB component and the two schematic symbols you can generate the
Part definition that will link the schematic symbols and PCB component together.

1. From within the Library Editor click on [File] tab->Open. Click [Browse the Library directory]
and open “Parts.lib”. Tip: Change the file type to Parts Libraries as shown below.

M Oen s
W - - T |
L) | ; ¢« Public » Zuken » CADSTAR Express XX.X » Library » - |¢7 | Search Library yeol
Organize = MNew folder =~ O .@.
-
m Name o
& Libraries 7] Maxim_Parts.lib
| Documents 3] Microchip_Parts.lib
o) Music 7| Motorola_Parts.lib
(] Pictures ] Matsemi_Parts.lib
E Videos i . —-—
L | TOnEh_ Pt _1 Mo preview available.
3 || Parts.LIB ”I
& Homegroup TR T T
7] peb.lib
L™l - .
R Computer ] Philips_Parts.lib
i Local Disk (C:) 7] symbol.lib il
ca Backups (E) - 4 (1 3
)
File name: Partz.LIB - I Parts Libraries - I
l1_ Foen— H— I ——— ]—
M = Parts.LIB (C:\Users\Public\Zuken\CADSTAR Express XX.X\Library\) - Parts Library - Zuken CADSTAR Library Editor ==l
Home Library Tools View & @)
r Schematic Symbols 3) Symbaol Fi
m| = &
|§| PCE Components gj Component —
Parts X Library Duplicate Where-used
|Zl] Documentation Symbols | searcher Report  (library)
Manage Tools Edit Check
Definitions E
@
Part Hame | Number Description Version Definition SPICE Part Acceptance - =
39K-MRS25-1% 2322-155-13903 | Metal film resistor MRS25 35K 1% 1 39K-MRS25-1% Obsolete - Replace with 35K-r0805-2% @
39K-ri805-2% Chip resistor 0805 39K 2% 1 39K-ri805-1% g
470E-MR525-1% 2322-155-14701 | Metal film resistor MRS25 470E 1% 1 470-MR525-1% =
470E-r0805-2% Chip resistor 0805 470E 2% 1 470E-r0805-1% %
10E-r0805-2% Chip resistor 0805 10E 2% 1 10E-r0805-1% ~ | =
4 . [# Prarsus [E )
[#] Design Rule Errors

Tip: The size of the text font used in the tables can be made more legible by holding down the

<ctrl> button and scrolling the mouse wheel to zoom in and out.
Home Library T
- - AR
2. From the [Home] tab click the New icon for Add New Row > & =
h Sort Mew | Delete
= Selected
lumn Rows
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When creating Part Definitions,you must fill in the Part Name and Definition column fields (in
both fields type: “Example” as shown below.) In addition you can fill in the Description if you
want to run a more detailed Parts List of the used components in your design.

100NF-20/80% SMD0E05 100NF 0805 SMD CAP (XTR) 1 100NF-20/80% SMDO805

4K7-1%-CRG0305 4K7 CRGO80S THICK FILM 1% 1 4KT-1%-CRGOE0S

G80E-1%-CRG0805 G80R CRGOB0S THICK FILM 1% 1 G80E-1%-CRGO305

Example 1 Example Example - do not use
4 @ Partsis B

3. Change the spreadsheet from [Parts] tab to [Definitions] tab by clicking on the Definitions tab.

F |
Pars % Definitions
o O inifEn l Component Max Pin| Stern[ FPGA l VALUE| SPICE Value [ Wsttagel Tolerance| Price Mant »
SK1-1%-CRGOEDS r0805 (reflow_IPC) 2 R BK1 1%
| [TAs-220m8 3V "Cap SMD POL .140SP 2 e | | 22uF | |
|| 22K-1%-CRG0805 r0805 (reflow_IPC) 2 IC 22K | 1%
R T0-263 3 I LP2937 ' |
TAJ10.0UB.3V Cap SMD POL .1405P 2 I 10uF
100E-1%-CRG0E0S r0&05 (reflow_IPC) 2 R 100E 1%
100NF-20/30% SMDD205 0805 (reflow) 2 c 100nF
| | 4K7-1%-CRGO8DS 70805 (reflow_IPC) 2 IR KT | 1%
|| 680E-1%-CRGOB0S 0805 (reflow_IPC) 2 R ] 680E ' 1%
Example | | | | -
‘ m »

Select Compenent Name
Path BLL
4 [Reflovi]
Here, you can; [EPANBAAE)
BOFP-132 [PO)
BZ01_A-4
c0402 [reflow)
e Choose a component SUB03 [eflow]
c0B03 [wave +/-0.25)
reference shape l.e. <0805 freflow]
0805 +0.25
BGA-64 (Reflow) by e W
NPT Cap Awial 35 by 16
double C|ICkIng in the E:E SMD POL 1405P .120.060 Pad)
05090254 (0254)
cell to open the oap-07200250 (0508]
browser 83'120;2200500 [0508]
CBGA-255 (FX)
CBGA-272
e Enter a default ref-des e
prefix or Stem “U” o — =
e Enter attribute 71 Show Alemates ) Sl P Browss..
information ] [ted] [ b

The basic idea is that multiple Part names can reference the same Definition. However depending
on your future Library creation plans, you may choose to reference only one part name per
definition.

> ZURKEN
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4. Select the new part definition row for “Example” and click on the
[Home] tab and the Part Definition button to edit. (or use the
right mouse button menu).

Home Library Tools View
A = ? &
Zl L= w UEE
Sort New  Delete Fart

B Selected | Definition

M| = 7| PartsLIB (CAUsers\Public\Zuken' CADSTAR Express XX.X\Librany\] - Example - Parts Library - Zuken CADSTAR Library Editor || |=)] [£3]

5. From the [Component] tab, [ wome ey 7oos v A @
CIICk the [Select] button and oz G- ._;.Symbol %) Item Properties ﬁ s:jPrvaous _iCIusE
Choose the PCB — %, Component ;:a:;l?mpemes — —:_E:‘;lenth ' Close All
ToTexdt G ) Start Page - B Switch ~
Component BGA_ Grid Colours Panes Tab Document
64(Ref|0w) that you E"‘an Emzu\s_l’ins_(ide_-*ﬁnﬁpma Attributes _;
created by using the BGA T I H
Wizard in the previous — | =] g
exercise. L _ e _I
= -
Max Electrical Fin: 64 Hame Stem: | U |

Set the Name Stem to: U

BGA-64 [Re

This is the prefix for the
Reference Designator that
will be used when the part is
added to a Design.

Note: both the Component i

sajuadoldway £l

flow)

name and Name stem 4 [ PertsuB - E Parts.B - Example [E)
could have been entered on | s veson fure o
the Deflnltlons tab |n Step 3 Converting design C\Users\Public\Zuken\CADSTAR Express ¥X.X\Templates\defaults.cm

P 118.78 9849

M| A 7 PartsLIB (CAUsers\Public\Zuken\CADSTAR Express Xo(X\Librany\) - Example -

6. Select the [Symbols] |MEM ome by Toos  view
tab and C“Ck the NeW .d. ..J., B, symbol iy Item Properties ﬁ 4= Previous _jCIose
button ShOWﬂ on the i Resi I component | Shape Properties c = Next = Close anl
To ITZ:x't é::ée 4l start Page P 29 switen -
[Home] tab to add a Grid Colours Panes Tab Dotument

second row for gate B.

[ Comgonere [ Syl | P [ Gotg P Swapping | Atutes

I Gatel Symbol Nglq'le Terminals
A |RC48F4400P0V] 10 I
B | RC48F4400P0V | 45

— -

- RC4BF4+4PAFAVTAR-P [FOWER-BLOCK

(Re f low]

4 [ PartslB, [B Parts.LIB - Example (B3

ﬁ‘] Dresign Rule Errors
Converting design C\Users\Public.Zuken CADSTAR Express XX X\Templates\defaults,sym

106.64 99.00

Parts Library - Zuken CADSTAR Library Editer =/ [=] [£3]
& @

salpadold adeys L'.

saluadold wajy _'__:.
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7. Double-click in the Symbol Name field or use the right mouse button menu [Select Symbol..] and
select, for Gate A, the symbol RC48F4400P0OVTO00-P(POWER-BLOCK) you created by using the
Schematic Block Creation Wizard in the previous exercise. For Gate B select the Symbol
RC48F4400P0OVTOO.

Tip: Start typing the symbol name and the searcher will take you quickly to the symbol name

8. Select the [Pins] tab. q M startPage | [ Parts.iB [ Parts.LIB - Example [E3) 2
) ) Component | Symbals ;-Pm_ I| Gate + Pin Swapping | Attrbutes
From here1 the phySICaI p|nS Of V| Part Pin Names/ldarﬁer:\ﬁsible
the Component reference shape : : _
BGA-64(Reflow) W|” be ;I:entiﬁerl| Name | Label| Signal | Terminal | Type | Load nF'oa;mon -
mapped to the pins of the two 2 :
schematic gates. At g
AB 0
Additional pin information can - : il
also be entered.
Grke 4 - FEABFAGRPIITES-P POVER-ELCEE) BGA-64 {Reflow]
Note that the Alpha-numeric pin I:::,j

names of the component are Fhla B FssatraTeD
listed in the Pin column. : ]
These names will be displayed
on the schematic symbol pin

locations once mapped.

Also note that when using Components reference shapes that contain Alpha-numeric pin
names it is not necessary to enter pin names in the table.

Home Library Too
9. Click on the Import Pin Labels button located on the [Home] tab. a1 _ -
e Mameldentify Pins
Rather than importing a pin label for each pin name a pinname list | J&import Pin Labels

file has been provided in C:\....\Zuken\CADSTAR Express 1352 Set Pin Name Position
XX.X\Self Teach.

MName

Select the file name: pinlist.pin click [Open]
Tip: A pin list can be often down-loaded from the component CHIP {Header}
, . . Al:  pinname (colon)

manufacturer’s website or you can extract it from the component A6
manufacturer datasheet in spreadsheet software (for example MS A8:
Excel). VPP:

A13:

VCC:

A18:

A22:

A2: . <cr><If>

% ZUKEN
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If the Pin list has less pins than what is in the [Pins] tab you will get the warning shown below.

| Component | Symbols | Pins | Gate + Fin Swapping | Attributes |

Part Fin Mames/ldentfiers Visible

Warniing (==l Identifier

Al
l b The import file contains less than 64 matching pins. Mot all pins will be labelled. A2

A3

A4

AS

Signal| Terminal | Type | Load | Position

AG
AT
AB
B1

ololololol ool oo

When you used the Schematic Block Wizard for the creation of the first symbol
(RC48F4400P0OVTO00-P) a total of 10 terminals were placed on the bottom and top side of the
symbol and if you remember, they are always numbered from left to right. Usually the VSS is
placed at the bottom of the power symbol and the VCC at the top.

64-Ball Easy BGA Ballout (64/128/256/512-Mbit)

Terminal Numbers ) ® . 2 5 4 5 o6 7 8
57 T o >
n o~ oo = - et
zlzlz|Z[z|= < [T | & o
ol o ol
N WM~ OO Luugooo
™ oo U U ogn
coaoaog Ma =>>000
p =3 >
y )]
:ﬁﬂ: mmmm ik pGis REU
O oL O = T o, ,.‘-A} {.,.}
WAT Ot
z |2 |3 (% o | e
fiEZIE e ol 2 S N S ven 5% o Sie v
< < 20 L X 181 101,
RFU VSS VCC VSS DO13 VSS DQ7 Azd
.EasyBGA
Numbered form Left to Right ()

10. The next step is to map the symbol terminals with the accompanying Pin Numbers/Names (and
Labels).

In other words you will start with the pin B2 (Label VSS) | Assign Terminsls =X
assigning it to Terminal A.1 = {Gate A. symbol terminal 1} Enter the first gate and terminal

zpecifier uzing the format A3

[ QK. l [ Cancel ] [ Help ]

o ZURKEN
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Select the Terminal cell belonging to Pin Name B2 (Label VSS), and select Assign Terminals

or use the right mouse button menu and select Assign Terminals or Just double click in the

cell.

E (= | Parts.LIB (C:\Users\Public\Zuken\CADSTAR Express )X X\Librany\) - Example - Parts Library - Zuken CADSTAR Library Editor Ex... |=| |E]| [E3

l_—\
Home Library Toals View P
_]t 5L name:Identify Pins #% Set Pin Type Make Identical i:*: = ¥ cut
Iilmport Pin Labels :';*:Assign Terminals .‘Lj-_]Copy From 53 Copy
search ) . Import Paste
g o€t Pin Name Pasition Multigate
Column Mame Type/Terminal Gates Import Clipboard
Component | Symbaols | Fins Gate + Pin Swapping | Attributes
V| Part Pin Mames/|dentifiers Visible
Identifier| Name | Label| Signal| Terminal| Type | Load | Position e
Al A22 0
B1 AZ 0
B2 V35 A | 0
B3 ?\\ A p 0
B4 NLCF / 0 il

4

Gate A - RC48F44BAFRYTEAR-F (FOWER-BLOCK|

¥

Gate B - RC4EF44B@FPEYTOE

[Re f low)

B startPage | [ PartsUB - (B Parts.LIB - Example [E3]

ﬁ Design Rule Errors
Converting design Ch\Users\Public\Zuken\CADSTAR. Express XX.X\Templates\defaults. sym

99,52 9340

t_*l

saladold adeys L,..

salpadold way Ll

Now you can finish the mapping for the power symbol by selecting, in the correct order, the next

power pins.

Look for pin H2 (Label VSS) and click in the terminal field. You will notice that automatically A.2
will be assigned.

As you assign the terminals the Pin name labels will appear on the Gate A symbol in the preview

pane.

Tip:

[Escape] key and restart in the correct box with the new start sequence!

98

If you make a mistake during the allocation of the terminals, don’t worry - just press the
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- pin H4 (VSS) to A.3

- pinH6 (VSS) to A4 Cotumn

M | A 7| Parts.LIB (C:\Users\Public\Zuken\CADSTAR Express XX.X\Library\) - Example - Parts Library - Zuken CADSTAR Library Editor Ex... IE\ @

Assign the following: ER o

Library Tools View & @
}3 I namedentity pins + Set Pin Type E Make Identical a: ‘i] ¥ cut
Iglmpurt Pin Labels EAsswgn Terminals Q]Copy From 53 Copy
Search 1 Import Paste
s o€t Pin Name Position Multigate
Name Type/Terminal Gates Import Clipboard
Or

- pin A4 (VPP) to A5

- pin A6 (VCC) to A.6

- pin H3 (VCC) to A7

- pin D5 (VCCQ) to A.8
- pin D6 (VCCQ) to A.9
- pin G4 (VCCQ) to A.10

4

Component | Symbols | Fins | Gate + Pin Swapping | Attibutes

V| Part Pin Names/|dentffiers Visible

Identifier

Name | Label| Signal Terminall Type

Load

Position

NC |

o
H2 VSS AZ | 0
H3 vCe AT 0
H4 vss A3 0
HS Da13 0
HE VS5 Al o
HT par 0

Gate

B - RC4GF442aPEYTER

E Start Page
ﬁ] Design Rule Errors
Converting design C\Users\Public\Zuken\.CADSTAR Express XX.X\Templates\defaults.sym 180,75 325.71

sajuadold adeys

1
saluadold way L'__:.

BGA-64 [Reflow)

[ Parts. B [B] Parts.LIB - Example [E3]

Continue assigning the terminals for Gate B (RC48F4400P0OVTO00). Just click in the terminal field
of pin Al (Label Al) and you will notice that automatically B.1 ={Gate B .Symbol Terminal 1} will

be assigned.

When you used the Schematic Block Wizard for the creation of the second symbol
(RC48F4400P0VTO00), a total of 49 terminals were placed at the left and right side of the symbol
and if you remember, they are always numbered from top to bottom.

Assign following pins for Gate B:

-pin A1 (Al) to B.1
- pin B1 (A2) to B.2
- pin C1 (A3) to B.3
- pin D1 ( A4) to B.4
- pin D2 ( A5) to B.5
- pin A2 ( AB) to B.6
- pin C2 (A7) to B.7
- pin A3 (A8) to B.8
- pin B3 (A9) to B.9
- pin C3 ( A10) to B.10
- pin D3 ( All) to B.11
- pin C4 (A12) to B.12
- pin A5 ( A13) to B.13
- pin B5 (Al14) to B.14
- pin C5 ( A15) to B.15
- pin D7 ( A16) to B.16
- pin D8 ( Al17) to B.17
- pin A7 ( A18) to B.18
- pin B7 (A19) to B.19
- pin C7 ( A20) to B.20
- pin C8 ( A21) to B.21
- pin A8 ( A22) to B.22
- pin G1 ( A23) to B.23
- pin H8 ( A24) to B.24
- pin B6 ( A25) to B.25

99

- pin B4 (‘'CE)
- pin C6 (‘WP
- pin D4 (‘RST)
- pin E6 ( CLK)
- pin F6 (‘ADV’)
- pin F7 ( WAIT)
-pin F8 (‘OE))
- pin G8 (‘WE’)
- pin F2 ( DQO)
- pin E2 ( DQ1)
- pin G3 ( DQ2)
- pin E4 ( DQ3)
- pin E5 ( DQ4)
- pin G5 ( DQ5)
- pin G6 ( DQ6)
- pin H7 ( DQ7)
- pin E1 ( DQ8)
- pin E3 ( DQY)
- pin F3 ( DQ10)
- pin F4 (DQ11)
- pin F5 ( DQ12)
- pin H5 ( DQ13)
- pin G7 ( DQ14)
- pin E7 ( DQ15)

to B.26
to B.27
to B.28
to B.29
to B.30
to B.31
to B.32
to B.33
to B.34
to B.35
to B.36
to B.37
to B.38
to B.39
to B.40
to B.41
to B.42
to B.43
to B.44
to B.45
to B.46
to B.47
to B.48
to B.49
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11. The next column, Type, is optional for this example part. However if you should take interest in
one of CADSTAR'’s Signal Integrity Verification (SIV) or Power Integrity Advanced applications,
proper pin type declarations will be needed.

Simply double click in the cell to reveal the list of available pin types and make your selection.

| Component | Symbols | Pins | Gate + Pin Swapping | Attributes

Part Pin Mames/ldentifiers Visible

Identifier | Name | Label| Signal| Terminal| Type | Load Pin Types

Ad VPP AL P Select Pin Type

AS A3 B.13 [F': Pioweer pir ']
A5 VCC AG P

a7 A18 B.18 [ ok | [ cancel | [ Beb |
A AZ2 B.22

B1 A2 B.2 ]

B2 V55 A G ]

12. Select the [Home] tab and then select Home = Libray  Tools  View

the Gate + Pln Swapplng tab g | B |» Create Element {E»Ungroup | ﬁ;
B e ’ Create Group §}< Remaove All Swapping

Click to expand the External Swapping il | | pme | P Externalswap T5 Set Default Swapping | putfoate

Group element containing 49 pins then Gates Swap Import

expand the element contained within. s======

| Component I Symbols | Pins || Gate + Pin Swapping |.|‘i'LnbuteB|
. . - External Swapping GroTp RCATFAIUOPIVTOO-B
Select the pins with the labels {A1} — £5-[ Element: 49 pins RCA4BF4400POVTO0-B

{A25} as shown and click on the WY Pin Al {AL}) Terminal B.1
Equivalent Pins button or select 0 ) Termine 82
<R.M.B.> - Equivalent Pins. Py oot Termine 83

} Terminal B4

1 Terminal B.S
1 Terminal B6

Repeat the action for the pins with the
labels DQO — DQ15. If you do so it will
help you to optimize the routing pattern
in the Design Editor and/or P.R.Editor
XR.

0} Terminal B.10
1} Terminal B.11
2} Terminal B.12

=¥ Pin C5{A15} Terminal B15
=0 Pin D7 {A16} Terminal B.16
2} Pin D8 {A17} Terminal B17
SN W Pin A7 {A18} Terminal B.18
=¥ Pin B7 {419} Terminal B19
W Pin C7 {420} Terminal B.20
} Terminal B.21
SN Pin AS {422} Terminal B.22
=400 Pin G1 {A23} Terminal B.23
24N Pin HE {A24} Terminal B.24
M0 Pin BO {A25) Terminal B.25

100 ZURKEN
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13. Select the [Attributes] tab and click on the text field for Manufacturers Part Number. Add the

value RC48F4400P0VTOO.

You can fill in more attributes if you like. Attribute values can be set as Read Only so users can
not change their values in a design.

Tip: You can create

user-defined attributes

by clicking on the
Attribute Names
button.

If you finished adding a part click on the [File] tab-> Save and Close the file.

Home Library Tools Wiew

o ———r

a5 |l == ¥ Cut
by | E o N
1 53 Copy
Search || Attribute Paste
Mames I

— -
Column | Attributes Clipboard

| Component | Symbals I Fing I Gate + Fin Swapping rpﬂ-ﬁBLES.]:

Attribute T = Tesl

Value

Read Only Type

WWattage

Tolerance

Price

Manufacturer

Manufacturers Part Number RC4EF4400PINVTOO

link Manufacturer

link URL to manufacturers PDF datasheet

[EE=EEE ]

Ne L CADETAD Do bs ot

If you didn’t manage to add the part without errors or warnings you can browse the Library folder
.\..\Zuken\CADSTAR Express 2018.0\Library and delete the Parts.lib. Then rename the file
Parts_CS.lib to Parts.lib and then select Libraries=> Parts and select [Parts Index]. You should not

have any errors or warnings.

Congratulations on creating your first complex part in CADSTAR!

Why not try and add it to a sample schematic?

101
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CADSTAR FPGA

If you want to skip most steps as described above you can also use a CSV (Aldec FPGA Data) file.

To learn more you can check out CADSTAR FPGA, supporting Actel, Altera, Lattice, Quicklogic and
Xilinx flows from one universal project manager that controls all the design files for simulation, synthesis,
place and route and pin assignment to the PCB.

Pin synchronization is often far from optimal for PCB routing; this new integrated solution supports the
I/0 synchronization between the FPGA device and the PCB board. CADSTAR FPGA supports forward-
and back-annotate pin assignment changes in order to optimize PCB routing.

A new collaborative product, combining Aldec's Active-HDL Lite and Zuken’s CADSTAR in one
universal project manager.

You can find more information at;

Design Solutions for Design Engineers

If you require any support during evaluation, please contact your local CADSTAR distributor.

Where to Buy CADSTAR

102 ZURKEN
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Chapter 4 — Design C (Standalone Place & Route Editor)

Design C has been created for the more advanced users, allowing you to make use of the Standalone
Place & Route Editor XR2000. Power Users of CADSTAR tend to prefer the more powerful features such
as those available within the Standalone P.R.Editor XR2000, which provides placement and routing
functionality and much more. By the way, all exercises completed for Design A and Design B in the
Embedded Place & Route solution, can as well be designed in the Standalone Place & Route Editor
XR2000!

Also in this design we will learn how to create an Intelligent Bus and the use of Signal Reference Links.

Step 1 - Schematic for Design C

1. The schematic of Design C is provided and is nearly completed. Just open DesignC_CS.scm
and save it as DesignC1.scm and begin.

CADSTAR is capable of creating intelligent busses; you can restrict the signals connecting to a
bus according to the signal names. The Item Properties dialog for a bus contains a [Signal] tab
where connections to a bus can be defined. If you set a bus to be none-restrictive you can connect
any net.

Signal reference links are used to view and ‘jump’ to the other signal references of the same net
throughout the (hierarchical) design.

=B
2. Select the [Home] tab and then select Bus. L) US_
We will start by creating an intelligent address (ADO-7) bus on sheet 1 | .. £ Attribute
between U1, U2 and U3. i A Text
Select the start point for this bus and draw the bus. To insert a corner click
left mouse button, to finish the bus double click the left mouse button.
U3-B

EN
Cl

%

AD@

0 b v

ADI

AD2

AD3

AD4

ADS

ADBE

AD7

FrbPHH

cra
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3. To add the bus name
Item Properties panel.

and signal names to the bus, select the bus %
Fill in the bus name ADI[0-7]

and click the non-modal

inMaker7_CS.pch DesignC3_CS.scm - Sheetl - Item Properties - Bus s
u Sl s = oW S e
3| | Uz D GE 5 S = 2 @
| ? | Property Value | ‘
. I cl Fixed ]
m Restrictive
! ﬁ:M Line Width Code  Line 50 =
I I Segment(s) Length 5524
! I Transfer Bus To PC  Don't transfer
I =l Bus Name AD[0-T]
i MName [AD[0-7] a5
Fixed ]
! Position X 573.40
Position Y 178.44
: Orientation 0.0 2
I Alignment (Mo Alignment)
Justification Left
Text Code Text Size 60/50/8 B

Alternatively this can be performed using the standard Items Properties dialog for Bus Items.
With the Bus item selected click the <R.M.B.> and click ltem Properties.

Select the [Signals] tab,
click on Add and fill in

AD[0-7] then press OK. .
uz Signals
Busz Signal Properties
Up N
Position:
Do
Oriertatior: =
Uze Alignment
Alignment
Delate
Click [OK] to exit the dialog. Add Bus Signal (el
Bus Signal:
ap[o-7]
Format is either 'Signal Name' or
'Signal Name Stem[Start Range-End Range]' e.g. DATA[0-15]
OK. ] [ Cancel ] [ Help ]
You can now connect
connections to the bus.

Itemn Properties - Bus

General | Signals
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4. Select * U3-B select the Move i icon and move U3-B towards the bus until the terminals are
on top of the bus, drop U3-B by pressing the left mouse button, the next window pops up

Set this window as follows: Auto Connect to Bus =
Start Signal Name: ADO
Start Pin Position: 2 Connecting between Symbol 1J3-B' and Bus ‘AD[0-7T.
End Pin Position: 9 Stat Signal Name: [ADD 7]
Press OK.
) o o Start Pir Position: [2 ']
Move U3-B back to its original position.
End Fin Pozition: [8 v]
Repeat this with U2-B.
[ Ok l [ Cancel ] [ Help ]
For U1-B:
Start Signal Name: ADO
Start Pin Position: 50
End Pin Position: 57
Press OK
-— ADB-7 ——
( ()
~ = uz2-B ~ U3-B
w N EN wh N EN
| LI o 1 P
o |22 AD7 A\ ADB 2 d=—2=L = A8 \ADD 2 d—7>Ln
DI = ADB A4 ADI 3 18 A9 ADI 3 18
2 |2 ADS A AD2 4 7 Al AD2 4 17
b3 =24 AD4 A AD3 5 16 Al AD3 5 15
ha |23 AD3 A AD4 B 15 A2 Y AD4 ) 15
5 |22 AD2 A aD5 7 14 a3 Yo ADS 7 14
Nog =l AD!_\ ADG 8 13 A4 )< ADB ] 13
7 |22 ADB A AD7 9 2 A5 AD7 3 12
rg :3_ 74HC573MD 74HC573MD

Tip: Add Mitres to the bus corners using the
Mitre Corner function located on the
[Net/Shape] tab.

t

Met / Shape Design Hierarchy Library Report To

3 %X | B

Merge Disconnect Edit

Pin Segment & ArcTo Line

Connection

;% Insert Segment [ =/ Fillet Corner
- Modify Arc [=4 Mitre Corner

Edit Segment

Tip: Bus Terminals can be rotated to suit the direction of the signal flow. Using the
<Ctrl><L.M.B.> method select all of the bus terminals you wish to rotate. Once selected, use the

rotate command of <F3>.

5. To connect single connections to the bus use the Add Connection function. Start at the pin to
be connected, then drag the wire to the bus and single click to finish. The function will ask which

signal name to add.
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Adding Signal Reference links.

Signal reference links are used to view and/or ‘jump’ to symbol Net / Shape Design
another associated signal reference elsewhere in the design. N [ petans B s
The visibility and format of the link is configured via — _
the [Design] tab->Defaults i | Crectrical Rules =] Units
dialog under the [Link] tab. i Zones
Defaults
| General | Shape I Text I Connection I Pin I Bus | Link: |
sn:eri 5 = = Zories\‘ 5 - sheef?

Use Signal Reference Links

Properties
= Alignment Justification
Cods: [Ariel 38/39/4 -] :
- @) Left

Ofet: [0.20 © Centre
Angls: 0.0 [ Use Mignmert =~ @ © Right
Formatting

Style Suppress Same Sheet Preview

() Zone |Use Sheet Number For a Signal Reference

h on sheet Top Shest”

(2 Sheet Sheet - Fone Separator: a1

@ Sheet, Zone |y ceparaton Eﬁg 21

() Zone, Sheet 205

100

I agiriumn Line Length:

Zones configuration is

0K | [ Cancel ||

Help

106

controlled via the .  pesign Zones (3]
[Design] tab->Zones _ chest Zones
dialog, I.@ Grids ’—| Harizontal - -~
@ Units FLASH Start Coordinat!: 443 :
To speqlfy the location ™ Zones End cgordinam: 235.00 |
of the link, zones can Grid Mumber of Zonds: |G 1
be used to split the . I
sheets into horizontal et :
and vertical segments. Size of Zone: . B
Vertical
6. Since the format sheet is a Euro sertCoordnatf: 235
size, change the units to mm. End Coordinatel 35 |
. . Mumber of Zonels: 4 |
7. Set the dialog to match the image !
shown = and then Click [Apply to sxscmass ) A !
all Sheets] Size of zone: | s0.00 :
—— R —
. . Get Coordinates from Sheet
In the Display section, check the S —— ] | ]
options for Left, Right, Top and Display Reference
Bottom. Text Code: [rmes New Roman 75/75/4 v]_lr (@ Horizontal-Vertical |
i- Left [ Right @ Ton [¥] Bottom T () Vertical-Horizontal
. e e e e e e e e ===
8. Set the Reference setting to
Horizontal-Vertical and select [OK].
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9. Now check the signal reference VCC in the lower left corner of the sheet. It should look like this:

&) Pprevious View Shift=Fa
3 viewan Alt-F8
VCC [
68 i) Hem Properties...
Z1G # cut Ctrl+X
53 Copy Ctrl=C
7 Delete Delete
=% Fix
=3 Unfix
You are now able to jump to the several VCC reference links in | i viewselection
this design by double clicking on for example 1:6B or by | Deselectan
selecting the Signal Reference % then pressing the right | M F2
mouse button and selecting one of the reference links. = €% Disconnect Pin
. . B, Edit Symbol
10. Save the schematic as DesignC3.SCM A S

If you don’t see the Signal Reference Links, just open 48

DesignC3_CS.scm and save it as DesignC3.scm and then
have a look.

5B
6B
Z1C

e

N 5o aT MEt MgATIgAT
i% Highlight Item Net

£ attribute...

] Assignments..,

13 Colours..,

11. Transfer the schematic to PCB through [Design]=>Transfer to
PCB as DesignC1.PCB, choose ‘Eurocard-160x100.pcb’ as PCB technology.

If you didn't manage to transfer the schematics design, just open DesignC1_CS.pcb and save it
as DesignC1.PCB before going to step 2.
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Step 2 — Placement for Design C

12. Create a rough manual placement here in the Design Editor.

13.

Place all ICs as shown. =

SMD components can be
placed on both sides of the
board.

Place all the capacitors on the
solder side of the board. I.e.
Select capacitor C1 and drag it
to the preferred place, click the
<R.M.B.> and select ‘Mirror
from the assist menu and then
single click to release.

Note: The colour of
components when swapped to
the other side of the board do
change!

7z

' IIIIIIITIIIIIIIJLIH

-

TITIUTITITIT

IIIIIIIIII!HIﬁ%;V |

TP2

-
®

A

c
w

-~ -

X1 can be placed at X 154.711 mm, Y 89.383 mm and rotated to 90 degrees.

If you didn't manage to place the components,
just open DesignC2_CS.pcb and save it as

DesignC2.pcb and then continue.

Component Met / Shape Design Lik
= & Multtiple [:]:] [ Gate
== ¥ Positional Jot Pin
Arrange Automatic
mpanents -

Tip: to see highlighted nets that connect to a
component, press “T’<enter> on the keyboard to
toggle the associated nets to a highlight colour.

Some connections between Ul and U2 are crossing!
To solve this, select the Automatic Gate and Pin
Swap button on the [Component] tab and click

[Start] .

Save the design as DesignC3.pch

Note: You can also swap pins on the fly in the
Standalone Place & Route Editor XR2000.

Gate and Pin Swap

[l

Type of Swap When to Stop

@ Run to Completion

) Summary After Each Pass

I Choosge Metz to Minimize... I
What ta Swap

[] Swap Fied ltems

Selected Components

© Within Area | [Board Duline) -

I Start I [Eancel] I Help I

Using CADSTAR you can decide to use schematics as master or the PCB design as master.
CADSTAR supports full back annotation. No matter what your choice will be, do not forget to run
a Back Annotation when you have changed something in your PCB design, like pin and gate
swap, renamed components, added, modified or deleted components, connections or attributes.
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If you didn't manage to do Gate and Pin Swap, just open DesignC3_CS.PCB and save it as

DesignC3.pcb before going on.

Open the schematic design DesignC3.scm
and select Back Annotation located on the
[Design] tab.

In the Back Annotation window select the
PCB design DesignC3.pch as the source.

If you have added new components in the PCB
design that do not exist in the Schematics you can
select the sheet on which you want to add these

components (in this case just select Sheetl).

The exclusion file can contain components that do
not exist in the schematics, like mechanical holes or
other components that you don’t want to appear in

the schematics. Just select Example3.cig.

Now select [OK] to run the back annotation.

109

Design Hierarchy Library Report Tools View
Hoe | S B R B
=] Units b
All Snap | Attribute Attribute | Transfer Back
3&”20”95 Cin/Off = Editor  Mames to PCB | Annotation
Grid Snap Attributes Transfer| Back Annotate
Back Annotation @

Back Annatation Source
C:hJzershPublic.. \DesignC3.pch

Perfarm initial B ack Annotation with detected RIMF file

Select...

Add new symbols on sheet

Sheetl

Camparizon Optiohs

Euclugions. . | | advanced Configuration. . |

| Perfarm Library Reload on completion
| Retain Local Reference Mame
| Betain connection paths [add danglers] on symbal deletion
V| Always add Single Mode Connechions
| Update Pin Labels
| Tranzfer Reuse Blocks
| Perform Update of Reuse Elocks on completion
Remaove ltems after successiul completion
Urused symbol gates/connectar ping
Unuzed global signals/signal references

Unconnected buzes
Dizconnected block s

Source PCE Options
Update Vanant Hierarchy
| Replace Met Route Codes
Met Route Code Azsignments

/| Replace Mindt ax B estrictions
| Feplace Optimal/Mecked Widths

| k. | |Eancel| | Help |

ZURKEN



http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar

™

Step 3 - PCB Routing for Design C

ket / Shape
1. Continue with DesignC3.pcb and go to the Standalone Place & Route o | Baa
Editor XR by selecting Tools>PREditor XR. [ [l
o PREditor PRE
2l XR
PREditor
RIF Export Options ==

When transferring to the P.R.Editor a RIF Export
Option window will be showed automatically.

Be sure to enable Always Transfer Colours.

Click [OK]

Before starting any routing or further placement
check the Configure=>Routing Setup dialogs or
(CTRL-T).

[V]i&lways Transfer Colours

[7] Use Rouwing Grid as System Grid
‘wite Part Information

wirite Jurnpers fram Librar

Show thiz dialog on transfer to PREditor %R [HS) as
well az through File Export/0 ptions

[ 0k ] [Eancell [ Help ]

Setting the routing options is very important before any routing. Ensure the settings are equal to
the example shown below. {If you don’t like copper to be poured automatically disable Auto Pour}

{values are shown in mm.}

110

T Routing Setup )
Manual / Autorouting | Pusher | Trurking Compaosition | Fan-out | Testpoints | Radial | Spiral Vias Autorouting Costs | Grids |
Options Angle Track
Errors Allowed @ Straight
45 |z| [T Angled Autorouting Style:

Mlow Pin Swaps @) Curved

On-ine DRC Activ-45 @ Necked

Passes 10 E| [] Enable Activ-45 Width: © Optimal

Effort 10 =l gy stie: i © Typed: |0.50800

Via Fixed Items

Vias Allowed Respect Fixed Fan-outs

Vias Under Single Layer Pads: Off |Z| Use Maximum Length

Enable Snap Vias Legal Distance: (0,000 Max Fan-out Length: | 5.000

Spiral Vias  Disallow [ Respect Fixed Escape Routing

PostTool Tasks Equispace Save Best Pass

[ Auto Pour Priority according to:

Completion
[[] Auto Teardrop [] change Length with Equispace [] Murnber of Fails
[] Number of Physical Errors
Freehand [] Number of Vias
) ’ ) [] Number of Segments
[E] Enable Freehand [] Equispace Whilst Refine Routing [ Total Length
[ Freehand Tidy [7] Use the best pass as the final autorouting result
Standard
Description: Always Generate Auto

Open... ] [ Save As... [ oK J [ Cancel ] [ Help ]
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If you don't like routes to be pushed by other objects you can disable the Pusher.

™5 Routing Setup @

Manual / Autorouting Pusher Trunking Composition Fan-out | Testpoints Radial Spiral Vias Autorouting Costs Grids

| Enable Pusher
V| Springback V| Allow Segment Breaks

Preview

Description: V| Always Generate Auto
Open... | | Save As... QK ] | Cancel | | Help
P.R.Editor can also be used for placing components 51 Interactive Move =

without going back to the Design Editor. Before starting
any placement check the Interactive Move and Push
Aside options.

[+ Allow Component Mave
[ Minimum Faorce Indicator
¥ Move Tracks with Component
[ Route Selection after Move

2. Set the options for moving components by selecting -

Configure=>Interactive Move in the menu bar.
v Errors Allowed

3 = | Effort to Find Legal Position
v ©On Line DRC
W Use Working Grid

Setting the placement functions behavior is very important | ¥ D n
before any placement is started. ok | standard | Cancel | Hep |

] Push Aside [= | @ (23]
3. Select Configure>Placement>Push Aside in the menu e
bar. Ensure the settings are equal to the example. )

[+ Springback

Push effort ’G
Ok | Cancel | Help |
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4. Select a component and click the Move tool bar icon @ Notice that other components are
being pushed aside and when there is enough space the selected component jumps over

other components. Components can also be swapped 2 to the other side of the board or
rotated | ¥ This can also be performed using the <R.M.B.> assist menu.

As this board is a 6 layer board with 2 power planes GND & VCC, we will first start with stub routing
for the GND & VCC.

5. Select Whole Net Mode :L, Auto route = and select the GND signal at a pin location
(repeat the same for VCC).

ot & o
n L

*'.

|><|<k GND — .

The Place & Route Editor XR will help you in routing your designs by using several auto-routing
technologies on a single net, a group of nets or within a certain area.

Note: By using the customizable Function Keys F5 or F6 you can scroll through the layers from
top to bottom or the other way around (Try it).

6. The next step is to create a Fan-out for a BGA. A Fan-out is a route template that can be
applied to an SMD component. It enables routes to “breakout' from a surface mounted pad
using a pattern that is efficient on space and gets the route to an inner layer as soon as
possible. Fan-outs are often used and can be easily re-used for BGAs, QFPs or other devices.

Fan-out Tools (=]

goid W1 LSS A= N 2 |0E

Note: If the Fan-out toolbar is not visible go to View->Toolbars-> select Fan out.
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7. Before creating the actual Fan-out, select Configure>Routing Setup [Fan out] tab - ensure

the settings are equal to the example shown below.

[4] Routing Setup -8 |[mEsa]
| Manual / Autorouting | Pusher | Trunking | Composition Fan-out | Testpoints | Radial | Spiral Vias | Autorouting Costs | Grids |
Fan-out Process
1: Simple Fan-out 2 |:| Autorouter Fan-out
Fan-out Settings
Simple Fan-out Autorouter Fan-out
Direction Outwards E| Via Position
First Length
- |
Via Properties |
Gridded [
- -]
ViaName  |Circle 20/10(via) [=] Second Length
1 (Top Elec) |Z|
Layer Pair
11 (Bottom Elec) |Z|
Spiral Vias Disallow |Z|
() Minimum Spacing
@ Absolute First Length |0.7
() Incrementsl | Second Length (0.7
Description: Always Generate Auto
’ Open... ] ’ Save As... ] [ QK ] ’ Cancel ] ’ Help ]

8. Select Configure>Routing Setup->[Manual/Autorouting] tab and change the Width from

Necked to Typed and enter a value 0.157 mm.

Note: If your Units are set to Thou., as indicated at the bottom of the Place & Route Editor window,
double click on the unit shown and change it to Millimetres with 3 decimals for precision. Suggested
Routing and Via grid for mm should be 0.1. See Routing Options dialog [Grids] tab.

9. Select Routing>Fan-out>Perform Fanout in
the menu bar and click to frame an area around
the component U4 (bga64) or just a number of

pads.

Outwards Inwards

%% %% *¢% o

N b AR A
ARSI S ool
ooo:rooo: :.:.:.:o‘:‘::
[ B BN BN BN BN BN NN J o0 000 000
[ N N J [ N N N ....’....
..”‘..Q... [ ] ‘....%..

113

[5] Fan-out Report E'E'@

Fanning out 26 pins

BEGL component U4, 26 pins
Fan—out attempting 26 pins...
Simple fan-out routed 26 pins

Completed

| 100%

[ Save As... H Print... l

(HTML Fan-out report dialog)
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If you would like to change the direction of the fanned out traces  Fan-out Settings
from Outwards to Inwards, select Configure> Routing Setup

[Fan-out] tab and change the direction from Outwards to | “mPeFamest | Auterouter Fan-out
InwardS. Direction QOutwards |
File -
Select the [OK] button on the menu and Undo the previous Fan Exit
t
Out. Via Properties | Qutwards
N —
Select Routing->Fan-out->Perform Fan out #% in the menu Y] Gridded |NE ]
bar and click to frame an area around the component U4 (bga64) ViaMame  |CisE
or just a number of pads. This time the pattern should be :
opposite.

10.When you are happy with the Fan-out you can save it for reuse, by selecting

Routing->Fan-out->Save ﬁp(Iocated on the Fan-out tool bar) and click to frame an
area around the created Fan-out, so you can re-use it within other designs. Save the

Fan-out as ‘bga64.fpt’.
Zoom-in on component U4 and Unroute “+| the created Fan-out.

11. Select Configure=>Routing Setup [Fan-out] tab and change the direction to File. Click the
file browse button and open the file bga64.fpt.

Fan-out Settings
["5] Select Fanout Template File @
Simple Fan-out Autorouter Fan-out — . E— |
ool | . € DesignC3_C5 » pch » router - |&,|| Search router o
Direction |File Izl Organize v New folder =~ 0 @
B b router [BGAG4. fpt ' Favorites *  Name Date modified Type
Ml Desktop 7] BGAGS fpt 2/26/2014 3:37PM  FPT File
Viia Properties & Downloads
= Recent Places
V| Gridded
Via Mame |Cirde 20/10(via) @ Libraries
j Documents
-, Music
| Pictures
2 videos
M Computer ad]| 1 %
File name: BGAG4.fpt - |*.fpt v|
[ Open |v] | Cancel |

Select the [OK] button on the Routing Setup dialog.

Undo the previous fan out.
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12. Select Routing—>Fan-out—>Perform Fan out % in the menu bar and click to frame an area
around the component U4 (bga64) or just a number of pads. This time the pattern will come

from the fan out file.

Tip: Once a design is fully “fanned out” the entire design can be saved to one fan out file. Each
components’ reference shapes’ fanned out pin data will be saved. If the design ever needed to
be rerouted using a different placement, the fan outs can easily be restored.

13. Select the Configure=>Routing
Setup [Fan-out] tab.

Set Direction to Exit.

Set Via Position to Minimum
Spacing.

Set Via Name to Circle 20/10(via).

Set Layer pair as shown.

14. Select Routing>Fan-out->Perform Fan-out or click the icon *®
located on the Fan-out tool bar and frame an area around the

component U3.

H Routing Setup

[ s

| Manual / Autorouting I Pusher | Trunking Compasition Fan-out | Testpoints I Radial I Spiral vias | Aute| 1

Fan-out Process

1 Simple Fan-out

Fan-out Settings

2 |:| Autorouter Fan-out

Simple Fan -outJ_ Autorouter Fan-out
- o
I Direction |Exit EI Via Position
-— e -
SMD to Via Spadng
-
Via Properties I
[¥] Gridded 1
_—ee o Ew o e = = .
| ViaName  |Circle 20/10(via) k
1 (Top Elec) E
1| e I
11 (Bottom Elec) I . J
e © Minimum Spacin
Spiral Vias Disallow
S -__-Aﬁube_ 4-'5:_5';:'
@ Incremental | Second Leng
Description: |Effort: 10, Via: Cirde 20/10(via), Layer Pair: 1-11, Lengths: 0.700 0.700 Always Generate Auto
o) o) [0

This option uses the default pin exit directions for the various pad
shapes as a guide to create the fan out entities.

This can be used on all SMD components to quickly and easily fan out

an entire design.

o8

15. For the next steps continue with your design or open DesighC4_CS.pcb in the Design Editor,
save it as DesignC4.PCB and then select Tools=2>PR Editor XR B,
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The Place & Route Editor XR will help you to complete your design step-by-step by using advanced
auto-route technologies. For instance; Trunk Routing will help you to complete data and address

lines easier.

What is Trunk Routing?

Trunk Routing introduces the concept of the
intelligent trunk object, allowing you to route
any given set of signals in an intuitive manner

and with as little effort as possible.

Track n Trurk

/ Trurk Via Pattern

N

Via in Trunk

/ Trurk Path

Trurk End

Trunk Segment

Trunk Corner/

Thrk Contast——

Trunk System

16. Selecting which connections are to be Trunk Routed.

on one of the pads as marked by the bus marker,
before selecting Manual Route -

Note: All pads as marked will
highlighted.

116

€ Busses of data and address lines can be pre-designated
in a schematic design (as done in DesignC) and transferred
to PCB and Place & Route Editor XR. A named bus (trunk)
can be selected by its’ bus marker.

Zoom in on the bus marker. Select Manual Route ' * and
(Shift + Click) on the round marker. This will start the action.

%

"k"'lm

Alternatively you
can double click

N

—

be selected and

If bus signals have not been defined in the schematic, no bus
marker will be visible. Alternatively you can drag a multiple
selection around a set of pins or connection wires before

selecting Manual Route "+ to start Trunk Routing.
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17. Before starting any trunk routing we advise you to check the Trunking Options located in the
Configure=>Routing Setup [Trunking] tab.

5 Routing Setup II‘
| Manual / Autorouting | Pusher Trunking | Compositon | Fan-out | Testpoints | Radial | spiralvias | Autc « |
Automatic End Routing Routing
Small Trunks Large Trunks (7] Automatically Minimize
|¥| Continuous MoreThan 2 Signals Crossed-connections
Dynamic Ends Only 7] Continuous

Dynamic Ends Only Default Corner Style

Use Routing Angle E]

Via Pattern Style
Method: Method: Box E]
Use Routing Angle E Use Routing Angle E] Allow Same Net Errors
Distance From Target: Distance From Target:
Medium E] Medium E] Width Change Style
Use Routing Angle B
Guides
) = Width
V| Active Snapping ¥/ Single Click Finish On Snap Line
Snap Distance  Medium E] Bus Marker Size |Medium B ® Necked Optimal
Snap Axis Length Medium E] Optimal Intra-trunk Spacding
Description: V| Always Generate
Open... } | Save As... | [ OK ] { Cancel \ [ Help |

Simple Manual Routing of a Trunk on a Single Layer

In order to aid routing, snap axes and trunk-end routing areas will be drawn on the canvas around
each of the target sets of pins for the trunk. You will see Twist Arrows drawn on the canvas
showing the best entry angle for the trunk to the target pins, this allows minimization of
connections crossed at each end. You will also notice that you have a Gather Point for the trunk
that is now dynamic on the end of your cursor. The Gather Point defines the start for the trunk
where all of the parallel tracks will be considered as a single object.

18. To start routing the trunk you can place the Gather Point by clicking the left mouse button in
the position that you want to start routing the trunk from. Trunk segments are now introduced
towards the cursor position as you move the mouse on the canvas. Use the left mouse button
to confirm trunk segments that you have added. A corner can be added by changing direction
of movement of the cursor after a left mouse click.

Note: There are different styles of corners that can be added during trunk routing. This can be
changed by using the Right Mouse Context Sensitive menu.

t ZURKEN


http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar

™

When you have added the required trunk path, it is possible to finish trunk routing in several ways:
e The 'Escape' key can be used in order to finish trunk routing at the last added corner
position or using the Right Mouse Context Sensitive menu Cancel option.

o With the ‘Single Click Finish on Snap Line’ option selected on the Trunking Options
dialog, a single click when positioned over a snap axis will also finish the trunk. Remember
to select Configure - Routing Setup =>[Trunking] tab in the menu bar.

It is also possible to restart the Trunk Router on a previously added trunk. This can be easily
done by selecting the manual routing icon ' * and then picking the trunk on the canvas, or

selecting the manual routing icon " with the trunk item already selected *
Note: Try also the ‘Backspace’ key (remove previous Item).

During routing of a trunk, the trunk contents will dynamically reorder to maintain the least number
of crossed connections at each of the ends. This is done to give the best routing pattern for each
end. This option can be configured using the Trunking Options dialog Minimise Crossed
Connection setting.

E;] 19. Adding Vias while Trunk Routing

To place a trunk via pattern while using the trunk router, you can double click the left mouse
button or choose a different layer using the Layer option on the Right Mouse Context Sensitive
menu. It is also possible to change the trunk via pattern style to a number of predefined styles
using the Right Mouse Context Sensitive menu during trunk routing or by pressing the 'Tab' key
in order to cycle through the predefined trunk via patterns.

E;] 20. Manual Reordering of Trunks and Via Patterns

It is possible to reorder the contents of a trunk manually by select a single track segment inside
the trunk. i.e. Hold down the ‘Shift’ key and click the left mouse button to select a track. Choose
one from the selection list. Hold down the <L.M.B.> and drag the track segment with in the trunk
and watch how the selected segment appears to move from position to position. It is possible to
switch to one of the other items by pressing the 'Tab' key. Each time the 'Tab' key is pressed the
next segment closest to the cursor will be outlined. You can then drag this track to another
position inside the trunk.

21. Manual Trunk End Routing

You can use the Manual and Activ-45 routers to interactively route the connections up to the end
of the trunk. During the routing process you can still re-order the trunk if necessary.

22. Automatic Trunk End Routing

While you are trunk routing, it is possible to automatically route the ends of a trunk using the trunk
end router. Routing will be attempted for all trunk ends that are inside a trunk end routing target

area. Select Configure>Routing Setup->[Trunking] tab and ensure the settings are equal to
the example shown below.
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5] Routing Setup @

Manual / Autorouting Pusher Trunking Composition Fan-out | Testpoints Radial Spiral Vias Aute 1 *

Automatic End Routing Routing
Small Trunks Large Trunks V| Automatically Minimize
| Continuous Mare Than |2 Signals Crossed-connections
Dynamic Ends Only 7| Continuous
| Dynamic Ends Only Default Corner Style

Use Routing Angle |Z|

Via Pattern Style
Method: Method: Box |Z|
Use Routing Andle |z| Use Routing Angle |Z| Allow Same Met Errors
Distance From Target: Distance From Target:
Medium |E| Medium IZ| Width Change Style
Use Routing Angle |Z|
Guides
Width
| Active Snapping /| Single Click Finish On Snap Line
Snap Distance Medium IZ| Bus Marker Size |Medium IZ| @ Necked Optimal
Snap Axis Length |Medium |Z| Optimal Intra-trunk Spacing
Description: | Always Generate Auto
Open... | | Save As... Ok l | Cancel | | Help

In some circumstances you may wish to decompose trunk objects that you have added to your
design into individual routes. For example, you may want to split a segment of a bus into routes
so that you can route the bus around an obstacle. To do this, select the trunk items that you wish
to decompose and then use the Decompose function on the <R.M.B.> menu.

Note: Once a trunk has been decomposed, it is not always possible to compose these items back
into trunks. If they have been modified beyond their closest spacings you can use the

°
°
®
*
®
®
o
®
°

@
»
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Trunk Routing, Manual and Activ-45 routers to interactively route the connections up to the end
and finish the board.

If you didn't manage to complete the trunk routing then exit the P.R.Editor XR without saving and
you will automatically return to the Design Editor and open DesignC5_CS.pcb and save it as
DesignC5.pch and continue.

23. Auto Routing

For the next exercise you should open DesignC6_CS.pcb and save it as DesignC6.pcb in the

Design Editor and go to the P.R.Editor XR by selecting [Tools] tab2>PR Editor XR B This
design is not routed since it will be auto routed.

Before starting any auto routing, change the [General] Routing Setup options (CTRL-T). Setting
them correctly is very important before any routing! Ensure the settings are the same as in the
example shown.

™4 Routing Setup 7[5
Manual [ Autorouting Pusher | Trunking Composition | Fan-out [ Testpoints | Radial | Spiral Vias | Autorouting Costs | Grids |
Options Angle Track
(V] Errors Allowed . 9 Straight
45 E || Angled Autorouting Style:
[] Allow Pin Swaps Curved
¥| On-line DRC Activ-45 ® Necked
Passes |10 EI [¥] Enable Activ-45 Width: ©) Optimal
Effort 10 7] iy ste: rul = Typed: |0.50800
Via Fixed Items
V] vias Allowed || Respect Fixed Fan-outs
Vias Under Single Layer Pads: Off E]
-:|0.000 Max Fan-out Length: [
Spiral Vias Disallow Respect Fixed Escape Routing
Post-Tool Tasks Equispace [V] Save Best Pass
| Auto Pour Priority according to:
| Auto Teardrop [] change Length With Equispace V] Completion -
| Number of Fails =
Freehand ] Number of Physical Errors
= e ’ ) ] Number of Vias
7] Enable Freehand || Equispace Whilst Refine Routing | 51 Mo sevabgr of Commente |
| Freehand Tid || Use the best pass as the final autorouting result
| Freehand Tidy Standard
Description: 7| Always Generate
open... | | savess... oK || concel |[ Hep |

Note: Although errors are allowed, you should first allow the router to make some errors. In
combination with Effort 10 the router will continue routing till no errors are left.
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24. Select Routing=>Autoroute 2 from the menu bar and drag an area around the whole board
outline or part of the board you would like to auto route. The auto router will stop automatically
once all connections have been routed. The routing might not be optimal, and therefore you
can run a Refine Routing Pass.

25. Select Routing—>Refine Routing 1 from the menu bar and drag an area around the whole
board outline or part of the board you would like to refine.

Note: As a result of the Refining Pass the number of vias and segments will be reduced.

26. Lastly, select the Mitre function located on the [Routing] menu and draw a frame around the
entire board outline. This will change the 90° angles to 45°.

Note: you can mitre layers individually by turning the layer visibility off for layers that you do not
wish to be modified.

If you didn't manage to complete the autorouting then exit the Place & Route Editor XR without
saving. You will automatically return to the Design Editor where you can open
DesignC7_CS.pcb, save it as DesignC7.PCB and then go to the P.R.Editor XR to for this step.

27. For In Circuit Test (ICT) purposes you can decide to automatically generate a testpoint on
every node (or as many as possible). Before starting any allocation of testpoints, select
Configure>Routing Setup->[Testpoints] tab and ensure the settings are equal to the
example. Do not forget to select ‘(Bottom Elec)’ in the Layers section option!
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4] Routing Setup

R ==

| Manual / Autorouting I Pusher I Trunking Compuosition Fan-out | Testpoints | Radial | Spiral Vias Autorouting Costs I Grids |
Usable Pads Layers
Use MName Type i Use Layer
1 [C] | Circle 20/10(via) Via 1 [] 1 (TopElec)
2 [O] | Circle 10(max) Surface Mount Pad 2 11 (Bottom Elec)
3 [O] | Circle10{min) Surface Mount Pad
4 Circle 47 (max) Surface Mount Pad
5 [O] | Circle 47(min) Surface Mount Pad
6 [] Rectanglel.3:1.2(min)@90000 | Surface Mount Pad
7 [C] Rectangle 24x74(max) Surface Mount Pad
& [7] | Rectangle 24x74(min) Surface Mount Pad
9 [] | Rectangle 74:24(max) Surface Mount Pad | |=
10 [7] | Rectangle 74x24(min) Surface Mount Pad
11 [ | bgabdr(max) Surface Mount Pad
12 [C]  bgaBdr(min) Surface Mount Pad
13 []  c0805r{max) Surface Mount Pad
14 [ | c0805r(min) Surface Mount Pad Pads for Added Testpoints
15 [7] | so28:56r(min)@90000 Surface Mount Pad Both Layers: |z|
16 [ | Circle 40/20(via) Through Hole Pad Top Layer: |Z|
17 [C] | Circle 55/28(via) Through Hole Pad
18 [ | Circle60/32fvia) Through Hole Pad | |  Bottom Layer: Circle 47(max) [~]
19 [ | Circle 75/40(via) Through Hole Pad Separation
20 [] Hole29MNPTH Through Hele Pad
71 [F1 |Hole 2.0 NPTH Through Hole Pad | 7|  Center to Center Distance: |0.300
Description: |Bottom Layer Pad: Cirde 47(max), Top Layer Pad: , Both Layer Pad: , Center to Center Distance: 0,300 Always Generate Auto
Open... l [ Save As... [ OK. ] l Cancel ] [ Help

The settings shown on the previous page will use the surface mount pad Circle 47 on the (max)
Bottom Elec layer for every net. The link to the demonstration video will show the results of also
including a through hole via as a usable test point option. Try the exercise both ways!

28. Now click on Select=>All from the menu bar or you may use <Ctrl+A>, and all will be selected.
Select Routing=>Testpoint=>Allocate # and the testpoints will be added automatically.
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29. Select Utilities>Reports2>Testpoints to create a testpoint report as in the example.

4] Testpoints [= ][O =]

Required Testpoint Requirement

Number Number Met On Grid Error  Mear Pad

Met Type Layer X Position Y Position

52 (Testpoint) Bottom 51.400 60,900
53 (Testpoint) Bottom 40,600 62900
5101 (Testpoint) Bottom 112,000 622,000
8113 (Testpoint) Bottom 107.000 #6.300
AD (Testpoint) Bottom 103.900 #8.300
Al (Testpoint) Bottom 104,000 83.600
A2 (Testpoint) Bottom 105,800 80,700
A3 (Testpoint) Bottom 102.700 20,000
A4 (Testpoint) Bottomn 105.000 78.400
A5 (Testpoint) Bottom 104,300 74,100
AG (Testpoint) Bottom 101,800 70,100
AT (Testpoint) Bottom 108,100 #3.500
AZ (Testpoint) Bottom 66,200 61.200
A9 (Testpoint) Bottom 84,200 55.100
A10 (Testpoint) Bottomn 109,900 59.900
A1l (Testpoint) Bottom 106,500 56.700

es Yes > 0,000 U1-2
es Yes = 0.000 Uz2-20
es Yes = 0.000 U3-20
Yes Yes = 0,000 R4-2
es Yes = 0,000 U4-a1
es Yes = 0,000 U4-B1
es Yes > 0,000 U4-C1
es Yes = 0.000 Ud-01
Yes Yes = 0,000 Ua-02
Yes Yes = 0,000 U4-42
es Yes = 0,000 U4-C2
es Yes > 0,000 U4-43
es Yes = 0.000 U1-39
Yes Yes = 0,000 U2-18
es Yes = 0,000 U3-17
Yes Yes = 0,000 U3-16

= e e Tl e e e T S R e S e S S S =
e = e T i e e = e R =R ST S =

s

m

-

[ Lock [ Close ] ’ Help

)

Now that you have finished the design, you can select File >Exit from the menu bar and
rebuild the results. If you didn't manage to finish the testpoint creation, just open

DesignC8_CS.pch, save it as DesignC8.pcb and then experiment to see the finished results.

RIF Import Options @

Import RIF Changes only

Group Trunks
[¥] Ei Grouped Trunks

Show thiz dialag on return from PREditor <F [HS] as
well az through File Impart/0ptions

[ ok [Cancel] [ Help ]
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Step 4 - Manufacturing Data for Design C

Batch
Process

Batch

Power Plane  [I] IPC-D-356 Report
Drill Drawing [%5] Check Plot
Artwork o
am M. C. Drill

Output

ODB++

ODB

Design
Reference

Reference

If you like, you can create the manufacturing data for this design by selecting [Manufacture] tab >
Batch Process. In the Batch Process window select [Open] 2 Manufacturing Output 6 Layer.ppf,

which you can find in the Self teach directory and click [START].

Check CADSTAR Place & Route Editor - Functionality Matrix on Zuken.com

Routing Matrix

Located in the Datasheets listing

124

ZURKEN


http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/cadstar
http://www.zuken.com/en/products/pcb-design/cadstar/resources
http://www.zuken.com/en/products/pcb-design/cadstar/resources
http://www.zuken.com/cadstar

™

Chapter 5 - Design D (Single Sided Board Design)

&
478 |

1N4148 3

f +H ° & Ohm

__ o Speaker

riN4148 2 23

I.i

Z2Nz985A

[,
o || E 2N3053 \

Transistor Audio Amp (50 mWw)

Information on Design D - Transistor Audio Amplifier

Design D is based on the same schematics as Design B (a little audio amplifier). But this time you will
create a SINGLE SIDED board and you will learn how to add jumpers on the fly. Typically, a jumper is
used to bridge across other routes, the jumpers discussed here are non-functional jumpers and do not

appear in the schematics. The sequence is the same as before.

Step 1 - Design D

E;] 1. Open DesignD_CS.scm and save it as DesignD.scm and transfer the schematic to PCB using
the Transfer to PCB process. Choose '1 layer 1.6mm.pcb' as PCB technology instead. This is
a default technology file that has already been prepared for you. Notice that, although you are
using the same library, the solder-pads are larger and that thicker track-widths and more spacing

has been defined.
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Step 2 - PCB Placement for Design D

You can now start to place and arrange the components on the PCB after the transfer. When creating
a single board design a good placement is highly important to avoid crosses in the connections, so take
your time. Don’t worry as you will be able in Place & Route Editor XR to add jumpers on the fly, just like
adding a via.

H=H 1. Check and/or change the Units & Grid (25 thou is preferred)

2. Change the default shape type to |Board

I’E:] 3. Draw a board outline (size 2000x1500 thou).

4. Arrange components around the Board Outline = (Watch How in the next step)

I’E:il 5. Manually place and fix the critical components inside the board outline using the non-modal
Item Properties panel. Cross-probe can be used if necessary.

Place VCC9V at X-position 150,0 and Y-position to 150,0
Place INPUTGND at X-position 150,0 and Y-position to 1050,0
Place INPUT at X-position 150,0 and Y-position to 1350,0
Place SPK at X-position 1850,0 and Y-position to 1350,0
Place SPKGND at X-position 1850,0 and Y-position to 1050,0

Eﬂ 6. Automatically place the other

components. If you didn't manage to me  Component  Net/Shape | Design
place the components, just open 4l |5 Defaults @ Drill Letters/Table ~
DesignD2_CS.pcb and save it as Slayers  ® Electrical Rules
DesignDZ.pCb Propellies 3 Materials D Origin ~

Settings

Design Properties
7. Before going to the routing environment
select the Properties dialog from the
[Design] tab and ensure Jumper support Design Size
is enabled on the [Design Options] tab. Mayimum Design Size: ~ 4138.4

_' Design Title | Design Options _

( Compress Net Names...

Legacy Constraint Management

Suppress Inner Layer Pads

V| Tidy Connections
By Option @) By [tem
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8. Also before going to the routing environment check out Library=>PCB Components. If you
expand the contents of the PCB.LIB (as shown below) you will see a sub folder for Jumpers.
There are already some pre-defined jumpers, which you will be able to select in Place & Route
Editor XR on the fly.

2] Library Manager @
Current Libram
Path: [E:'\LIserskF‘uinc\Zuken'\E.ﬁ.DST.ﬁ.H Express = =5Librany’, v]
Type: PCE Components
File Mame: pch.lib [ Browse. .. l [ Create... ]
[ Add Folder ] [ Rename Folder ] [ Delete Folder ] £{-- Logate
Edit =8 peblib | = JUMPERNFeado 8 016 | []Use Mapping file
= - 1:_? Jumpers & JUMPERMF-lead0.8 (1270) Add File. .
Lo il 8] Temporary Library | | JUMPERNF-lad0 8 [1524)
Delete  JUMPERMF-l2ad0.8 [1778]
T JUMPERMF-lead0.8 (2032) E——
& JUMPERNF-0803 (reflow_IPC
& JUMPERNF-0805 [reflow_IPC [~ Jigy Librany
2 JUMPERNF-1206 [reflow_IPC
o
Wersionz...
Select all FRIETR s
- -
(") Show subfolder contents 0 Selected From 2 Listed

@ Show selected folder anly

LCloze ] Help

9. Open the Place & Route Editor XR2000 by selecting Tools>PREditor XR.
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“=Cj Step 3 - PCB Routing for Design D

When transferring to the Standalone Place & Route | >pertOptiens C==
Editor XR a RIF Export Option window will be showed

automatically. Ensure that Write Jumpers from Library V] Adwszys Transfer Colaurs

is enabled.

[¥]Uze Fouting Grid as System Grid

[T]wiite Part Infarmation

Shiova thiz dialog on transfer to PRE ditar <R [H5] as
well az through File Ewport/Options

[ (1] ] [Eancell [ Help ]

1. Before starting any routing, check the Routing Setup options. Select Configure =»Routing
Setup [Manual/Autorouting] tab in the menu bar (or use CTRL-T). Ensure the settings are equal
to the example. If you don'’t like copper to be poured automatically disable it. If you don't like
routes to be pushed you can disable the Pusher or reduce the Effort in which case less routes
will be pushed aside.

] Routing Setup (2 |mEse)
Manual { Autorouting | Pusher | Trunking Compasition | Fan-out | Testpaints | Radial I Spiral Vias Autorouting Costs I Grids |

COptions Angle Track

[ Errors Allowed @ Straight

45 |Z| [ Angled Autorouting Style:

Allow Pin Swaps ) Curved

On-ine DRC Activ-45 @ Mecked

Passes |10 E [T] Enable Activ-45 width: ©) Optimal

Effort 10 =] nay styie: o © Typed: |20.0000

Via Fixed Items

Vias Allowed [] Respect Fixed Fan-outs

Vias Under Single Layer Pads: off |Z|

Enable Snap Vias Legal Distance: [0L0

Spiral Vias |Disallow [] Respect Fixed Escape Routing

Fost-Tool Tasks Equispace Save Best Pass

|:| Auto Pour Priority according to:

[T Auto Teardrop [ change Length With Equispace Completion o

[7] Mumber of Fails 3
Freehand [] Mumber of Physical Errors
; ; ) Mumber of Vias
[] Enable Freehand [C] Equispace Whilst Refine Routing g Mlinher nf Sanmante S
Freehand Tid [ use the best pass as the final autorouting result
=l v Standard
Description: |Passes: 10, Effort: 10, Angle: 45, Errors Allowed: Off, Pushing: On, Save Best Pass: On Always Generate Auto

Cpen... ] ’ Save As... [ oK l ’ Cancel ] ’ Help ]
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2. Click the [Layer {current layer}] selection
on the menu bar. Change the Current
Layer to Bottom Elec as shown to the
right >

Click [OK].

Note: 2 layers have been added to this
technology (Top Jumper and Bottom
Jumper)!

3. Manually route the net using the Item
focus mode between resistor R2 and
capacitor C2 as in the example on the
Bottom Elec layer.

In the next step you will add a jumper on
the fly by manually routing A LT
the net between transistor TR1 and
resistor R2 as shown in the example
below on the Bottom Elec layer.

4. Route to the location you want to add

:ﬂ Layer Settings @

Preset: El | On | | Off |
Layer Current Active Display Bias

1 (Tep Jumnper) v v Jumper

2 (Top Elec) v ] Y bias

——
B 4 (Bottom E|ec( 2 [ v X bias

5 (Bettom Jump... — = T4 7 Jumper

|- 0K | | Apply | | Close | | Help

LI (IR

the first pad of the jumper and double click, select Top Jumper.
Now move the cursor to the location you want to add the second

pad of the jumper. P.R.Editor XR will

show you a thin line

representing the pitch of the pre-defined jumpers depending on
the available space. Double click again and you will add the
jumper and you can continue routing. P.R.Editor XR will show you
only a list of pre-defined jumpers if more than one jumpers with
the same pitch have been defined in the library. It's as easy as

adding a via!

TrA@ELD
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5. Now route all the connections on Bottom Elec layer and insert jumpers if necessarily.

6. Once you have finished the design you can select File>Exit. All routing and jumpers will be back
annotated to the PCB Design. Running an ECO update won’t remove jumpers and the jumpers
will appear normally in the Part List and placement data.

If you didn't manage to complete the design, just open DesignD3_CS.pch, save it as
DesignD3.pcb and then experiment to have a look.

®
N/

7~
N

—o-

-

DesignD3 after Placement & Routing — your routing may be different.
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Step 4 - Manufacturing Data for Design D

At this stage, you can also create the manufacturing data (Gerber, N.C.Drill, Parts List, Placement data
etc.) for the manufacturing of the PCB (as you did for Design A) by selecting [Manufacture]tab—>
Batch Process. In the Batch Process window you select [Open] and use Manufacturing Output 2
Layer.ppf, which you can find in the User directory and click [START].

Use Description Pr.:'_i;‘zs

1 E Gerber Copper pattern Compenentside | Artwor
2 E Gerber Copper pattern GND layer Power

3 z Gerber Copper pattern Inner 3 Artwor
4 [/] | Gerber Copper pattern Inner 4 Artwor
5 |¥| | Gerber Copper pattern WVCC layer Power

(] z Gerber Copper pattern Solderside Artwor
7 V| | Gerber Solderresist Componentside Artwar
(i V| | Gerber Solderresist Solderside Artwar
9 V] | Gerber Sikscreen Componentside Artwar
10 E Gerber Solderpaste Componentside Artwor
11 z PDF Assembly Componentside Artwor
12 rtlisting Report

13 | & ntdata Report

14 [&] | Dril ed Through Holes) N.C. Dril
15 E Drilldata {Men-Plated Through Holes) N.C. Dril
16 E Layer Stack-up report Report

You can easily disable the rows that you do not wish to post-process. In this design, since it is a single
layer board, the layers that are to be generated are Bottom Elec, Top Solder Mask, Bottom Solder Mask
and Top Silkscreen (all in Extended Gerber RS274-X format). Other additional manufacturing data that
CADSTAR can generate which is necessary for manufacturing are Parts Lists, Placement Data and Drill
Data. All manufacturing data will be saved in the Output directory.

Alternatively you might want to produce an ODB++ output file. ODB++ is one of the most intelligent

CAD/CAM data exchange formats available today, capturing all CAD/EDA, assembly and PCB
fabrication knowledge in one single, unified database.
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Conclusion

After these five exercises you should now be more familiar with the basics of PCB design. In the near
future you may even be designing a more complex PCB using CADSTAR.

With this booklet, you have received a free copy of CADSTAR Express. CADSTAR Express provides a
number of features of the full CADSTAR version, only limited by the number of components (max 50)
and pads (max 300).

For further information on pricing or if you require any support during evaluation or prefer to receive a
detailed demonstration, please contact your local CADSTAR distributor:

Where to Buy CADSTAR

There are also other CADSTAR tools that help Schematic and PCB designers to create board layouts.
Check for more information on CADSTAR products:

www.zuken.com/cadstar

| hope to see you again when we talk about some of our other, more advanced products:
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